Mailman was working, then a (Gentoo) 'emerge -Davu system' update happened
the other day and looks like it broke mailman.

daevid portage-logs # ll *mailman*
-rw-r--r-- 1 root root 62662 Sep 7 11:34 3485-mailman-2.1.5-r4.log
-rw-r--r-- 1 root root 1105 Sep 7 11:34 3486-mailman-2.1.5-r4.log

Sep 12 12:16:19 [Mailman mail-wrapper] Group mismatch error. Mailman
expected the mail_wrapper script to be executed as group "mailman", but_the
system's mail server executed the mail script as_group "mail". Try tweaking
the mail server to run the_script as group "mailman", or re-run configure,
_providing the command line option `--with-mail-gid=mail'._
Sep 12 12:16:19 [exim] 2005-09-12 12:16:19 1EEtms-00021M-60 **
/usr/local/mailman/mail/mailman post rbc <rbc at daevid.com> R=system_aliases
T=address_pipe: Child process of address_pipe transport returned 2 from
command: /usr/local/mailman/mail/mailman

daevid bin # locate mail_wrapper
daevid bin # locate as_group

daevid portage-logs # ll /usr/local/mailman/mail/mailman
-rwxr-sr-x 1 mailman mailman 7768 Sep 7 11:34
/usr/local/mailman/mail/mailman

daevid bin # ll
total 372
drwxrwsr-x 2 mailman mailman 4096 Sep 7 11:34 .
drwxrwsr-x 20 mailman mailman 4096 Apr 4 13:52 ..
-rwxr-xr-x 1 mailman mailman 7612 Sep 7 11:34 add_members
-rwxr-xr-x 1 mailman mailman 5406 Sep 7 11:34 arch
-rw-r--r-- 1 mailman mailman 3748 Sep 7 11:34 auto
-rwxr-xr-x 1 mailman mailman 2559 Sep 7 11:34 b4b5-archfix
-rwxr-xr-x 1 mailman mailman 6130 Sep 7 11:34 change_pw
-rwxr-xr-x 1 mailman mailman 4264 Sep 7 11:34 check_db
-rwxr-xr-x 1 mailman mailman 12223 Sep 7 11:34 check_perms
-rwxr-xr-x 1 mailman mailman 6632 Sep 7 11:34 check_perms_grsecurity.py
-rwxr-xr-x 1 mailman mailman 5492 Sep 7 11:34 cleanarch
-rwxr-xr-x 1 mailman mailman 6409 Sep 7 11:34 clone_member
-rwxr-xr-x 1 mailman mailman 12326 Sep 7 11:34 config_list
-rwxr-xr-x 1 mailman mailman 1499 Sep 7 11:34 convert.py
-rwxr-xr-x 1 mailman mailman 3238 Sep 7 11:34 discard
-rwxr-xr-x 1 mailman mailman 4399 Sep 7 11:34 dumpdb
-rwxr-xr-x 1 mailman mailman 4951 Sep 7 11:34 find_member
-rwxr-xr-x 1 mailman mailman 2633 Sep 7 11:34 fix_url.py
-rw-r--r-- 1 mailman mailman 2497 Apr 4 13:52 fix_url.pyc
-rwxr-xr-x 1 mailman mailman 3097 Sep 7 11:34 genaliases
-rwxr-xr-x 1 mailman mailman 2815 Sep 7 11:34 inject
-rwxr-xr-x 1 mailman mailman 2561 Sep 7 11:34 list_admins
-rwxr-xr-x 1 mailman mailman 3329 Sep 7 11:34 list_lists
-rwxr-xr-x 1 mailman mailman 8316 Sep 7 11:34 list_members
-rwxr-xr-x 1 mailman mailman 3165 Sep 7 11:34 list_owners
-rwxr-xr-x 1 mailman mailman 21124 Sep 7 11:34 mailmanctl
-rw-r--r-- 1 mailman mailman 18995 Sep 7 11:34 majordomo2mailman.pl
-rw-r--r-- 1 mailman mailman 5951 Sep 7 11:34 mm-handler
-rw-r--r-- 1 mailman mailman 7048 Sep 7 11:34 mm-handler.readme
-rwxr-xr-x 1 mailman mailman 2989 Sep 7 11:34 mmsitepass
-rwxr-xr-x 1 mailman mailman 5530 Sep 7 11:34 msgfmt.py
-rwxr-xr-x 1 mailman mailman 7127 Sep 7 11:34 newlist
-rw-r--r-- 1 mailman mailman 2412 Sep 7 11:34 paths.py
-rw-r--r-- 1 root mailman 652 Sep 7 11:34 paths.pyc
-rwxr-xr-x 1 mailman mailman 4076 Sep 7 11:34 qmail-to-mailman.py
-rwxr-xr-x 1 mailman mailman 9196 Sep 7 11:34 qrunner
-rwxr-xr-x 1 mailman mailman 2957 Sep 7 11:34 rb-archfix
-rwxr-xr-x 1 mailman mailman 4699 Sep 7 11:34 remove_members
-rwxr-xr-x 1 mailman mailman 4256 Sep 7 11:34 rmlist
-rwxr-xr-x 1 mailman mailman 3463 Sep 7 11:34 rotatelogs.py
-rwxr-xr-x 1 mailman mailman 1346 Sep 7 11:34 show_qfiles
-rwxr-xr-x 1 mailman mailman 9664 Sep 7 11:34 sync_members
-rwxr-xr-x 1 mailman mailman 11999 Sep 7 11:34 transcheck
-rwxr-xr-x 1 mailman mailman 2286 Sep 7 11:34 unshunt
-rwxr-xr-x 1 mailman mailman 29648 Sep 7 11:34 update
-rwxr-xr-x 1 mailman mailman 963 Sep 7 11:34 version
-rwxr-xr-x 1 mailman mailman 8382 Sep 7 11:34 withlist

daevid portage-logs # more 3486-mailman-2.1.5-r4.log
No updates are necessary.
* Running `/usr/local/mailman/bin/check_perms -f` *
/usr/local/mailman/cgi-bin/admindb must be set-gid (fixing)
/usr/local/mailman/cgi-bin/admin must be set-gid (fixing)
/usr/local/mailman/cgi-bin/confirm must be set-gid (fixing)
/usr/local/mailman/cgi-bin/create must be set-gid (fixing)
/usr/local/mailman/cgi-bin/edithtml must be set-gid (fixing)
/usr/local/mailman/cgi-bin/listinfo must be set-gid (fixing)
/usr/local/mailman/cgi-bin/options must be set-gid (fixing)
/usr/local/mailman/cgi-bin/private must be set-gid (fixing)
/usr/local/mailman/cgi-bin/rmlist must be set-gid (fixing)
/usr/local/mailman/cgi-bin/roster must be set-gid (fixing)
/usr/local/mailman/cgi-bin/subscribe must be set-gid (fixing)
/usr/local/mailman/mail/mailman must be set-gid (fixing)
Problems found: 12
Re-run as mailman (or root) with -f flag to fix
*
* Please read /usr/share/doc/mailman-2.1.5-r4/README.gentoo.gz for
additional
* Setup information, mailman will NOT run unless you follow
* those instructions!
*

daevid portage-logs # /usr/local/mailman/bin/check_perms -f
No problems found

I read the README, but I've already been using mailman, it doesn't mention
anything about upgrading.

daevid bin # ./check_db
Nothing to do.

Search Discussions

  • Mark Sapiro at Sep 12, 2005 at 8:10 pm

    Daevid Vincent wrote:
    Sep 12 12:16:19 [Mailman mail-wrapper] Group mismatch error. Mailman
    expected the mail_wrapper script to be executed as group "mailman", but_the
    system's mail server executed the mail script as_group "mail". Try tweaking
    the mail server to run the_script as group "mailman", or re-run configure,
    _providing the command line option `--with-mail-gid=mail'._
    See http://www.python.org/cgi-bin/faqw-mm.py?req=show&file=faq06.016.htp

    --
    Mark Sapiro <msapiro at value.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Daevid Vincent at Sep 12, 2005 at 8:51 pm
    Thanks for the reply. I don't know why this would have broken/changed. I've
    been running mailman, so this was really just an upgrade. Same user/groups,
    lists, dirs, etc.

    The only 'USE' flag I have availabe to me is +apache2
    [ebuild R ] net-mail/mailman-2.1.5-r4 +apache2 5,611 kB

    Furthermore, it appears that the .ebuild has those --with flags mentioned in
    the FAQ.

    # more /usr/portage/net-mail/mailman/mailman-2.1.5-r4.ebuild
    ...
    src_compile() {
    econf \
    --prefix=${INSTALLDIR} \
    --with-mail-gid=${MAILGID} \
    --with-cgi-gid=${APACHEGID} \
    die "configure failed"
    make || die "make failed"
    }
    ...
    -----Original Message-----
    From: Mark Sapiro [mailto:msapiro at value.net]
    Sent: Monday, September 12, 2005 1:11 PM
    To: Daevid Vincent; mailman-users at python.org
    Subject: Re: [Mailman-Users] mailman stopped working after upgrade

    Daevid Vincent wrote:
    Sep 12 12:16:19 [Mailman mail-wrapper] Group mismatch error. Mailman
    expected the mail_wrapper script to be executed as group
    "mailman", but_the
    system's mail server executed the mail script as_group
    "mail". Try tweaking
    the mail server to run the_script as group "mailman", or
    re-run configure,
    _providing the command line option `--with-mail-gid=mail'._
    See
    http://www.python.org/cgi-bin/faqw-mm.py?req=show&file=faq06.016.htp

    --
    Mark Sapiro <msapiro at value.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Mark Sapiro at Sep 12, 2005 at 9:05 pm

    Daevid Vincent wrote:
    Furthermore, it appears that the .ebuild has those --with flags mentioned in
    the FAQ.

    # more /usr/portage/net-mail/mailman/mailman-2.1.5-r4.ebuild
    ...
    src_compile() {
    econf \
    --prefix=${INSTALLDIR} \
    --with-mail-gid=${MAILGID} \
    --with-cgi-gid=${APACHEGID} \
    die "configure failed"
    make || die "make failed"
    }
    ...

    Yes, it has the flags, but what is the value of the ${MAILGID}
    parameter? The error message you received says it's 'mailman' and
    should be 'mail'.

    Your original post says:
    daevid portage-logs # ll /usr/local/mailman/mail/mailman
    -rwxr-sr-x 1 mailman mailman 7768 Sep 7 11:34 /usr/local/mailman/mail/mailman
    Thus, the wrapper was recompiled with the upgrade on Sep 7 and that's
    when things quit working so this is the likely cause.

    --
    Mark Sapiro <msapiro at value.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Daevid Vincent at Sep 13, 2005 at 1:45 am

    Yes, it has the flags, but what is the value of the ${MAILGID}
    parameter? The error message you received says it's 'mailman' and
    should be 'mail'.

    Your original post says:
    daevid portage-logs # ll /usr/local/mailman/mail/mailman
    -rwxr-sr-x 1 mailman mailman 7768 Sep 7 11:34
    /usr/local/mailman/mail/mailman

    Thus, the wrapper was recompiled with the upgrade on Sep 7 and that's
    when things quit working so this is the likely cause.
    # id mail
    uid=8(mail) gid(mail) groups(mail),408(shadow)

    # id mailman
    uid(0(mailman) gid(0(mailman) groups(0(mailman),16(cron)

    # ls -l /usr/local/mailman/mail/mailman
    -rwxr-sr-x 1 mailman mailman 7768 Sep 12 15:47
    /usr/local/mailman/mail/mailman

    I tried to emerge mailman again today just incase that helped. Same results.

    daevid portage-logs # ll *mailman*
    -rw-r--r-- 1 root root 62662 Sep 7 11:34 3485-mailman-2.1.5-r4.log
    -rw-r--r-- 1 root root 1105 Sep 7 11:34 3486-mailman-2.1.5-r4.log
    -rw-r--r-- 1 root root 62663 Sep 12 15:47 3528-mailman-2.1.5-r4.log
    -rw-r--r-- 1 root root 1105 Sep 12 15:48 3529-mailman-2.1.5-r4.log
    From the .log file:
    checking for --with-permcheck... yes
    checking for --with-username... mailman
    checking for user name "mailman"... okay
    checking for --with-groupname... mailman
    checking for group name "mailman"... okay
    checking permissions on /usr/local/mailman... okay
    checking for mail wrapper group; i.e. --with-mail-gid... mailman
    checking for CGI wrapper group; i.e. --with-cgi-gid... apache

    I am using Exim as my MTA BTW:

    [ebuild R ] mail-mta/exim-4.50-r1 +X -dnsdb -exiscan -exiscan-acl +ipv6
    -ldap -lmtp -mailwrapper -mbox +mysql -nis +pam +perl -postgres -sasl +ssl
    -syslog +tcpd 1,401 kB

    But I don't believe that's changed since:

    daevid portage-logs # ll *exim*
    -rw-r--r-- 1 root root 23369 Jul 7 00:57 3190-exim-4.50-r1.log
    -rw-r--r-- 1 root root 242 Jul 7 00:57 3191-exim-4.50-r1.log
  • Daevid Vincent at Sep 13, 2005 at 1:54 am
    Mark said, "Yes, it has the flags, but what is the value of the ${MAILGID}
    parameter? The error message you received says it's 'mailman' and should be
    'mail'."

    And looking at the log, he seems to be correct:
    Sep 12 12:16:19 [Mailman mail-wrapper] Group mismatch error. Mailman
    expected the mail_wrapper script to be executed as group "mailman", but_the
    system's mail server executed the mail script as_group "mail". Try tweaking
    the mail server to run the_script as group "mailman", or re-run configure,
    _providing the command line option `--with-mail-gid=mail'._

    But the .ebuild script sets it to gid 280, shouldn't it be 8? why is that?
    Is that the problem? How can I fix that. Re-emerging doesn't let me change
    those .ebuild values. MD5 errors and such.

    APACHEGID="81"
    MAILGID="280"

    src_compile() {
    econf \
    --prefix=${INSTALLDIR} \
    --with-mail-gid=${MAILGID} \
    --with-cgi-gid=${APACHEGID} \
    die "configure failed"
    make || die "make failed"
    }

    # ll /etc/exim/exim.conf
    -rw-r--r-- 1 root root 29452 Apr 29 13:54 /etc/exim/exim.conf

    # User and group for Mailman, should match your --with-mail-gid
    # switch to Mailman's configure script.
    # Value is normally "mailman"
    MM_UID=mailman
    MM_GID=mailman

    So, these match what the comment says there, and what the .ebuild is doing.

    I'm so confused. *sigh*
  • Mark Sapiro at Sep 13, 2005 at 2:58 am

    Daevid Vincent wrote:
    Mark said, "Yes, it has the flags, but what is the value of the ${MAILGID}
    parameter? The error message you received says it's 'mailman' and should be
    'mail'."

    And looking at the log, he seems to be correct:
    Sep 12 12:16:19 [Mailman mail-wrapper] Group mismatch error. Mailman
    expected the mail_wrapper script to be executed as group "mailman", but_the
    system's mail server executed the mail script as_group "mail". Try tweaking
    the mail server to run the_script as group "mailman", or re-run configure,
    _providing the command line option `--with-mail-gid=mail'._

    But the .ebuild script sets it to gid 280, shouldn't it be 8? why is that?
    Is that the problem? How can I fix that. Re-emerging doesn't let me change
    those .ebuild values. MD5 errors and such.

    APACHEGID="81"
    MAILGID="280"

    src_compile() {
    econf \
    --prefix=${INSTALLDIR} \
    --with-mail-gid=${MAILGID} \
    --with-cgi-gid=${APACHEGID} \
    die "configure failed"
    make || die "make failed"
    }

    # ll /etc/exim/exim.conf
    -rw-r--r-- 1 root root 29452 Apr 29 13:54 /etc/exim/exim.conf

    # User and group for Mailman, should match your --with-mail-gid
    # switch to Mailman's configure script.
    # Value is normally "mailman"
    MM_UID=mailman
    MM_GID=mailman

    So, these match what the comment says there, and what the .ebuild is doing.

    I'm so confused. *sigh*

    As well you should be at this point. The wrapper is telling you that it
    expects to be executed as group 'mailman', and it looks from what
    you've presented that it was in fact built that way. It also seems you
    can't change it in your update package.

    The wrapper also complains that it is not being executed as group
    'mailman', but rather as group 'mail'. This is the confusing part
    because it seems from the above that you are telling Exim to invoke
    the wrapper as group 'mailman' yet the wrapper is telling you it is
    being invoked as group 'mail'. I would look carefully at the Exim
    configuration to be sure that

    MM_UID=mailman
    MM_GID=mailman

    are in the right place and are not being overridden somewhere else.

    --
    Mark Sapiro <msapiro at value.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • John W. Baxter at Sep 13, 2005 at 5:22 pm

    On 9/12/05 7:58 PM, "Mark Sapiro" wrote:

    The wrapper is telling you that it
    expects to be executed as group 'mailman', and it looks from what
    you've presented that it was in fact built that way. It also seems you
    can't change it in your update package.

    The wrapper also complains that it is not being executed as group
    'mailman', but rather as group 'mail'. This is the confusing part
    because it seems from the above that you are telling Exim to invoke
    the wrapper as group 'mailman' yet the wrapper is telling you it is
    being invoked as group 'mail'. I would look carefully at the Exim
    configuration to be sure that

    MM_UID=mailman
    MM_GID=mailman

    are in the right place and are not being overridden somewhere else.
    Has Exim lost its setuid bit (and/or its root ownership) in the upgrade?

    --John
  • Daevid Vincent at Sep 13, 2005 at 6:33 pm

    -----Original Message-----
    From: John W. Baxter

    Has Exim lost its setuid bit (and/or its root ownership) in
    the upgrade?
    Thanks for the suggestion John, but the perms look correct. Also, other
    email works fine (incoming/outgoing). It's only mailman...

    daevid ~ # which exim
    /usr/sbin/exim

    daevid ~ # ll /usr/sbin/exim
    -rws--x--x 1 root root 830012 Jul 7 00:57 /usr/sbin/exim
  • John Dennis at Sep 13, 2005 at 7:17 pm

    On Tue, 2005-09-13 at 11:33 -0700, Daevid Vincent wrote:
    -----Original Message-----
    From: John W. Baxter

    Has Exim lost its setuid bit (and/or its root ownership) in
    the upgrade?
    Thanks for the suggestion John, but the perms look correct. Also, other
    email works fine (incoming/outgoing). It's only mailman...

    daevid ~ # which exim
    /usr/sbin/exim

    daevid ~ # ll /usr/sbin/exim
    -rws--x--x 1 root root 830012 Jul 7 00:57 /usr/sbin/exim
    I doubt it can just be mailman. It's failing in the mail wrapper which
    calls getgid() to get the group its being executed as. Mailman is simply
    reporting the facts, which is it is not being executed as the group it
    was intended to be executed as. In your configuration it is exim that is
    executing mailman wrapper, thus it is exim that needs looking at. Also,
    please note the error concerns group id not the user id. The error
    reported says exim executed the mail wrapper as the group "mail" when it
    expected it to be group "mailman". This means exim invoked the wrapper
    in the "mail" group. Sorry, I'm not an exim user so I can't tell you the
    particulars of exim, but I suspect there is an option when executing the
    mailman wrapper to elect the group in addition to the user (its the
    group thats important).

    Also, its not the setuid or setgid bit of exim that's relevant in this
    case, that says when that exim executable is run, ignore who is invoking
    me and run as this user or group instead. Which for exim when invoking
    mailman on your behalf is not relevant (and may not even be desirable),
    what is relevant is that when exim invokes the mailman wrapper it calls
    setgid("mailman") (I'm playing a little loose and fast here, but thats
    the idea in a nutshell). This probably only happens via an exim
    configuration parameter tied to mailman invocation.

    HTH,
    --
    John Dennis <jdennis at redhat.com>
  • Daevid Vincent at Sep 13, 2005 at 10:52 pm

    From: John W. Baxter
    daevid ~ # which exim
    /usr/sbin/exim

    daevid ~ # ll /usr/sbin/exim
    -rws--x--x 1 root root 830012 Jul 7 00:57 /usr/sbin/exim
    I doubt it can just be mailman.
    Well, exim hasn't changed since that date above, and the config hasn't
    changed for even longer, so I believe it *is* mailman and not exim:

    # ll
    total 80
    drwxr-xr-x 2 root root 4096 Jun 26 12:45 .
    drwxr-xr-x 77 root root 4096 Sep 13 03:14 ..
    -rw-r--r-- 1 root root 775 Jul 7 00:57 auth_conf.sub
    -rw-r--r-- 1 root root 29452 Apr 29 13:54 exim.conf
    -rw-r--r-- 1 root root 25931 Jul 7 00:57 exim.conf.dist
    -rw-r--r-- 1 root root 8120 Jul 7 00:57 system_filter.exim

    Mailman WAS working just fine until September 7th, when I updated it.

    # ll /usr/local/mailman/mail/mailman
    -rwxr-sr-x 1 mailman mailman 7768 Sep 7 11:34
    /usr/local/mailman/mail/mailman
  • Mark Sapiro at Sep 16, 2005 at 5:53 pm

    Daevid Vincent wrote:
    Well, exim hasn't changed since that date above, and the config hasn't
    changed for even longer, so I believe it *is* mailman and not exim:

    # ll
    total 80
    drwxr-xr-x 2 root root 4096 Jun 26 12:45 .
    drwxr-xr-x 77 root root 4096 Sep 13 03:14 ..
    -rw-r--r-- 1 root root 775 Jul 7 00:57 auth_conf.sub
    -rw-r--r-- 1 root root 29452 Apr 29 13:54 exim.conf
    -rw-r--r-- 1 root root 25931 Jul 7 00:57 exim.conf.dist
    -rw-r--r-- 1 root root 8120 Jul 7 00:57 system_filter.exim

    Mailman WAS working just fine until September 7th, when I updated it.

    # ll /usr/local/mailman/mail/mailman
    -rwxr-sr-x 1 mailman mailman 7768 Sep 7 11:34
    /usr/local/mailman/mail/mailman
    OK. It may well be Mailman. If so, the change is that prior to the
    update, the wrapper was expecting to be invoked as group 'mail' and
    now it is expecting to be invoked as group 'mailman', but you say you
    can't change configure to make the --with-mail-gid = 'mail' because
    "Re-emerging doesn't let me change those .ebuild values. MD5 errors
    and such."

    So it would seem you have two choices:
    1) change Exim so it does in fact invoke the wrapper as group mailman.

    or
    2) find the src directory and change the line in src/Makefile that says

    MAIL_GROUP= mailman

    to

    MAIL_GROUP= mail

    and remake the wrapper.

    Of course, 2) will only avoid the problem until the next update.

    --
    Mark Sapiro <msapiro at value.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Daevid Vincent at Sep 13, 2005 at 7:05 pm

    Mark said, "Yes, it has the flags, but what is the value of
    the ${MAILGID}
    parameter? The error message you received says it's
    'mailman' and should be
    'mail'."

    And looking at the log, he seems to be correct:
    Sep 12 12:16:19 [Mailman mail-wrapper] Group mismatch error. Mailman
    expected the mail_wrapper script to be executed as group
    "mailman", but_the
    system's mail server executed the mail script as_group
    "mail". Try tweaking
    the mail server to run the_script as group "mailman", or
    re-run configure,
    _providing the command line option `--with-mail-gid=mail'._

    But the .ebuild script sets it to gid 280, shouldn't it be
    8? why is that?
    Is that the problem? How can I fix that. Re-emerging doesn't
    let me change
    those .ebuild values. MD5 errors and such.

    APACHEGID="81"
    MAILGID="280"

    src_compile() {
    econf \
    --prefix=${INSTALLDIR} \
    --with-mail-gid=${MAILGID} \
    --with-cgi-gid=${APACHEGID} \
    die "configure failed"
    make || die "make failed"
    }

    # ll /etc/exim/exim.conf
    -rw-r--r-- 1 root root 29452 Apr 29 13:54 /etc/exim/exim.conf

    # User and group for Mailman, should match your --with-mail-gid
    # switch to Mailman's configure script.
    # Value is normally "mailman"
    MM_UID=mailman
    MM_GID=mailman

    So, these match what the comment says there, and what the
    .ebuild is doing.
    I'm so confused. *sigh*

    As well you should be at this point. The wrapper is telling
    you that it
    expects to be executed as group 'mailman', and it looks from what
    you've presented that it was in fact built that way. It also seems you
    can't change it in your update package.

    The wrapper also complains that it is not being executed as group
    'mailman', but rather as group 'mail'. This is the confusing part
    because it seems from the above that you are telling Exim to invoke
    the wrapper as group 'mailman' yet the wrapper is telling you it is
    being invoked as group 'mail'. I would look carefully at the Exim
    configuration to be sure that

    MM_UID=mailman
    MM_GID=mailman

    are in the right place and are not being overridden somewhere else.
    Below is portions of my /etc/exim/exim.conf. I deleted out any irrellevant
    parts, but I kept everything in the right order... I believe it's pretty
    much stock. (I don't know much about exim).
    # cat /etc/exim/exim.conf
    ######################################################################
    # Runtime configuration file for Exim #
    ######################################################################


    #
    # copied from http://www.exim.org/howto/mailman21.html#exconf
    #
    # Home dir for your Mailman installation -- aka Mailman's prefix
    directory.
    # By default this is set to "/usr/local/mailman"
    # On a Red Hat/Fedora system using the RPM use "/var/mailman"
    # On Debian using the deb package use "/var/lib/mailman"
    # This is normally the same as ~mailman
    MM_HOME=/usr/local/mailman
    #
    # User and group for Mailman, should match your --with-mail-gid
    # switch to Mailman's configure script.
    # Value is normally "mailman"
    MM_UID=mailman
    MM_GID=mailman
    #
    # Domains that your lists are in - colon separated list
    # you may wish to add these into local_domains as well
    domainlist
    mm_domains=daevid.com:rollinballzcrew.com:me-racing.com:marq.org
    #
    # -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
    #
    # These values are derived from the ones above and should not need
    # editing unless you have munged your mailman installation
    #
    # The path of the Mailman mail wrapper script
    MM_WRAP=MM_HOME/mail/mailman
    #
    # The path of the list config file (used as a required file when
    # verifying list addresses)
    MM_LISTCHK=MM_HOME/lists/${lc::$local_part}/config.pck


    ######################################################################
    # MAIN CONFIGURATION SETTINGS #
    ######################################################################

    exim_user = mail

    ######################################################################
    # ROUTERS CONFIGURATION #
    # Specifies how addresses are handled #
    ######################################################################
    # THE ORDER IN WHICH THE ROUTERS ARE DEFINED IS IMPORTANT! #
    # An address is passed to each router in turn until it is accepted. #
    ######################################################################

    mailman_router:
    driver = accept
    domains = +mm_domains
    require_files = MM_LISTCHK
    local_part_suffix_optional
    local_part_suffix = -admin : \
    -bounces : -bounces+* : \
    -confirm : -confirm+* : \
    -join : -leave : \
    -owner : -request : \
    -subscribe : -unsubscribe
    transport = mailman_transport

    procmail:
    debug_print = "R: procmail for $local_part@$domain"
    driver = accept
    check_local_user
    transport = procmail_pipe
    require_files = ${local_part}:${home}/.procmailrc:+/usr/bin/procmail
    no_verify
    no_expn

    userforward:
    driver = redirect
    check_local_user
    # local_part_suffix = +* : -*
    # local_part_suffix_optional
    file = $home/.forward
    # allow_filter
    no_verify
    no_expn
    check_ancestor
    file_transport = address_file
    pipe_transport = address_pipe
    reply_transport = address_reply

    localuser:
    driver = accept
    check_local_user
    # local_part_suffix = +* : -*
    # local_part_suffix_optional
    transport = local_delivery
    cannot_route_message = Unknown user


    ######################################################################
    # TRANSPORTS CONFIGURATION #
    ######################################################################
    # ORDER DOES NOT MATTER #
    # Only one appropriate transport is called for each delivery. #
    ######################################################################

    mailman_transport:
    driver = pipe
    command = MM_WRAP \
    '${if def:local_part_suffix \
    {${sg{$local_part_suffix}{-(\\w+)(\\+.*)?}{\$1}}} \
    {post}}' \
    $local_part
    current_directory = MM_HOME
    home_directory = MM_HOME
    user = MM_UID
    group = MM_GID

    # End of Exim configuration file
  • John Dennis at Sep 13, 2005 at 7:29 pm

    On Tue, 2005-09-13 at 12:05 -0700, Daevid Vincent wrote:
    # User and group for Mailman, should match your --with-mail-gid
    # switch to Mailman's configure script.
    # Value is normally "mailman"
    MM_UID=mailman
    MM_GID=mailman
    #
    # Domains that your lists are in - colon separated list
    # you may wish to add these into local_domains as well
    domainlist
    mm_domains=daevid.com:rollinballzcrew.com:me-racing.com:marq.org
    #
    # -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
    #
    # These values are derived from the ones above and should not need
    # editing unless you have munged your mailman installation
    #
    # The path of the Mailman mail wrapper script
    MM_WRAP=MM_HOME/mail/mailman
    Caveat: I don't know exim! But the above does suggest to me that when it
    invokes MM_WRAP=MM_HOME/mail/mailman will do it as uid=mailman,
    gid=mailman (because it calls setgid(mailman), is exim running with root
    privileges? it can't change the group if its not). BUT the mailman
    wrapper is telling you that is not what is happening, its being executed
    as group mail.
    ######################################################################
    # MAIN CONFIGURATION SETTINGS #
    ######################################################################

    exim_user = mail
    hmm... very suspicious, looks like this is what is being picked up as
    the execution context.


    --
    John Dennis <jdennis at redhat.com>

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedSep 12, '05 at 7:34p
activeSep 16, '05 at 5:53p
posts14
users4
websitelist.org

People

Translate

site design / logo © 2022 Grokbase