FAQ
I'm having a problem with the mailman (2.1.5) configuration.

In our setup, we are utilizing an external proxy to serve the
connections via an internal host. Therefore, the mailman configuration
must reflect the external hostname for it to work properly.

I've set up in the mm_cfg.py:

DEFAULT_EMAIL_HOST = 'externalhost.com'
DEFAULT_URL_HOST = 'www.externalhost.com'
add_virtualhost(DEFAULT_URL_HOST, DEFAULT_EMAIL_HOST)


as well as the ServerName in httpd.conf for www.externalhost.com.

Yet, still, the URLs in the resulting admin page from mailman have:

http://the.internalhost.name.com/path/to/mailman/admin/listname


I'm stumped. I tried using DEFAULT_HOST_NAME in mm_cfg.py to override
this, to no avail.

Anyone know what's wrong?


Thanks.

Search Discussions

  • Poster at Jul 18, 2005 at 8:33 pm

    Forrest Aldrich said:
    I'm having a problem with the mailman (2.1.5) configuration.

    In our setup, we are utilizing an external proxy to serve the
    connections via an internal host. Therefore, the mailman
    configuration
    must reflect the external hostname for it to work properly.

    I've set up in the mm_cfg.py:

    DEFAULT_EMAIL_HOST = 'externalhost.com'
    DEFAULT_URL_HOST = 'www.externalhost.com'
    add_virtualhost(DEFAULT_URL_HOST, DEFAULT_EMAIL_HOST)
    Hmm. Are you using virtual hosts?

    ~Poster
  • Forrest Aldrich at Jul 18, 2005 at 8:45 pm
    No, not using virtual hosts.... should I?



    Poster wrote:
    Forrest Aldrich said:

    I'm having a problem with the mailman (2.1.5) configuration.

    In our setup, we are utilizing an external proxy to serve the
    connections via an internal host. Therefore, the mailman
    configuration
    must reflect the external hostname for it to work properly.

    I've set up in the mm_cfg.py:

    DEFAULT_EMAIL_HOST = 'externalhost.com'
    DEFAULT_URL_HOST = 'www.externalhost.com'
    add_virtualhost(DEFAULT_URL_HOST, DEFAULT_EMAIL_HOST)
    Hmm. Are you using virtual hosts?

    ~Poster

    ------------------------------------------------------
    Mailman-Users mailing list
    Mailman-Users at python.org
    http://mail.python.org/mailman/listinfo/mailman-users
    Mailman FAQ: http://www.python.org/cgi-bin/faqw-mm.py
    Searchable Archives: http://www.mail-archive.com/mailman-users%40python.org/
    Unsubscribe: http://mail.python.org/mailman/options/mailman-users/forrie%40forrie.com

    Security Policy: http://www.python.org/cgi-bin/faqw-mm.py?req=show&file=faq01.027.htp
  • Poster at Jul 19, 2005 at 1:10 am

    Forrest Aldrich said:
    No, not using virtual hosts.... should I?
    ONLY if you are actually sending out the list from a virtual host.
    (It's a monster pain that I wish I could have avoided, but no luck as
    I have to have virtually-hosted mailing lists). With the last line
    appearing, I wasn't sure if you had added anything else relating to
    them. :) As long as you don't fiddle with them elsewhere, then the

    add_virtualhost(DEFAULT_URL_HOST, DEFAULT_EMAIL_HOST)

    line will work.

    ~He who posts.
    Poster wrote:
    Forrest Aldrich said:

    I'm having a problem with the mailman (2.1.5) configuration.

    In our setup, we are utilizing an external proxy to serve the
    connections via an internal host. Therefore, the mailman
    configuration
    must reflect the external hostname for it to work properly.

    I've set up in the mm_cfg.py:

    DEFAULT_EMAIL_HOST = 'externalhost.com'
    DEFAULT_URL_HOST = 'www.externalhost.com'
    add_virtualhost(DEFAULT_URL_HOST, DEFAULT_EMAIL_HOST)
    Hmm. Are you using virtual hosts?

    ~Poster

    ------------------------------------------------------
    Mailman-Users mailing list
    Mailman-Users at python.org
    http://mail.python.org/mailman/listinfo/mailman-users
    Mailman FAQ: http://www.python.org/cgi-bin/faqw-mm.py
    Searchable Archives:
    http://www.mail-archive.com/mailman-users%40python.org/
    Unsubscribe:
    http://mail.python.org/mailman/options/mailman-users/forrie%40forrie.com

    Security Policy:
    http://www.python.org/cgi-bin/faqw-mm.py?req=show&file=faq01.027.htp
    ------------------------------------------------------
    Mailman-Users mailing list
    Mailman-Users at python.org
    http://mail.python.org/mailman/listinfo/mailman-users
    Mailman FAQ: http://www.python.org/cgi-bin/faqw-mm.py
    Searchable Archives:
    http://www.mail-archive.com/mailman-users%40python.org/
    Unsubscribe:
    http://mail.python.org/mailman/options/mailman-users/poster%40aurora.cotse.net

    Security Policy:
    http://www.python.org/cgi-bin/faqw-mm.py?req=show&file=faq01.027.htp

    ++++++++++++++++++++++++++++++++++++++
    + www.intaligo.com/mt +
    + Professional Editing/Web Design +
    + www.intaligo.com/mt +
    ++++++++++++++++++++++++++++++++++++++
  • Jim Tittsler at Jul 18, 2005 at 11:30 pm

    On Jul 19, 2005, at 03:39, Forrest Aldrich wrote:

    I've set up in the mm_cfg.py:

    DEFAULT_EMAIL_HOST = 'externalhost.com'
    DEFAULT_URL_HOST = 'www.externalhost.com'
    add_virtualhost(DEFAULT_URL_HOST, DEFAULT_EMAIL_HOST)
    You may need to add:
    VIRTUAL_HOSTS.clear()
    just before the add_virtualhost() call.
    [...] Yet, still, the URLs in the resulting admin page from mailman
    have:
    Remember that to update URLs in existing lists, you need to run
    ~mailman/bin/fix_url.py (It is done with bin/withlist. Run
    fix_url.py with no arguments for details, or check the FAQ for more
    info on fix_url.py.)


    --
    Jim Tittsler http://www.OnJapan.net/ GPG: 0x01159DB6
    Python Starship http://Starship.Python.net/crew/jwt/
    Mailman IRC irc://irc.freenode.net/#mailman
  • Forrest Aldrich at Jul 18, 2005 at 11:42 pm
    I was just working on this, and I have:

    DEFAULT_EMAIL_HOST = 'mydomain.net'
    DEFAULT_URL_HOST = 'www.mydomain.net'
    VIRTUAL_HOSTS.clear()
    add_virtualhost(DEFAULT_URL_HOST, DEFAULT_EMAIL_HOST)


    And this does not work. I'm still seeing the old internal URL:

    http://host.internal.mydomain.net/blah/blah


    I'm not sure what is wrong - I searched the FAQ on this one and this
    seemed to be the right solution.

    To reiterate: our mailman server is on an internal network - the
    external website is configured to proxy http://www.ourdomain.com/mailman
    to the internal host. The URLs showing up on the admin page (for
    example) are still reflecting the internal host name, which is incorrect
    for what we're needing.


    Thanks.


    Jim Tittsler wrote:
    On Jul 19, 2005, at 03:39, Forrest Aldrich wrote:

    I've set up in the mm_cfg.py:

    DEFAULT_EMAIL_HOST = 'externalhost.com'
    DEFAULT_URL_HOST = 'www.externalhost.com'
    add_virtualhost(DEFAULT_URL_HOST, DEFAULT_EMAIL_HOST)

    You may need to add:
    VIRTUAL_HOSTS.clear()
    just before the add_virtualhost() call.
    [...] Yet, still, the URLs in the resulting admin page from mailman
    have:

    Remember that to update URLs in existing lists, you need to run
    ~mailman/bin/fix_url.py (It is done with bin/withlist. Run
    fix_url.py with no arguments for details, or check the FAQ for more
    info on fix_url.py.)
  • Mark Sapiro at Jul 19, 2005 at 4:51 pm

    Forrest Aldrich wrote:
    I was just working on this, and I have:

    DEFAULT_EMAIL_HOST = 'mydomain.net'
    DEFAULT_URL_HOST = 'www.mydomain.net'
    VIRTUAL_HOSTS.clear()
    add_virtualhost(DEFAULT_URL_HOST, DEFAULT_EMAIL_HOST)


    And this does not work. I'm still seeing the old internal URL:

    http://host.internal.mydomain.net/blah/blah
    Did you run fix_url as Jim said in his previous reply. This is
    necessary because the URL was stored as a list attribute when the list
    was created. (Also, are you restarting Mailman after mm_cfg.py
    changes?)
    I'm not sure what is wrong - I searched the FAQ on this one and this
    seemed to be the right solution.

    FAQ 4.29 covers this although the fix_url part is somewhat buried.


    Jim Tittsler wrote:
    <snip>
    Remember that to update URLs in existing lists, you need to run
    ~mailman/bin/fix_url.py (It is done with bin/withlist. Run
    fix_url.py with no arguments for details, or check the FAQ for more
    info on fix_url.py.)

    --
    Mark Sapiro <msapiro at value.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedJul 18, '05 at 6:39p
activeJul 19, '05 at 4:51p
posts7
users4
websitelist.org

People

Translate

site design / logo © 2022 Grokbase