FAQ
Hi all,

I was wondering if anyone could help me figure out this problem.

When I go to my web admin page for mailman, the page is just blank and
nothing apepars in my log files.
site is:

http://www.commoncents.net.au/cgi-bin/admin/test/

Any help is appreciated.

Regards,

Rabbie Zalaf
PC / Network Consultant
Common Cents Solutions
www.commoncents.net.au

-----BEGIN GEEK CODE BLOCK-----
VERSION: 3.1
GIT d++ s:>s-:- a23 C++++ L U+++
P+ L+++>$L+++++ E--- W+++ w-- M--
t+++ G++
-----END GEEK CODE BLOCK-----

Search Discussions

  • Mark Sapiro at Mar 22, 2005 at 5:02 pm

    Rabbie Zalaf wrote:
    When I go to my web admin page for mailman, the page is just blank and
    nothing apepars in my log files.
    site is:

    http://www.commoncents.net.au/cgi-bin/admin/test/
    If I go there I get a "Not Found" error, not a blank page.

    See http://www.list.org/mailman-install/node10.html for information on
    setting up your web server.

    --
    Mark Sapiro <msapiro at value.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Rabbie Zalaf at Mar 22, 2005 at 8:04 pm
    Actually,

    I meant:

    http://www.commoncents.net.au/cgi-bin/mailman/admin/test/

    and I added

    ScriptAlias /cgi-bin/mailman /usr/lib/cgi-bin/mailman/

    And

    <Directory /usr/lib/cgi-bin/mailman>
    Options ExecCGI
    </Directory>

    And its still blank.

    and
    Jim Tittsler said:
    On Mar 22, 2005, at 06:50, Rabbie Zalaf wrote:

    When I go to my web admin page for mailman, the page is just blank and
    nothing apepars in my log files.
    site is:

    http://www.commoncents.net.au/cgi-bin/admin/test/
    Don't you mean http://www.commoncents.net.au/mailman/admin/test/ ?

    Actually, neither works for me. Double check your Apache configuration
    (especially the ScriptAlias line).


    --
    Jim Tittsler http://www.OnJapan.net/ GPG: 0x01159DB6
    Python Starship http://Starship.Python.net/
    Ringo MUG Tokyo http://www.ringo.net/rss.html

    Rabbie Zalaf
    PC / Network Consultant
    Common Cents Solutions
    www.commoncents.net.au

    -----BEGIN GEEK CODE BLOCK-----
    VERSION: 3.1
    GIT d++ s:>s-:- a23 C++++ L U+++
    P+ L+++>$L+++++ E--- W+++ w-- M--
    t+++ G++
    -----END GEEK CODE BLOCK-----
  • Mark Sapiro at Mar 22, 2005 at 9:01 pm

    Rabbie Zalaf wrote:
    I meant:

    http://www.commoncents.net.au/cgi-bin/mailman/admin/test/

    and I added

    ScriptAlias /cgi-bin/mailman /usr/lib/cgi-bin/mailman/
    The more normal thing would be

    ScriptAlias /mailman/ /usr/lib/cgi-bin/mailman/

    for the Apache config and

    http://www.commoncents.net.au/mailman/admin/test/

    for the URL, but what you have should work.

    I tried all of

    http://www.commoncents.net.au/cgi-bin/mailman/admin/test
    http://www.commoncents.net.au/cgi-bin/mailman/admin
    http://www.commoncents.net.au/cgi-bin/mailman/listinfo/test
    http://www.commoncents.net.au/cgi-bin/mailman/listinfo

    The second and fourth look 'normal' except that the admin page lists
    'test' as a public list and the listinfo page says there are no public
    lists.

    As you note, the admin/test page is empty. The listinfo/test URL
    produces a

    Bug in Mailman version 2.0.11

    We're sorry, we hit a bug!

    page. I'm guessing you have group/permission problems. There should be
    errors in your Mailman 'error' log now.

    BTW, if as it seems this is a new installation, why are you installing
    2.0.11 instead of 2.1.5 or 2.1.6 beta?


    --
    Mark Sapiro <msapiro at value.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Jim Tittsler at Mar 23, 2005 at 12:58 am

    On Tue, Mar 22, 2005 at 01:01:26PM -0800, Mark Sapiro wrote:
    Rabbie Zalaf wrote:
    I meant:

    http://www.commoncents.net.au/cgi-bin/mailman/admin/test/

    and I added

    ScriptAlias /cgi-bin/mailman /usr/lib/cgi-bin/mailman/
    The more normal thing would be

    ScriptAlias /mailman/ /usr/lib/cgi-bin/mailman/

    for the Apache config and

    http://www.commoncents.net.au/mailman/admin/test/

    for the URL, but what you have should work.
    And note that if you do want the cgi-bin to be part of your URL
    for some reason, make sure it is included in DEFAULT_URL in
    your mm_cfg.py (which will be reflected in the web_page_url
    value for each list).
    BTW, if as it seems this is a new installation, why are you installing
    2.0.11 instead of 2.1.5 or 2.1.6 beta?
    I have to reiterate Mark's question... Are you *sure* you want
    to install a 3+ year old version? 2.1.5 contains numerous
    improvements. (And the 2.1.6beta contains fixes for some of
    the known problems in 2.1.5.)

    --
    Jim Tittsler http://www.OnJapan.net/ GPG: 0x01159DB6
    Python Starship http://Starship.Python.net/
    Ringo MUG Tokyo http://www.ringo.net/rss.html
  • Rabbie Zalaf at Mar 23, 2005 at 2:47 am
    Thanks Jim & Mark,

    I know it sounds like im some sicko with a Mailman 2.0 fetish..

    Its just that I installed mailman using woody's apt-get install mailman.

    Im just gonna scrap it and install the source from the python site.

    Thanks for all your help guy's.

    Rabbie.

    -----Original Message-----
    From: mailman-users-bounces+rabsmobile=commoncents.net.au at python.org
    [mailto:mailman-users-bounces+rabsmobile=commoncents.net.au at python.org] On
    Behalf Of Jim Tittsler
    Sent: Wednesday, March 23, 2005 11:59 AM
    To: rabbie at commoncents.net.au
    Cc: mailman-users at python.org
    Subject: Re: [Mailman-Users] Mailman admin page is blank.
    On Tue, Mar 22, 2005 at 01:01:26PM -0800, Mark Sapiro wrote:
    Rabbie Zalaf wrote:
    I meant:

    http://www.commoncents.net.au/cgi-bin/mailman/admin/test/

    and I added

    ScriptAlias /cgi-bin/mailman /usr/lib/cgi-bin/mailman/
    The more normal thing would be

    ScriptAlias /mailman/ /usr/lib/cgi-bin/mailman/

    for the Apache config and

    http://www.commoncents.net.au/mailman/admin/test/

    for the URL, but what you have should work.
    And note that if you do want the cgi-bin to be part of your URL
    for some reason, make sure it is included in DEFAULT_URL in
    your mm_cfg.py (which will be reflected in the web_page_url
    value for each list).
    BTW, if as it seems this is a new installation, why are you installing
    2.0.11 instead of 2.1.5 or 2.1.6 beta?
    I have to reiterate Mark's question... Are you *sure* you want
    to install a 3+ year old version? 2.1.5 contains numerous
    improvements. (And the 2.1.6beta contains fixes for some of
    the known problems in 2.1.5.)
  • John W. Baxter at Mar 23, 2005 at 3:17 am

    On 3/22/2005 18:47, "Rabbie Zalaf" wrote:

    Thanks Jim & Mark,

    I know it sounds like im some sicko with a Mailman 2.0 fetish..

    Its just that I installed mailman using woody's apt-get install mailman.

    Im just gonna scrap it and install the source from the python site.

    Thanks for all your help guy's.

    Rabbie.
    Although I haven't tried, you can probably find backports of something in
    the 2.1 series for your installation.

    However, anything much later and you'll also need to find a backport of a
    modern Python version.

    --John

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedMar 21, '05 at 9:50p
activeMar 23, '05 at 3:17a
posts7
users5
websitelist.org

People

Translate

site design / logo © 2022 Grokbase