FAQ
Hi all,

After installing mailman into an existing postfix virtual mailserver
setup, I have been trying to get postfix to deliver email to mailman,
but have had no luck so far.

All attempts to deliver mail locally get delivered via smtp instead -
which causes a mail loop and thus a bounce. Mailman never gets a look in.

Has anybody run into hassles like this before? I am stumped.

I inject a mail message like so:

/usr/sbin/sendmail -v xxx-announce at wired.co.za
Hello.
.

The log I get for this message is like so:

Mar 3 16:50:47 chandler postfix/pickup[24195]: A64D4923270: uid=0
from=<root>
Mar 3 16:50:47 chandler postfix/cleanup[24475]: A64D4923270:
message-id=<20050303225047.A64D4923270 at chandler.sharp.fm>
Mar 3 16:50:47 chandler postfix/qmgr[24196]: A64D4923270:
from=<root at chandler.sharp.fm>, size)5, nrcpt=1 (queue active)
Mar 3 16:50:47 chandler postfix/smtp[24476]: A64D4923270:
to=<xxx-announce at chandler.sharp.fm>, orig_to=<xxx-announce at wired.co.za>,
relay=none, delay=0, status=bounced (mail for chandler.sharp.fm loops back
to myself)

The postconf -n is like so:

[root at chandler mailman]# postconf -n
alias_database = hash:/etc/aliases
alias_maps = hash:/var/mailman/data/aliases
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
disable_vrfy_command = yes
home_mailbox = Maildir/
html_directory = /usr/share/doc/postfix-2.1.5-documentation/html
inet_interfaces = all
local_recipient_maps = hash:/var/mailman/data/aliases
local_transport = local:$myhostname
mail_owner = postfix
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
mydestination = $myhostname, localhost, localhost.$mydomain
mynetworks = 127.0.0.0/8
newaliases_path = /usr/bin/newaliases.postfix
owner_request_special = no
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.1.5-documentation/readme
recipient_delimiter = +
relay_clientcerts = ldap:relayclientcerts
sample_directory = /etc/postfix/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtp_tls_CAfile = /etc/postfix/certs/caCert.pem
smtp_tls_cert_file = /etc/postfix/certs/hostCert.pem
smtp_tls_key_file = /etc/postfix/certs/hostKey.pem
smtp_tls_per_site = ldap:tlspersite
smtpd_helo_required = yes
smtpd_recipient_restrictions = reject_non_fqdn_sender,
reject_non_fqdn_recipient, reject_unknown_sender_domain,
reject_unknown_recipient_domain, reject_unauth_pipelining,
permit_mynetworks, reject_unauth_destination,
reject_rbl_client dnsbl.njabl.org, reject_rbl_client
opm.blitzed.org, reject_rbl_client cbl.abuseat.org,
reject_rbl_client sbl.spamhaus.org, reject_rbl_client
dnsbl.sorbs.net, reject_rbl_client relays.ordb.org,
reject_rbl_client list.dsbl.org, reject_rbl_client
dynablock.easynet.nl, reject_rbl_client blackholes.easynet.nl,
reject_rbl_client proxies.blackholes.easynet.nl,
permit
smtpd_tls_CAfile = /etc/postfix/certs/caCert.pem
smtpd_tls_auth_only = yes
smtpd_tls_cert_file = /etc/postfix/certs/hostCert.pem
smtpd_tls_key_file = /etc/postfix/certs/hostKey.pem
smtpd_tls_loglevel = 2
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom
transport_maps = hash:/etc/postfix/transport, ldap:ldapremote,
ldap:ldaplocal, static:smtp:
unknown_local_recipient_reject_code = 450
virtual_alias_maps = hash:/var/mailman/data/virtual-mailman,
ldap:ldapforward, ldap:ldapalias
virtual_gid_maps = static:517
virtual_mailbox_base = /
virtual_mailbox_domains = ldap:acceptdomains
virtual_mailbox_limit = 0
virtual_mailbox_maps = ldap:ldapvirtual
virtual_minimum_uid = 500
virtual_transport = virtual
virtual_uid_maps = static:517

Does anyone have any ideas?

Regards,
Graham
--

Search Discussions

  • Brad Knowles at Mar 4, 2005 at 1:17 am

    At 1:49 AM +0200 2005-03-04, Graham Leggett wrote:

    Mar 3 16:50:47 chandler postfix/smtp[24476]: A64D4923270:
    to=<xxx-announce at chandler.sharp.fm>, orig_to=<xxx-announce at wired.co.za>,
    relay=none, delay=0, status=bounced (mail for chandler.sharp.fm loops back
    to myself)
    This is a postfix configuration problem. I would recommend
    checking the Postfix FAQ, and the archive of the postfix-users
    mailing list.

    --
    Brad Knowles, <brad at stop.mail-abuse.org>

    "Those who would give up essential Liberty, to purchase a little
    temporary Safety, deserve neither Liberty nor Safety."

    -- Benjamin Franklin (1706-1790), reply of the Pennsylvania
    Assembly to the Governor, November 11, 1755

    SAGE member since 1995. See <http://www.sage.org/> for more info.
  • Graham Leggett at Mar 4, 2005 at 7:44 am

    Brad Knowles said:

    This is a postfix configuration problem. I would recommend
    checking the Postfix FAQ, and the archive of the postfix-users
    mailing list.
    Already did to no avail, which is why I am now asking it here in case
    anyone here has ever run into this.

    Regards,
    Graham
    --
  • Brad Knowles at Mar 4, 2005 at 8:18 am

    At 9:44 AM +0200 2005-03-04, Graham Leggett wrote:

    This is a postfix configuration problem. I would recommend
    checking the Postfix FAQ, and the archive of the postfix-users
    mailing list.
    Already did to no avail, which is why I am now asking it here in case
    anyone here has ever run into this.
    A few seconds Googling for "postfix mail loops back to myself"
    turns up the page at <http://www.topology.org/linux/postfixloop.html>
    as the third link. Most of the other links that are returned are
    from the archive of the postfix-users mailing list.


    The issue is not that this is a common or uncommon problem. The
    issue is that this is a postfix problem, and the answer is easily
    found in the archives of their mailing list, as well as various other
    related pages.

    Moreover, a few seconds spent searching for the answer on your
    part means that those of us who have run into this problem before
    don't have to sit down and spend a lot of time to effectively
    re-invent the wheel in order to try to put together an explanation of
    the sort seen at <http://www.topology.org/linux/postfixloop.html>.

    --
    Brad Knowles, <brad at stop.mail-abuse.org>

    "Those who would give up essential Liberty, to purchase a little
    temporary Safety, deserve neither Liberty nor Safety."

    -- Benjamin Franklin (1706-1790), reply of the Pennsylvania
    Assembly to the Governor, November 11, 1755

    SAGE member since 1995. See <http://www.sage.org/> for more info.
  • Graham Leggett at Mar 4, 2005 at 11:05 am

    Brad Knowles said:

    A few seconds Googling for "postfix mail loops back to myself"
    turns up the page at <http://www.topology.org/linux/postfixloop.html>
    as the third link.
    A link which does not describe the problem I am having in the slightest.
    Moreover, a few seconds spent searching for the answer on your
    part means that those of us who have run into this problem before
    don't have to sit down and spend a lot of time to effectively
    re-invent the wheel in order to try to put together an explanation of
    the sort seen at <http://www.topology.org/linux/postfixloop.html>.
    I have spent _three full days_ trying to search for the answer to this
    problem, not a few seconds. I have googled forwards backwards and
    sideways, I have jacked up the logging, I now completely understand what
    Postfix is trying to do (it is delivering local mail via the smtp
    transport, no clue why) but I cannot find the solution and neither could
    anybody on the postfix list.

    Please do not assume that all mailing list posters are lazy or stupid, or
    that every problem out there is trivially answered by the third link down
    on Google. A few seconds of reading a post may cause you to think the
    answer is trivial, but a few more seconds of reading it would have shown
    that the problem isn't that simple.

    As I said, I posted here in an effort to find out if anybody else has had
    a problem integrating mailman and postfix virtual mail config. If nobody
    can help me, then so be it, but I've had enough of a trying time with this
    problem over the last three days, I don't need flame bait piled on top of
    it.

    Regards,
    Graham
    --
  • Brad Knowles at Mar 4, 2005 at 2:36 pm

    At 1:05 PM +0200 2005-03-04, Graham Leggett wrote:

    Brad Knowles said:
    A few seconds Googling for "postfix mail loops back to myself"
    turns up the page at <http://www.topology.org/linux/postfixloop.html>
    as the third link.
    A link which does not describe the problem I am having in the slightest.
    Try re-reading it. I believe you will find that it does.
    I have spent _three full days_ trying to search for the answer to this
    problem, not a few seconds.
    I can understand your frustration, but taking it out on me isn't
    going to help you solve your problem any sooner.
    I have googled forwards backwards and
    sideways, I have jacked up the logging, I now completely understand what
    Postfix is trying to do (it is delivering local mail via the smtp
    transport, no clue why) but I cannot find the solution and neither could
    anybody on the postfix list.
    Try putting the fully qualified domain name in question into your
    $mydestination list. Postfix should then recognize the domain as
    local and not something to be delivered via SMTP. This is explained
    on the page above.

    However, the author of that page spent a lot of time putting
    together examples to make the description of the problem more
    concrete, so that he could better explain the problem, and better
    explain the solution.
    A few seconds of reading a post may cause you to think the
    answer is trivial, but a few more seconds of reading it would have shown
    that the problem isn't that simple.
    Having looked at your entire post yet once again, It sure looks
    that simple to me. You've got the following $mydestination defined:

    mydestination = $myhostname, localhost, localhost.$mydomain

    From looking at the log entries you quoted, I presume that your
    $hostname may be "chandler". I hope that you've got $mydomain set to
    "sharp.fm". However, you do not define $mydestination to include
    "$myhostname.$mydomain", although you do include "localhost" and
    "localhost.$mydomain".

    The fact that you might require $mydestination to include
    "$myhostname.$mydestination" should have been obvious by reading the
    documentation, and the page I quoted.
    As I said, I posted here in an effort to find out if anybody else has had
    a problem integrating mailman and postfix virtual mail config. If nobody
    can help me, then so be it, but I've had enough of a trying time with this
    problem over the last three days, I don't need flame bait piled on top of
    it.
    It is fundamentally *not* a problem with Mailman, or an
    integration issue between postfix or Mailman. If it was, I would
    have given you a lot more leeway.

    This is clearly a pure postfix problem. Even if I'm wrong in the
    solution that I recommend, I am quite certain that this is a pure
    postfix problem, and has absolutely nothing to do with Mailman.

    This is why I said:

    This is a postfix configuration problem. I would recommend
    checking the Postfix FAQ, and the archive of the postfix-users
    mailing list.

    I see nothing here that would be considered to be inflammatory.

    Your response was:

    Already did to no avail, which is why I am now asking it here
    in case anyone here has ever run into this.


    However, the problem is that this mailing list is intended for
    the support of Mailman, and a lot of people on the list do not use
    postfix. Asking us to support postfix as well as Mailman is not a
    good idea, and detracts from the main purpose of this list.

    You need to use the resources which were intended to support your
    non-Mailman problem, and not abuse us to support a program which is
    not our focus.

    And yes, although I understand your frustration, you are getting
    rather abusive now. You're not only abusing the list to support a
    program other than Mailman, you're being personally abusive towards
    me because I'm trying to get you to take the problem where it really
    belongs.


    To be honest, I should not have attempted to provide any kind of
    a solution for you. But at this point, I basically just want the
    abuse to stop.

    The next time someone asks us to answer postfix questions,
    they're going to get a lot less help than you have. That's a pity.

    --
    Brad Knowles, <brad at stop.mail-abuse.org>

    "Those who would give up essential Liberty, to purchase a little
    temporary Safety, deserve neither Liberty nor Safety."

    -- Benjamin Franklin (1706-1790), reply of the Pennsylvania
    Assembly to the Governor, November 11, 1755

    SAGE member since 1995. See <http://www.sage.org/> for more info.
  • Graham Leggett at Mar 4, 2005 at 5:17 pm

    Brad Knowles wrote:

    Try re-reading it. I believe you will find that it does.
    Having investigated exactly that issue three days ago and found it not
    to be the problem, I am quite confident that it does not.
    I can understand your frustration, but taking it out on me isn't
    going to help you solve your problem any sooner.
    Do you understand the impact of making a post like you did to the
    question? Those who are skimming mailing lists are not likely to read my
    post because they see it's already been replied to. And those who read
    your post will simply assume I was expecting the list to solve my
    problem without any effort on my part, making the possiblity of a reply
    even less likely. And now these posts will get archived and indexed by
    Google, and someone else will get the misleading advice in a search.
    Try putting the fully qualified domain name in question into your
    $mydestination list. Postfix should then recognize the domain as local
    and not something to be delivered via SMTP. This is explained on the
    page above.
    We have already, as I explained, ascertained that there is nothing
    whatsoever wrong with the mydestination setting. So far there looks like
    there is an issue with the transport_maps the pop toaster is using to
    implement mail server clustering that might have an impact on local
    delivery. When I am not about to board a plane, I am going to be looking
    at it further.
    Having looked at your entire post yet once again, It sure looks that
    simple to me. You've got the following $mydestination defined:

    mydestination = $myhostname, localhost, localhost.$mydomain

    From looking at the log entries you quoted, I presume that your
    $hostname may be "chandler". I hope that you've got $mydomain set to
    "sharp.fm". However, you do not define $mydestination to include
    "$myhostname.$mydomain", although you do include "localhost" and
    "localhost.$mydomain".
    Wrong. The hostname is "chandler.sharp.fm":

    [root at chandler root]# postconf myhostname
    myhostname = chandler.sharp.fm

    Regards,
    Graham
    --
  • Brad Knowles at Mar 4, 2005 at 6:50 pm

    At 7:17 PM +0200 2005-03-04, Graham Leggett wrote:

    Do you understand the impact of making a post like you did to the question?
    Do you realize that asking postfix questions on a mailing list
    that is not devoted to supporting postfix is not really a good idea?

    If you're not finding the answers to your postfix questions using
    non-postfix resources such as this mailing list, then I suggest you
    try using other resources which are more likely to be useful.

    --
    Brad Knowles, <brad at stop.mail-abuse.org>

    "Those who would give up essential Liberty, to purchase a little
    temporary Safety, deserve neither Liberty nor Safety."

    -- Benjamin Franklin (1706-1790), reply of the Pennsylvania
    Assembly to the Governor, November 11, 1755

    SAGE member since 1995. See <http://www.sage.org/> for more info.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedMar 3, '05 at 11:49p
activeMar 4, '05 at 6:50p
posts8
users2
websitelist.org

2 users in discussion

Graham Leggett: 4 posts Brad Knowles: 4 posts

People

Translate

site design / logo © 2022 Grokbase