FAQ
Hi,

I'm using Mailman 2.1.5 on a Debian Woody installation.

When I tell Mailman to receive my mails from a list in a daily digest I
receive this digest but the header of the digest mail does not contain a
Date line, i.e. the Mails are shown in my mail client with the date
January 1st 1970. How can this be fixed?

Thank you!

Torsten

Search Discussions

  • Mark Sapiro at Feb 6, 2005 at 4:29 pm

    Torsten Ehlers wrote:
    When I tell Mailman to receive my mails from a list in a daily digest I
    receive this digest but the header of the digest mail does not contain a
    Date line, i.e. the Mails are shown in my mail client with the date
    January 1st 1970. How can this be fixed?
    This will be fixed in the next release of 2.1.6. It didn't quite make
    2.1.6b2.

    See
    http://cvs.sourceforge.net/viewcvs.py/mailman/mailman/Mailman/Handlers/ToDigest.py?r1=2.22.2.10&r2=2.22.2.11&diff_format=u
    for a patch that can be applied to 2.1.5.

    --
    Mark Sapiro <msapiro at value.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan
  • Brad Knowles at Feb 6, 2005 at 6:23 pm

    At 11:35 AM +0100 2005-02-06, Torsten Ehlers wrote:

    When I tell Mailman to receive my mails from a list in a daily digest
    I receive this digest but the header of the digest mail does not contain
    a Date line, i.e. the Mails are shown in my mail client with the date
    January 1st 1970. How can this be fixed?
    Mailman 2.1.5 does not include a Date: header on the messages it
    sends out. Since this header is required by the SMTP RFCs, it is up
    to the MTA to put an appropriate Date: header onto the outgoing
    message. The server for your MTA must have an incorrectly set clock.

    I suggest that you have that machine configured to run "ntpd",
    suitably configured. There's some information at
    <http://ntp.isc.org/bin/view/Support/WebHome> to help you get this
    going.

    --
    Brad Knowles, <brad at stop.mail-abuse.org>

    "Those who would give up essential Liberty, to purchase a little
    temporary Safety, deserve neither Liberty nor Safety."

    -- Benjamin Franklin (1706-1790), reply of the Pennsylvania
    Assembly to the Governor, November 11, 1755

    SAGE member since 1995. See <http://www.sage.org/> for more info.
  • Jeff Groves at Feb 6, 2005 at 9:37 pm
    Brad:

    It seems to be worse than not having the date set. The MTA itself is behaving very badly by
    setting the sent date to 0 seconds since the January 1, 1970 (standard zero time in UNIX).

    The chances that ALL messages are dated January 1, 1970 because of a time synchronization
    problem are pretty slim, since machines don't default to much later dates than 1990 now-a-days.

    Whomever wrote that MTA did a poor job of handling a "no Date" header" situation.

    Jeff G.

    Brad Knowles wrote:
    At 11:35 AM +0100 2005-02-06, Torsten Ehlers wrote:

    When I tell Mailman to receive my mails from a list in a daily digest
    I receive this digest but the header of the digest mail does not contain
    a Date line, i.e. the Mails are shown in my mail client with the date
    January 1st 1970. How can this be fixed?

    Mailman 2.1.5 does not include a Date: header on the messages it
    sends out. Since this header is required by the SMTP RFCs, it is up to
    the MTA to put an appropriate Date: header onto the outgoing message.
    The server for your MTA must have an incorrectly set clock.

    I suggest that you have that machine configured to run "ntpd",
    suitably configured. There's some information at
    <http://ntp.isc.org/bin/view/Support/WebHome> to help you get this going.
    --
    Law of Procrastination:
    Procrastination avoids boredom; one never has
    the feeling that there is nothing important to do.
  • Torsten Ehlers at Feb 6, 2005 at 9:45 pm
    Hi,

    my MTA is qmail. The date of my machine is set correctly (I'm already
    using ntp, by the way). Other mails sent from this machine have the
    correct date.

    But I could fix the problem by using Mark's tip. It was a Mailman bug.

    Thanks!

    Torsten

    Jeff Groves schrieb am 06.02.2005 22:37:
    Brad:

    It seems to be worse than not having the date set. The MTA itself is
    behaving very badly by setting the sent date to 0 seconds since the
    January 1, 1970 (standard zero time in UNIX).

    The chances that ALL messages are dated January 1, 1970 because of a
    time synchronization problem are pretty slim, since machines don't
    default to much later dates than 1990 now-a-days.

    Whomever wrote that MTA did a poor job of handling a "no Date" header"
    situation.

    Jeff G.

    Brad Knowles wrote:
    At 11:35 AM +0100 2005-02-06, Torsten Ehlers wrote:

    When I tell Mailman to receive my mails from a list in a daily digest
    I receive this digest but the header of the digest mail does not
    contain
    a Date line, i.e. the Mails are shown in my mail client with the date
    January 1st 1970. How can this be fixed?


    Mailman 2.1.5 does not include a Date: header on the messages it
    sends out. Since this header is required by the SMTP RFCs, it is up
    to the MTA to put an appropriate Date: header onto the outgoing
    message. The server for your MTA must have an incorrectly set clock.

    I suggest that you have that machine configured to run "ntpd",
    suitably configured. There's some information at
    <http://ntp.isc.org/bin/view/Support/WebHome> to help you get this going.
  • Brad Knowles at Feb 6, 2005 at 9:54 pm

    At 10:45 PM +0100 2005-02-06, Torsten Ehlers wrote:

    my MTA is qmail. The date of my machine is set correctly (I'm already
    using ntp, by the way).
    Ahh. This is a known issue with qmail.
    Other mails sent from this machine have the
    correct date.
    Most likely because the applications create their own Date:
    header before sending it out.
    But I could fix the problem by using Mark's tip. It was a Mailman bug.
    Typical behaviour of all other MTAs I know of is to add a proper
    Date: header if none is present, so I think we can argue that the
    fault here is in qmail. At the very least, qmail is violating the
    "Principle Of Least Astonishment".

    Nevertheless, this is something that can be fixed by having the
    application generate its own correct Date: header.

    --
    Brad Knowles, <brad at stop.mail-abuse.org>

    "Those who would give up essential Liberty, to purchase a little
    temporary Safety, deserve neither Liberty nor Safety."

    -- Benjamin Franklin (1706-1790), reply of the Pennsylvania
    Assembly to the Governor, November 11, 1755

    SAGE member since 1995. See <http://www.sage.org/> for more info.
  • Jeff Groves at Feb 6, 2005 at 9:32 pm
    Torsten:

    Which MTA are you using? It handles the situation of no "Date:" header is being added by a
    mail client VERY badly.

    Jeff G.

    Torsten Ehlers wrote:
    Hi,

    I'm using Mailman 2.1.5 on a Debian Woody installation.

    When I tell Mailman to receive my mails from a list in a daily digest I
    receive this digest but the header of the digest mail does not contain a
    Date line, i.e. the Mails are shown in my mail client with the date
    January 1st 1970. How can this be fixed?

    Thank you!

    Torsten
    ------------------------------------------------------
    Mailman-Users mailing list
    Mailman-Users at python.org
    http://mail.python.org/mailman/listinfo/mailman-users
    Mailman FAQ: http://www.python.org/cgi-bin/faqw-mm.py
    Searchable Archives:
    http://www.mail-archive.com/mailman-users%40python.org/
    Unsubscribe:
    http://mail.python.org/mailman/options/mailman-users/jgroves%40krenim.org
    --
    Law of Procrastination:
    Procrastination avoids boredom; one never has
    the feeling that there is nothing important to do.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedFeb 6, '05 at 10:35a
activeFeb 6, '05 at 9:54p
posts7
users4
websitelist.org

People

Translate

site design / logo © 2022 Grokbase