FAQ
I completely changed IP numbers for my domain. Now I notice on the list administration
General Options Section, the following series of links appears:

Other Administrative Activities

Tend to pending moderator requests:
http://machine.mydomain.com/mailman/admindb/listname

Go to the general list information page
http://machine.mydomain.com/mailman/listinfo/listname

Edit the public HTML pages
http://machine.mydomain.com/mailman/edithtml/listname

Go to list archives
http://adsl-65-67-80-177.dsl.ltrkar.swbell.net/pipermail/listname

The first three work fine, but for some reason, the archives link doesn't use my domain
name, but the ISP's name for my address. This pattern is true on this link for all
lists. Why doesn't it use my regular domain name??

When I manually go to:

http://machine.mydomain.com/pipermail/listname

I can see the archives for the list, but they stop when the IP change happened. This is
true for all lists in existence at the time of the change. Lists begun since the
switchover are working fine.

Where do I tweak the setup to get my archives working again?

Any guidance will be greatly appreciated!

Fred

Search Discussions

  • Mark Sapiro at Nov 3, 2004 at 1:04 am

    Fred Ball wrote:
    I completely changed IP numbers for my domain. Now I notice on the list administration
    General Options Section, the following series of links appears:

    Other Administrative Activities

    Tend to pending moderator requests:
    http://machine.mydomain.com/mailman/admindb/listname

    Go to the general list information page
    http://machine.mydomain.com/mailman/listinfo/listname

    Edit the public HTML pages
    http://machine.mydomain.com/mailman/edithtml/listname

    Go to list archives
    http://adsl-65-67-80-177.dsl.ltrkar.swbell.net/pipermail/listname

    The first three work fine, but for some reason, the archives link doesn't use my domain
    name, but the ISP's name for my address. This pattern is true on this link for all
    lists. Why doesn't it use my regular domain name??

    When I manually go to:

    http://machine.mydomain.com/pipermail/listname

    I can see the archives for the list, but they stop when the IP change happened. This is
    true for all lists in existence at the time of the change. Lists begun since the
    switchover are working fine.

    Where do I tweak the setup to get my archives working again?
    Since newly created lists work and only old lists don't, this might be
    a problem that can be fixed with fix_url.py.
    See article 4.29 for more info.

    --
    Mark Sapiro <msapiro at value.net> The highway is for gamblers,
    San Francisco Bay Area, California better use your sense - B. Dylan

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedOct 25, '04 at 6:03p
activeNov 3, '04 at 1:04a
posts2
users2
websitelist.org

2 users in discussion

Fred Ball: 1 post Mark Sapiro: 1 post

People

Translate

site design / logo © 2022 Grokbase