Hello,
My fresh install of Mailman 2.1.5 seems to be OK, except that moderation isn't
working. When moderation is set, messages to the list disappear into a black
hole, and the moderator isn't even notified.

Messages do go through when moderation is deactivated.

I've pored through all the options to make sure I'm not doing something
wrong--moderation bits are set, moderation is on (have even tried emergency
moderation), and it's set to notify the moderator immediately about new
messages.

My MTA is Postfix 1.1.11-0, Python 2.1.3-3, OS Debian stable (woody)/kernel
2.2.20, on Compaq Proliant 1600 (PII) hardware.

(There may be one other problem; a user reported that without moderation set,
messages from non list-members were going through, even though the options
didn't allow that.)

I have checked permissions and owners, and configured Mailman with the
following options:

--with-mail-gid=mailman --with-cgi-gid=www-data

I also followed the instructions for configuring Mailman to work with
Postfix--i.e., modifying the postfix config to look for the mailman aliases
file. I have run newaliases and reloaded Postfix. (Several times!)

Here is the business part of my mm_cfg.py:

##################################################
# Put YOUR site-specific settings below this line.

MTA = 'Postfix'
DEFAULT_EMAIL_HOST = 'my.domain.is.here.in.the.real.file.net'
DEFAULT_URL_HOST = 'my.domain.is.here.in.the.real.file.net'


Help?!?!

Jeff Nelson

Search Discussions

  • Jeff Nelson at Sep 21, 2004 at 5:49 pm
    Hi,
    Well, I removed my Mailman 2.1.5 install and put in 2.0.13. After getting
    everything configured, I can subscribe users and Mailman sends out welcome
    messages, but messages on a list set to be moderated still
    disappear--actually, ALL messages to the list disappear now, even when
    moderation is not set.

    According to the docs, 2.1.5 is supposed to *work* with Python 2.1.3, though
    the later version is recommended. I'm thinking that this wasn't the problem
    after all. :-{

    I will be most grateful for ideas. If I can't get Mailman working within a
    couple of days, I'm going to have to try some other list manager, like Sympa,
    but I hate to do that because Mailman still has the best interface by far.

    Jeff
    On Sep 20, 2004, at 1:44 AM, Jeff Nelson wrote:
    My MTA is Postfix 1.1.11-0, Python 2.1.3-3, OS Debian stable
    (woody)/kernel
    2.2.20, on Compaq Proliant 1600 (PII) hardware.
    I don't know if this is the cause of your problems, but IIRC, 2.1.5
    requires Python 2.3 or later.

    Dan

    ================================
    Dan Phillips
    Associate Professor of Horn, University of Memphis
    site administrator: music.memphis.edu
  • Brad Knowles at Sep 23, 2004 at 9:57 am

    At 10:49 AM -0700 2004-09-21, Jeff Nelson wrote:

    According to the docs, 2.1.5 is supposed to *work* with Python 2.1.3, though
    the later version is recommended. I'm thinking that this wasn't the problem
    after all. :-{
    Python 2.3 is actually required for Mailman 2.1.5. See
    <http://www.python.org/cgi-bin/faqw-mm.py?req=show&file=faq05.008.htp>.

    --
    Brad Knowles, <brad at stop.mail-abuse.org>

    "Those who would give up essential Liberty, to purchase a little
    temporary Safety, deserve neither Liberty nor Safety."

    -- Benjamin Franklin (1706-1790), reply of the Pennsylvania
    Assembly to the Governor, November 11, 1755

    SAGE member since 1995. See <http://www.sage.org/> for more info.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedSep 20, '04 at 6:44a
activeSep 23, '04 at 9:57a
posts3
users3
websitelist.org

People

Translate

site design / logo © 2022 Grokbase