Hello,

I don't know why, but qrunner (which I guess is related to mailman) is
using 99% of my cpu all the time.
I ran "qrunner -r All" because I assumed that I needed everything.

Any hints would be appreciated!
Thanks,
Takahiro

Search Discussions

  • Takahiro_Horie at Sep 10, 2004 at 10:36 pm
    I am running mailman 2.1.5 and postfix 1.1.11.

    I tried a few things such as not running ArchRunner (I don't think it was
    ever running in the first place).
    I checked the logs such as mail.log mail.err, mail.info and also log files
    in mailman but there was nothing that really showed something obviously
    wrong.
    I tried changing my mm_cfg.py to have: QRUNNER_SLEEP_TIME = seconds(5).
    I tried changing my /etc/postfix/main.cf to have:
    unknown_local_recipient_reject_code = 550

    None of these are helping, and qrunner -r All is still running at 99% cpu
    usage.

    Also, the mailing list is actually functioning fine. Everyone is getting
    their e-mail. This is a very small server and I only have one list of 5
    e-mail addresses. Only three messages have been posted so far. There is no
    reason for qrunner to be going crazy.

    If anyone has any suggestions, please let me know.
    Thanks,
    Takahiro






    Jim Tittsler <jwt at OnJapan.net>
    09/07/2004 05:42 PM


    To: Takahiro_Horie at nidek.com
    cc:
    Subject: Re: [Mailman-Users] qrunner using 99% of my CPU time?
    On Tue, Sep 07, 2004 at 12:20:29PM -0700, Takahiro_Horie at nidek.com wrote:
    I don't know why, but qrunner (which I guess is related to mailman) is
    using 99% of my cpu all the time.
    Make sure that there is no problem connecting to your mail
    server from Mailman. When Mailman's queue runners have
    difficulty connecting (and delivering mail) to the local
    mail server, they can consume a LOT of CPU time.

    --
    Jim Tittsler http://www.OnJapan.net/ GPG: 0x01159DB6
    Python Starship http://Starship.Python.net/
    Ringo MUG Tokyo http://www.ringo.net/rss.html
  • Brad Knowles at Sep 10, 2004 at 11:29 pm

    At 3:36 PM -0700 2004-09-10, Takahiro_Horie at nidek.com wrote:

    None of these are helping, and qrunner -r All is still running at 99% cpu
    usage.
    You read everything at
    <http://www.python.org/cgi-bin/faqw-mm.py?req=show&file=faq04.041.htp>,
    and all the threads that it links to?

    What's in your logs? Are you sure you're not having NIS or DNS problems?

    --
    Brad Knowles, <brad at stop.mail-abuse.org>

    "Those who would give up essential Liberty, to purchase a little
    temporary Safety, deserve neither Liberty nor Safety."

    -- Benjamin Franklin (1706-1790), reply of the Pennsylvania
    Assembly to the Governor, November 11, 1755

    SAGE member since 1995. See <http://www.sage.org/> for more info.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedSep 7, '04 at 7:20p
activeSep 10, '04 at 11:29p
posts3
users2
websitelist.org

2 users in discussion

Takahiro_Horie: 2 posts Brad Knowles: 1 post

People

Translate

site design / logo © 2022 Grokbase