Dear Mailman Users,

I have setup mailman on a Debian woody machine with qmail. Everything
seems to be working correctly except for a few small details. The main
issue I am having right now is detailed below. The user is attempting
to send an HTML formatted email to the list. The received email looks
nothing like the sent item, It looks like the HTML has been striped.
This puzzles me because it looks like the command it uses to strip is
lynx -dump, and lynx is not installed on the machine. I have verified
that the original message is viewable as an html message when not sent
through mailman.
How do I make HTML email arrive intact?

Many Thanks,
-David Wilson
Fastmetrics Systems Administrator.



-----Original Message-----

I've attempted several times to send an html newsletter via the Mailman
mailing list, without success.

The html newsletter transmits successfully, ie with its html intact, if
I
send it directly through Outlook Express.

The newsletter itself (in attached file) is less than 60K. I increased
the
memory to 200K just in case, but the newsletter was still transmitted as
plain text and image attachments.

My current content filtering settings are as follows:

(1) Should Mailman filter the content of list traffic according to the
settings below?: NO

(2) (filter_mime_types) Remove msg. attachments that have a matching
content
type: (set to BLANK - nothing in the text box)

(3) (pass_mime_types) Remove msg. attachments that don't have a matching
content type (again set to BLANK - nothing in the text box) -

(4) Should Mailman convert text/html parts to plain text? This
conversion
happens after MIME attachments have been stripped: NO

(5) Action to take when a message matches th e content filtering rules:
PRESERVE



-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: newsletter_test2.htm
Url: http://mail.python.org/pipermail/mailman-users/attachments/20030918/a8c13e72/attachment.pot

Search Discussions

  • John DeCarlo at Sep 22, 2003 at 3:57 pm
    David,

    Your Mailman settings seem correct for not stripping out HTML.

    Have you confirmed that other users on your Debian machine get the HTML
    mail correctly (your statement isn't clear on this)? I suspect
    something else besides Mailman is involved.

    Also, you might want to check the aliases for Mailman within qmail.
    There could be a preprocessing filter in there.

    David Wilson wrote:
    Dear Mailman Users,

    I have setup mailman on a Debian woody machine with qmail. Everything
    seems to be working correctly except for a few small details. The main
    issue I am having right now is detailed below. The user is attempting
    to send an HTML formatted email to the list. The received email looks
    nothing like the sent item, It looks like the HTML has been striped.
    This puzzles me because it looks like the command it uses to strip is
    lynx -dump, and lynx is not installed on the machine. I have verified
    that the original message is viewable as an html message when not sent
    through mailman.
    How do I make HTML email arrive intact?

    John DeCarlo, My Views Are My Own

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedSep 19, '03 at 1:54a
activeSep 22, '03 at 3:57p
posts2
users2
websitelist.org

2 users in discussion

John DeCarlo: 1 post David Wilson: 1 post

People

Translate

site design / logo © 2022 Grokbase