using redhat 9, sendmail 8.12.8, mailman 2.1.2

I can access the web interface, send messages to mailman at domain and
not receive any error replies. What I cannot do is get any mail from
mailman. If I subscribe to a list, I don't receive the confirmation
message. If I send a message to mailman at domain.com, body containing
help (or anything else), no reply. As near as I can tell, the correct
entries are in my alias file. The mailman service appears to be
running.

Looking at the maillog, it seems that incoming messages are being
passed to /usr/local/mailman/mail/mailman successfully. but nothing
is ever sent.

I am running mimedefang and spamassassin on my mail server, but
looking at the logs, they aren't killing the messages... I suppose
they might be interfering somehow, but I don't see how. (obviously).

I've been beating on this thing for 2 days now, up to and including
completely removing mailman and reinstalling from scratch. I'm
stumped. Any ideas?

Mike-

Mornings: Evolution in action. Only the grumpy will survive.
-----------------------------------------------------

Please note - Due to the intense volume of spam, we have
installed site-wide spam filters at catherders.com. If
email from you bounces, try non-HTML, non-encoded,
non-attachments.

Search Discussions

  • Michael W. Cocke at Sep 12, 2003 at 4:39 pm

    On Fri, 12 Sep 2003 08:20:04 -0400, you wrote:
    Does "mailmanctl stop" kill all the mailman processes or does the
    Outgoing queue stay up?
    Looks like it kills everything.
    Which version of python are you running?
    Python 2.2.2

    Mike-

    Mornings: Evolution in action. Only the grumpy will survive.
    -----------------------------------------------------

    Please note - Due to the intense volume of spam, we have
    installed site-wide spam filters at catherders.com. If
    email from you bounces, try non-HTML, non-encoded,
    non-attachments.
  • Michael W. Cocke at Sep 12, 2003 at 4:44 pm

    On Fri, 12 Sep 2003 08:04:50 -0500, you wrote:
    If you are using the RPM that came with RH9, that's your problem...it's
    broken. Remove the RPM and install from source.

    Mike
    I Already did that twice, but thanks for the suggestion.

    Mike-
    Mornings: Evolution in action. Only the grumpy will survive.
    -----------------------------------------------------

    Please note - Due to the intense volume of spam, we have
    installed site-wide spam filters at catherders.com. If
    email from you bounces, try non-HTML, non-encoded,
    non-attachments.
  • Michael W. Cocke at Sep 12, 2003 at 4:57 pm
    Yes, it is. At this point I've only got one subscriber to a test list
    - me. I have no good way to tell if it will send to a different
    domain...

    Mike-
    On Fri, 12 Sep 2003 09:54:44 -0700, you wrote:

    This sounds similar to what I've been seeing. Is the email address that
    you're sending to on the same domain as where mailman is? That's my
    problem. But I noticed that it was sending mail to accounts on yahoo and
    other places. Just curious if that was your problem as well.

    Thanks,
    Concordia

    -----Original Message-----
    From: mailman-users-bounces+concordia=aldea.com at python.org
    [mailto:mailman-users-bounces+concordia=aldea.com at python.org] On Behalf
    Of Michael W. Cocke
    Sent: Friday, September 12, 2003 9:44 AM
    To: mailman-users at python.org
    Subject: Re: [Mailman-Users] mailman 2.1.2 not sending mail
    On Fri, 12 Sep 2003 08:04:50 -0500, you wrote:

    If you are using the RPM that came with RH9, that's your problem...it's
    broken. Remove the RPM and install from source.

    Mike
    I Already did that twice, but thanks for the suggestion.

    Mike-
    Mornings: Evolution in action. Only the grumpy will survive.
    -----------------------------------------------------

    Please note - Due to the intense volume of spam, we have
    installed site-wide spam filters at catherders.com. If
    email from you bounces, try non-HTML, non-encoded,
    non-attachments.


    ------------------------------------------------------
    Mailman-Users mailing list
    Mailman-Users at python.org
    http://mail.python.org/mailman/listinfo/mailman-users
    Mailman FAQ: http://www.python.org/cgi-bin/faqw-mm.py
    Searchable Archives:
    http://www.mail-archive.com/mailman-users%40python.org/

    This message was sent to: concordia at aldea.com
    Unsubscribe or change your options at
    http://mail.python.org/mailman/options/mailman-users/concordia%40aldea.c
    om
    Mornings: Evolution in action. Only the grumpy will survive.
    -----------------------------------------------------

    Please note - Due to the intense volume of spam, we have
    installed site-wide spam filters at catherders.com. If
    email from you bounces, try non-HTML, non-encoded,
    non-attachments.
  • John W. Baxter at Sep 14, 2003 at 11:38 pm

    On 9/12/2003 9:57, "Michael W. Cocke" wrote:

    Yes, it is. At this point I've only got one subscriber to a test list
    - me. I have no good way to tell if it will send to a different
    domain...
    Get yourself a free email account (on Yahoo or wherever) and subscribe it to
    your test list. (When the spam to the account becomes unbearable, abandon
    it.)

    --John
  • Michael W. Cocke at Sep 15, 2003 at 12:40 pm

    On Sun, 14 Sep 2003 16:38:01 -0700, you wrote:
    On 9/12/2003 9:57, "Michael W. Cocke" wrote:

    Yes, it is. At this point I've only got one subscriber to a test list
    - me. I have no good way to tell if it will send to a different
    domain...
    Get yourself a free email account (on Yahoo or wherever) and subscribe it to
    your test list. (When the spam to the account becomes unbearable, abandon
    it.)

    --John

    I sent this a day or so ago, but I haven't seen it come back - looks
    like it didn't go for some reason, so I'll repost;

    Sorted!

    I knew it had to be something stupid...

    I had my firewall (which also runs on the same system as mailman,
    sendmail, etc. cranked down so tight it was blocking the smtp server
    on 127.0.0.1. Once I opened that up again, messages work. I think
    mailman should have logged something when it couldn't contact the smtp
    server, but that's a nit.


    Mike-

    Mornings: Evolution in action. Only the grumpy will survive.
    -----------------------------------------------------

    Please note - Due to the intense volume of spam, we have
    installed site-wide spam filters at catherders.com. If
    email from you bounces, try non-HTML, non-encoded,
    non-attachments.
  • Michael W. Cocke at Sep 12, 2003 at 6:53 pm
    I just noticed that when I have mailman running (for what THAT'S
    worth), the system bogs down hopelessly.

    I MUST have this thing set up wrong, but darned if I see what I did!

    I've tried following the INSTALL file that comes with mailman, but I
    guess I'm too stupid - is there a blooming idiots guide to mailman
    somewhere?


    Mike-
    Mornings: Evolution in action. Only the grumpy will survive.
    -----------------------------------------------------

    Please note - Due to the intense volume of spam, we have
    installed site-wide spam filters at catherders.com. If
    email from you bounces, try non-HTML, non-encoded,
    non-attachments.
  • Michael W. Cocke at Sep 12, 2003 at 8:16 pm
    I'll get right on it - this should have been working 2 days ago...
    Thanks!

    Mike-

    On Fri, 12 Sep 2003 14:59:20 -0400, you wrote:

    I've been working on one of those and it has a modified Postfix integration
    section. I highly recommend using Postfix over Sendmail. Qmail needs to
    change its licensing and then I will call it the best. Anywho take a look
    www.pfohlsolutions.com/projects/server/. Please keep in mind it may not be
    100 complete however its close with the mailman info.

    Steve

    -----Original Message-----
    From: mailman-users-bounces+list=pfohlsolutions.com at python.org
    [mailto:mailman-users-bounces+list=pfohlsolutions.com at python.org]On
    Behalf Of Michael W. Cocke
    Sent: Friday, September 12, 2003 2:53 PM
    To: mailman-users at python.org
    Subject: Re: [Mailman-Users] mailman 2.1.2 not sending mail



    I just noticed that when I have mailman running (for what THAT'S
    worth), the system bogs down hopelessly.

    I MUST have this thing set up wrong, but darned if I see what I did!

    I've tried following the INSTALL file that comes with mailman, but I
    guess I'm too stupid - is there a blooming idiots guide to mailman
    somewhere?


    Mike-
    Mornings: Evolution in action. Only the grumpy will survive.
    -----------------------------------------------------

    Please note - Due to the intense volume of spam, we have
    installed site-wide spam filters at catherders.com. If
    email from you bounces, try non-HTML, non-encoded,
    non-attachments.

    ------------------------------------------------------
    Mailman-Users mailing list
    Mailman-Users at python.org
    http://mail.python.org/mailman/listinfo/mailman-users
    Mailman FAQ: http://www.python.org/cgi-bin/faqw-mm.py
    Searchable Archives: http://www.mail-archive.com/mailman-users%40python.org/

    This message was sent to: list at pfohlsolutions.com
    Unsubscribe or change your options at
    http://mail.python.org/mailman/options/mailman-users/list%40pfohlsolutions.c
    om
    Mornings: Evolution in action. Only the grumpy will survive.
    -----------------------------------------------------

    Please note - Due to the intense volume of spam, we have
    installed site-wide spam filters at catherders.com. If
    email from you bounces, try non-HTML, non-encoded,
    non-attachments.
  • Michael W. Cocke at Sep 12, 2003 at 9:44 pm
    I knew it had to be something stupid...

    I had my firewall (which also runs on the same system as mailman,
    sendmail, etc. cranked down so tight it was blocking the smtp server
    on 127.0.0.1. Once I opened that up again, messages work. Now all I
    need to do is fix the performance.... I could send mail faster with
    carrier pigeons. It looks like the outgoing qrunner is cycling
    endlessly without a pause.... Is there a setting somewhere?

    Mike-

    Mornings: Evolution in action. Only the grumpy will survive.
    -----------------------------------------------------

    Please note - Due to the intense volume of spam, we have
    installed site-wide spam filters at catherders.com. If
    email from you bounces, try non-HTML, non-encoded,
    non-attachments.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedSep 12, '03 at 12:14p
activeSep 15, '03 at 12:40p
posts9
users2
websitelist.org

People

Translate

site design / logo © 2022 Grokbase