FAQ
Hi,

We have upgraded mailman to 2.1.1-5 on debian sid,
using python version 2.2.2-6. Web interface works
okay, but qrunner is failed to start normally, so
no mails from the que is delviered to the list members.
The exim mailserver passes the incoming mails to
mailman. check_permissions report no problem in bin dir.

qrunner logfile says:

May 04 23:01:34 2003 (22324) ArchRunner qrunner started.
May 04 23:01:34 2003 (22325) BounceRunner qrunner started.
May 04 23:01:34 2003 (22326) CommandRunner qrunner started.
May 04 23:01:34 2003 (22327) IncomingRunner qrunner started.
May 04 23:01:34 2003 (22328) NewsRunner qrunner started.
May 04 23:01:34 2003 (22329) OutgoingRunner qrunner started.
May 04 23:01:34 2003 (22330) VirginRunner qrunner started.
May 04 23:01:35 2003 (22323) Master qrunner detected subprocess exit
(pid: 22327, sig: None, sts: 1, class: IncomingRunner, slice: 1/1) [restarting]
May 04 23:01:35 2003 (22334) IncomingRunner qrunner started.
May 04 23:01:35 2003 (22323) Master qrunner detected subprocess exit
(pid: 22334, sig: None, sts: 1, class: IncomingRunner, slice: 1/1) [restarting]
May 04 23:01:36 2003 (22335) IncomingRunner qrunner started.
May 04 23:01:36 2003 (22323) Master qrunner detected subprocess exit
(pid: 22335, sig: None, sts: 1, class: IncomingRunner, slice: 1/1) [restarting]
May 04 23:01:37 2003 (22336) IncomingRunner qrunner started.
May 04 23:01:37 2003 (22323) Master qrunner detected subprocess exit
(pid: 22336, sig: None, sts: 1, class: IncomingRunner, slice: 1/1) [restarting]
May 04 23:01:38 2003 (22337) IncomingRunner qrunner started.
May 04 23:01:38 2003 (22323) Master qrunner detected subprocess exit
(pid: 22337, sig: None, sts: 1, class: IncomingRunner, slice: 1/1) [restarting]
May 04 23:01:38 2003 (22338) IncomingRunner qrunner started.
May 04 23:01:38 2003 (22323) Master qrunner detected subprocess exit
(pid: 22338, sig: None, sts: 1, class: IncomingRunner, slice: 1/1) [restarting]
May 04 23:01:39 2003 (22339) IncomingRunner qrunner started.
May 04 23:01:39 2003 (22323) Master qrunner detected subprocess exit
(pid: 22339, sig: None, sts: 1, class: IncomingRunner, slice: 1/1) [restarting]
May 04 23:01:40 2003 (22340) IncomingRunner qrunner started.
May 04 23:01:40 2003 (22323) Master qrunner detected subprocess exit
(pid: 22340, sig: None, sts: 1, class: IncomingRunner, slice: 1/1) [restarting]
May 04 23:01:41 2003 (22342) IncomingRunner qrunner started.
May 04 23:01:41 2003 (22323) Master qrunner detected subprocess exit
(pid: 22342, sig: None, sts: 1, class: IncomingRunner, slice: 1/1) [restarting]
May 04 23:01:42 2003 (22343) IncomingRunner qrunner started.
May 04 23:01:42 2003 (22323) Master qrunner detected subprocess exit
(pid: 22343, sig: None, sts: 1, class: IncomingRunner, slice: 1/1) [restarting]
May 04 23:01:42 2003 (22345) IncomingRunner qrunner started.
May 04 23:01:42 2003 (22323) Master qrunner detected subprocess exit
(pid: 22345, sig: None, sts: 1, class: IncomingRunner, slice: 1/1) [restarting]
May 04 23:01:42 2003 (22323) Qrunner IncomingRunner reached maximum restart limit of 10, not restarting.

all other logfiles are empty.

Any ideas what to check ?
(I have recompiled mailman from source didn't help)

thnx
--
Feczo ___________________________
<-- http://feczo.koli.kando.hu -->

Search Discussions

  • Kysh at May 5, 2003 at 12:20 am

    On Sun, May 04, 2003 at 11:14:35PM +0200, Feczak Szabolcs wrote:
    Hi,

    We have upgraded mailman to 2.1.1-5 on debian sid,
    using python version 2.2.2-6. Web interface works
    okay, but qrunner is failed to start normally, so
    no mails from the que is delviered to the list members.
    I had an identical problem, but nobody had an answer for me.
    (Several wanted me to try and debug, but I don't have time to debug broken code
    all day for every app that doesn't quite work right)

    I was able to hobble along for many months by just running
    /var/lib/mailman/bin/qrunner -r All &.

    I got it working again 'for real' just recently, by backing up $PREFIX/lists,
    purging all semblances of mailman, upgrading python to the latest of everything,
    reinstalling mailman and copying $PREFIX/lists back over.

    I am not happy with what I had to do to make that work, but it worked.

    -Kysh
    --
    .+------------------------------------------------------------+.
    'Life begins at 120kias' - http://www.lapdragon.org/flying |
    CBR-F4 streetbike - http://www.lapdragon.org/cbr |
    1968 Mustang fastback - http://www.lapdragon.org/mustang |
    Got 'nix? - http://www.infrastructure.org/ |
    KG6FOB - http://www.lapdragon.org/ham |
    Give blood: Play Hockey! http://www.unixdragon.com/ |
    `+------------------------------------------------------------+'
  • Jon Carnes at May 5, 2003 at 2:31 am
    You're not the first to have this problem on Debian. You should
    download the source and install from there. You might also need to
    install Python from source as well - but first I would simply try
    re-installing Mailman using the source code.

    Let us know how you do. If installing from source solves the problem
    then you should contact the Mailman maintainer on Debian.

    Jon Carnes
    On Sun, 2003-05-04 at 17:14, Feczak Szabolcs wrote:
    Hi,

    We have upgraded mailman to 2.1.1-5 on debian sid,
    using python version 2.2.2-6. Web interface works
    okay, but qrunner is failed to start normally, so
    no mails from the que is delviered to the list members.
    The exim mailserver passes the incoming mails to
    mailman. check_permissions report no problem in bin dir.

    qrunner logfile says:

    May 04 23:01:34 2003 (22324) ArchRunner qrunner started.
    May 04 23:01:34 2003 (22325) BounceRunner qrunner started.
    May 04 23:01:34 2003 (22326) CommandRunner qrunner started.
    May 04 23:01:34 2003 (22327) IncomingRunner qrunner started.
    May 04 23:01:34 2003 (22328) NewsRunner qrunner started.
    May 04 23:01:34 2003 (22329) OutgoingRunner qrunner started.
    May 04 23:01:34 2003 (22330) VirginRunner qrunner started.
    May 04 23:01:35 2003 (22323) Master qrunner detected subprocess exit
    (pid: 22327, sig: None, sts: 1, class: IncomingRunner, slice: 1/1) [restarting]
    May 04 23:01:35 2003 (22334) IncomingRunner qrunner started.
    May 04 23:01:35 2003 (22323) Master qrunner detected subprocess exit
    (pid: 22334, sig: None, sts: 1, class: IncomingRunner, slice: 1/1) [restarting]
    May 04 23:01:36 2003 (22335) IncomingRunner qrunner started.
    May 04 23:01:36 2003 (22323) Master qrunner detected subprocess exit
    (pid: 22335, sig: None, sts: 1, class: IncomingRunner, slice: 1/1) [restarting]
    May 04 23:01:37 2003 (22336) IncomingRunner qrunner started.
    May 04 23:01:37 2003 (22323) Master qrunner detected subprocess exit
    (pid: 22336, sig: None, sts: 1, class: IncomingRunner, slice: 1/1) [restarting]
    May 04 23:01:38 2003 (22337) IncomingRunner qrunner started.
    May 04 23:01:38 2003 (22323) Master qrunner detected subprocess exit
    (pid: 22337, sig: None, sts: 1, class: IncomingRunner, slice: 1/1) [restarting]
    May 04 23:01:38 2003 (22338) IncomingRunner qrunner started.
    May 04 23:01:38 2003 (22323) Master qrunner detected subprocess exit
    (pid: 22338, sig: None, sts: 1, class: IncomingRunner, slice: 1/1) [restarting]
    May 04 23:01:39 2003 (22339) IncomingRunner qrunner started.
    May 04 23:01:39 2003 (22323) Master qrunner detected subprocess exit
    (pid: 22339, sig: None, sts: 1, class: IncomingRunner, slice: 1/1) [restarting]
    May 04 23:01:40 2003 (22340) IncomingRunner qrunner started.
    May 04 23:01:40 2003 (22323) Master qrunner detected subprocess exit
    (pid: 22340, sig: None, sts: 1, class: IncomingRunner, slice: 1/1) [restarting]
    May 04 23:01:41 2003 (22342) IncomingRunner qrunner started.
    May 04 23:01:41 2003 (22323) Master qrunner detected subprocess exit
    (pid: 22342, sig: None, sts: 1, class: IncomingRunner, slice: 1/1) [restarting]
    May 04 23:01:42 2003 (22343) IncomingRunner qrunner started.
    May 04 23:01:42 2003 (22323) Master qrunner detected subprocess exit
    (pid: 22343, sig: None, sts: 1, class: IncomingRunner, slice: 1/1) [restarting]
    May 04 23:01:42 2003 (22345) IncomingRunner qrunner started.
    May 04 23:01:42 2003 (22323) Master qrunner detected subprocess exit
    (pid: 22345, sig: None, sts: 1, class: IncomingRunner, slice: 1/1) [restarting]
    May 04 23:01:42 2003 (22323) Qrunner IncomingRunner reached maximum restart limit of 10, not restarting.

    all other logfiles are empty.

    Any ideas what to check ?
    (I have recompiled mailman from source didn't help)

    thnx
  • Feczak Szabolcs at May 5, 2003 at 2:07 pm

    On Sun, May 04, 2003 at 10:31:50PM -0400, Jon Carnes wrote:
    You're not the first to have this problem on Debian. You should
    download the source and install from there. You might also need to
    install Python from source as well - but first I would simply try
    re-installing Mailman using the source code.
    You probably jumped over this part of my letter:
    (I have recompiled mailman from source didn't help)
    so it is not a package problem


    --
    Feczo ___________________________
    <-- http://feczo.koli.kando.hu -->
  • Feczak Szabolcs at May 5, 2003 at 2:08 pm

    On Sun, May 04, 2003 at 05:20:01PM -0700, Kysh wrote:
    I was able to hobble along for many months by just running
    /var/lib/mailman/bin/qrunner -r All &.
    Looks like I have bit different problem:

    /var/lib/mailman/bin/qrunner -r All
    Traceback (most recent call last):
    File "/var/lib/mailman/bin/qrunner", line 270, in ?
    main()
    File "/var/lib/mailman/bin/qrunner", line 260, in main
    qrunner.run()
    File "/usr/lib/mailman/Mailman/Queue/Runner.py", line 59, in run
    filecnt = self._oneloop()
    File "/usr/lib/mailman/Mailman/Queue/Runner.py", line 88, in _oneloop
    msg, msgdata = self._switchboard.dequeue(filebase)
    File "/var/lib/mailman/Mailman/Queue/Switchboard.py", line 144, in dequeue
    data = self._ext_read(dbfile)
    File "/var/lib/mailman/Mailman/Queue/Switchboard.py", line 245, in _ext_read
    dict = marshal.load(fp)
    ValueError: bad marshal data
    I got it working again 'for real' just recently, by backing up $PREFIX/lists,
    purging all semblances of mailman, upgrading python to the latest of everything,
    What version of python are you using ?
    (me: 2.2.2)

    --
    Feczo ___________________________
    <-- http://feczo.koli.kando.hu -->

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedMay 4, '03 at 9:14p
activeMay 5, '03 at 2:08p
posts5
users3
websitelist.org

People

Translate

site design / logo © 2022 Grokbase