FAQ
I just upgraded a list server from Mailman 2.0.13 to Mailman 2.1.1 and
noticed that I can't change any list settings any more on the web. I
am able to login to the administrative interface using either the list
admin or site admin password and to navigate around but it seems to me
that none of the settings are saved when I click on "Submit your
changes". If I change something and click on "submit your changes", on
the next page, I see all settings the way they were before changing
them. I am also unable to reset the list admin password or to
accept/reject/discard any of the pending requests. I am not getting
errors on the web page. Posting to the mailing lists seems to work and
I think all file permissions are correct. I am using Python 2.1.3 on
Solaris. Did anyone else have the same problem?


-akop

Search Discussions

  • Mike Kercher at Apr 16, 2003 at 2:24 pm
    Yes...I have the same problem here on a Redhat AS 2.1 I upgraded from 2.0.13
    (rpm) to 2.1.1 All of my lists work as far as email goes, but nothing done in
    the admin interface works. I have 2 admin requests waiting on the server, but
    when I try to take action on them, nothing happens.

    Mike


    -----Original Message-----
    From: mailman-users-bounces+mike=camaross.net at python.org
    [mailto:mailman-users-bounces+mike=camaross.net at python.org] On Behalf Of Akop
    Pogosian
    Sent: Tuesday, April 15, 2003 11:23 PM
    To: mailman-users at python.org
    Subject: [Mailman-Users] unable to change any list setting after the upgrade


    I just upgraded a list server from Mailman 2.0.13 to Mailman 2.1.1 and
    noticed that I can't change any list settings any more on the web. I
    am able to login to the administrative interface using either the list
    admin or site admin password and to navigate around but it seems to me
    that none of the settings are saved when I click on "Submit your
    changes". If I change something and click on "submit your changes", on
    the next page, I see all settings the way they were before changing
    them. I am also unable to reset the list admin password or to
    accept/reject/discard any of the pending requests. I am not getting
    errors on the web page. Posting to the mailing lists seems to work and
    I think all file permissions are correct. I am using Python 2.1.3 on
    Solaris. Did anyone else have the same problem?


    -akop

    ------------------------------------------------------
    Mailman-Users mailing list
    Mailman-Users at python.org
    http://mail.python.org/mailman/listinfo/mailman-users
    Mailman FAQ: http://www.python.org/cgi-bin/faqw-mm.py
    Searchable Archives: http://www.mail-archive.com/mailman-users%40python.org/

    This message was sent to: mike at camaross.net
    Unsubscribe or change your options at
    http://mail.python.org/mailman/options/mailman-users/mike%40camaross.net
  • Mike Kercher at Apr 16, 2003 at 5:14 pm
    Well, after lots of digging around the upgraded system, I was unable to figure
    out why my web interface to my lists wasn't working. Changes in neither
    mm_cfg.py nor Defaults.py were being picked up. My resolution ended up being to
    delete all of my lists and recreate them all. I left the archives in place and
    they are working fine. I'd love to know how to avoid this in the future though!

    Mike


    -----Original Message-----
    From: mailman-users-bounces+mike=camaross.net at python.org
    [mailto:mailman-users-bounces+mike=camaross.net at python.org] On Behalf Of Mike
    Kercher
    Sent: Wednesday, April 16, 2003 9:24 AM
    To: mailman-users at python.org
    Subject: RE: [Mailman-Users] unable to change any list setting after theupgrade


    Yes...I have the same problem here on a Redhat AS 2.1 I upgraded from 2.0.13
    (rpm) to 2.1.1 All of my lists work as far as email goes, but nothing done in
    the admin interface works. I have 2 admin requests waiting on the server, but
    when I try to take action on them, nothing happens.

    Mike


    -----Original Message-----
    From: mailman-users-bounces+mike=camaross.net at python.org
    [mailto:mailman-users-bounces+mike=camaross.net at python.org] On Behalf Of Akop
    Pogosian
    Sent: Tuesday, April 15, 2003 11:23 PM
    To: mailman-users at python.org
    Subject: [Mailman-Users] unable to change any list setting after the upgrade


    I just upgraded a list server from Mailman 2.0.13 to Mailman 2.1.1 and
    noticed that I can't change any list settings any more on the web. I
    am able to login to the administrative interface using either the list
    admin or site admin password and to navigate around but it seems to me
    that none of the settings are saved when I click on "Submit your
    changes". If I change something and click on "submit your changes", on
    the next page, I see all settings the way they were before changing
    them. I am also unable to reset the list admin password or to
    accept/reject/discard any of the pending requests. I am not getting
    errors on the web page. Posting to the mailing lists seems to work and
    I think all file permissions are correct. I am using Python 2.1.3 on
    Solaris. Did anyone else have the same problem?


    -akop

    ------------------------------------------------------
    Mailman-Users mailing list
    Mailman-Users at python.org
    http://mail.python.org/mailman/listinfo/mailman-users
    Mailman FAQ: http://www.python.org/cgi-bin/faqw-mm.py
    Searchable Archives: http://www.mail-archive.com/mailman-users%40python.org/

    This message was sent to: mike at camaross.net
    Unsubscribe or change your options at
    http://mail.python.org/mailman/options/mailman-users/mike%40camaross.net


    ------------------------------------------------------
    Mailman-Users mailing list
    Mailman-Users at python.org
    http://mail.python.org/mailman/listinfo/mailman-users
    Mailman FAQ: http://www.python.org/cgi-bin/faqw-mm.py
    Searchable Archives: http://www.mail-archive.com/mailman-users%40python.org/

    This message was sent to: mike at camaross.net
    Unsubscribe or change your options at
    http://mail.python.org/mailman/options/mailman-users/mike%40camaross.net
  • Akop Pogosian at Apr 17, 2003 at 10:33 am

    On Wed, Apr 16, 2003 at 09:24:04AM -0500, Mike Kercher wrote:
    Yes...I have the same problem here on a Redhat AS 2.1 I upgraded from 2.0.13
    (rpm) to 2.1.1 All of my lists work as far as email goes, but nothing done in
    the admin interface works. I have 2 admin requests waiting on the server, but
    when I try to take action on them, nothing happens.

    Mike
    I solved this particular problem but it probably want the same problem
    you were having. It turns out that Mailman guessed incorrectly the web
    server host name (DEFAULT_URL_HOST) and our web server is also
    configured to redirect all requests for non-default web server host
    name to the default host name. This broke all CGI scripts that use
    POST method for passing variables. This one was easy to fix once I
    figured out what it was.

    -akop

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedApr 16, '03 at 4:23a
activeApr 17, '03 at 10:33a
posts4
users2
websitelist.org

2 users in discussion

Mike Kercher: 2 posts Akop Pogosian: 2 posts

People

Translate

site design / logo © 2022 Grokbase