FAQ
So I am able to see all of the admin pages/cgis for mailman, but I cannot see the public archives. The private archives work fine. This seems like a cut-and-dry "Follow symbolic links" issue on the webserver, but I have triple checked that it is enabled. Is there any other possiblility?

From the error log of iPlanet 6.2 when I access the public archives:

14/Aug/2002:08:25:49] failure (10535):
for host x.x.x.50 trying to GET /pipermail/test3/index.html, cgi_start_exec reports: cannot execute CGI script
/opt/mailman/archives/public/test3/index.html (permission denied)

From the access log when I access the private archives:

x.x.x.50 - - [14/Aug/2002:08:26:34 -0600] "POST /mailman/private/test2/ HTTP/1.0" 200 1072
x.x.x.50 - - [14/Aug/2002:08:26:36 -0600] "GET /mailman/private/test2/2002-August/thread.html HTTP/1.0" 200 1635


--


Ryan H. Pratt
NWS Lab Manager
Sun Microsystems, Inc.
(303) 272-8902

Search Discussions

  • Jon Carnes at Aug 14, 2002 at 2:52 pm
    Could it really be a rights issue? Who has rights to read
    /opt/mailman/archives/public/test3/index.html

    -----Original Message-----
    From: Ryan Pratt [mailto:Ryan.Pratt at Sun.COM]
    Sent: Wednesday, August 14, 2002 10:32 AM
    To: mailman-users
    Subject: [Mailman-Users] iPlanet and Mailman/Pipermail issue


    So I am able to see all of the admin pages/cgis for mailman, but I cannot
    see the public archives. The private archives work fine. This seems like a
    cut-and-dry "Follow symbolic links" issue on the webserver, but I have
    triple checked that it is enabled. Is there any other possiblility?

    From the error log of iPlanet 6.2 when I access the public archives:

    14/Aug/2002:08:25:49] failure (10535):
    for host x.x.x.50 trying to GET /pipermail/test3/index.html, cgi_start_exec
    reports: cannot execute CGI script
    /opt/mailman/archives/public/test3/index.html (permission denied)

    From the access log when I access the private archives:

    x.x.x.50 - - [14/Aug/2002:08:26:34 -0600] "POST /mailman/private/test2/
    HTTP/1.0" 200 1072
    x.x.x.50 - - [14/Aug/2002:08:26:36 -0600] "GET
    /mailman/private/test2/2002-August/thread.html HTTP/1.0" 200 1635


    --


    Ryan H. Pratt
    NWS Lab Manager
    Sun Microsystems, Inc.
    (303) 272-8902


    ------------------------------------------------------
    Mailman-Users mailing list
    Mailman-Users at python.org
    http://mail.python.org/mailman/listinfo/mailman-users
    Mailman FAQ: http://www.python.org/cgi-bin/faqw-mm.py
    Searchable Archives: http://www.mail-archive.com/mailman-users%40python.org/
  • Ryan Pratt at Aug 14, 2002 at 3:08 pm
    It is mailman:mailman. I opened it up with 777 and this is the error that I get now...

    [14/Aug/2002:09:06:45] failure (10535):
    for host x.x.x.7 trying to GET /pipermail/test3/index.html, cgi_start_output reports: cannot execute CGI script
    /opt/mailman/archives/public/test3/index.html (exec() failure [Exec format error]), chroot=<none>, dir=<none>,
    user=<none>, group=<none>

    Jon Carnes wrote:
    Could it really be a rights issue? Who has rights to read
    /opt/mailman/archives/public/test3/index.html

    -----Original Message-----
    From: Ryan Pratt [mailto:Ryan.Pratt at Sun.COM]
    Sent: Wednesday, August 14, 2002 10:32 AM
    To: mailman-users
    Subject: [Mailman-Users] iPlanet and Mailman/Pipermail issue


    So I am able to see all of the admin pages/cgis for mailman, but I cannot
    see the public archives. The private archives work fine. This seems like a
    cut-and-dry "Follow symbolic links" issue on the webserver, but I have
    triple checked that it is enabled. Is there any other possiblility?

    From the error log of iPlanet 6.2 when I access the public archives:

    14/Aug/2002:08:25:49] failure (10535):
    for host x.x.x.50 trying to GET /pipermail/test3/index.html, cgi_start_exec
    reports: cannot execute CGI script
    /opt/mailman/archives/public/test3/index.html (permission denied)

    From the access log when I access the private archives:

    x.x.x.50 - - [14/Aug/2002:08:26:34 -0600] "POST /mailman/private/test2/
    HTTP/1.0" 200 1072
    x.x.x.50 - - [14/Aug/2002:08:26:36 -0600] "GET
    /mailman/private/test2/2002-August/thread.html HTTP/1.0" 200 1635


    --


    Ryan H. Pratt
    NWS Lab Manager
    Sun Microsystems, Inc.
    (303) 272-8902


    ------------------------------------------------------
    Mailman-Users mailing list
    Mailman-Users at python.org
    http://mail.python.org/mailman/listinfo/mailman-users
    Mailman FAQ: http://www.python.org/cgi-bin/faqw-mm.py
    Searchable Archives: http://www.mail-archive.com/mailman-users%40python.org/

    --


    Ryan H. Pratt
    NWS Lab Manager
    Sun Microsystems, Inc.
    (303) 272-8902
  • Jon Carnes at Aug 14, 2002 at 4:16 pm
    Interesting... That error in Solaris typically means that the server cannot
    find the executable that is supposed to run a CGI. However, "pipermail"
    should simply be a web alias and not a script alias. Do you have it setup
    as a CGI?

    "pipermail" is generally a shortcut to ~mailman/archives/public/

    -----Original Message-----
    From: Ryan Pratt [mailto:Ryan.Pratt at Sun.COM]
    Sent: Wednesday, August 14, 2002 11:08 AM
    To: jonc at haht.com
    Cc: mailman-users
    Subject: Re: [Mailman-Users] iPlanet and Mailman/Pipermail issue


    It is mailman:mailman. I opened it up with 777 and this is the error that I
    get now...

    [14/Aug/2002:09:06:45] failure (10535):
    for host x.x.x.7 trying to GET /pipermail/test3/index.html,
    cgi_start_output reports: cannot execute CGI script
    /opt/mailman/archives/public/test3/index.html (exec() failure [Exec format
    error]), chroot=<none>, dir=<none>,
    user=<none>, group=<none>

    Jon Carnes wrote:
    Could it really be a rights issue? Who has rights to read
    /opt/mailman/archives/public/test3/index.html

    -----Original Message-----
    From: Ryan Pratt [mailto:Ryan.Pratt at Sun.COM]
    Sent: Wednesday, August 14, 2002 10:32 AM
    To: mailman-users
    Subject: [Mailman-Users] iPlanet and Mailman/Pipermail issue


    So I am able to see all of the admin pages/cgis for mailman, but I cannot
    see the public archives. The private archives work fine. This seems like a
    cut-and-dry "Follow symbolic links" issue on the webserver, but I have
    triple checked that it is enabled. Is there any other possiblility?

    From the error log of iPlanet 6.2 when I access the public archives:

    14/Aug/2002:08:25:49] failure (10535):
    for host x.x.x.50 trying to GET /pipermail/test3/index.html,
    cgi_start_exec
    reports: cannot execute CGI script
    /opt/mailman/archives/public/test3/index.html (permission denied)

    From the access log when I access the private archives:

    x.x.x.50 - - [14/Aug/2002:08:26:34 -0600] "POST /mailman/private/test2/
    HTTP/1.0" 200 1072
    x.x.x.50 - - [14/Aug/2002:08:26:36 -0600] "GET
    /mailman/private/test2/2002-August/thread.html HTTP/1.0" 200 1635


    --


    Ryan H. Pratt
    NWS Lab Manager
    Sun Microsystems, Inc.
    (303) 272-8902


    ------------------------------------------------------
    Mailman-Users mailing list
    Mailman-Users at python.org
    http://mail.python.org/mailman/listinfo/mailman-users
    Mailman FAQ: http://www.python.org/cgi-bin/faqw-mm.py
    Searchable Archives:
    http://www.mail-archive.com/mailman-users%40python.org/

    --


    Ryan H. Pratt
    NWS Lab Manager
    Sun Microsystems, Inc.
    (303) 272-8902

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedAug 14, '02 at 2:31p
activeAug 14, '02 at 4:16p
posts4
users2
websitelist.org

2 users in discussion

Jon Carnes: 2 posts Ryan Pratt: 2 posts

People

Translate

site design / logo © 2022 Grokbase