FAQ
Hi,

I've been trying for the past couple of evenings to get Mailman working on
my system - its a RedHat 7.1 machine with the Ensim control panel installed
(not that I wanted Ensim; but I don't think it matters for this).

My sendmail.cf has the following in:

O DefaultUser=8:12

So I configure Mailman with:

./configure --with-cgi-gid="www www-data apache nobody" --with-mail-gid="12"

And then I do
make clean;make install

When I try to post to a list, I get

Mar 21 16:55:00 ensim sendmail[11168]: g2LLt0o11167:
to="|/home/mailman/mail/wrapper mailowner outlook-03-2002",
ctladdr=(8/0), delay�:00:00,
xdelay�:00:00, mailer=prog, pri8400, dsn=4.0.0, stat=Operating system
error

And the mail is left in the queue with "Operating system error"

If I su to "mail", I can invoke from the command line

/home/mailman/mail/wrapper mailowner outlook-03-2002

Just fine. If I su to nobody (or anyone else) it gives an error message
about the wrong GID.

I've tried different --with-mail-gid options, including:
- "mail"
- "mail, nobody"
- "12, 99, 0"

If you give it multiple values, the configure script seems to pay attention
only to the last one; the installation instructions seem to imply you can
have multiple values for this field.


I'm going mad here; does anyone have any tips? I appreciate its probably a
simple configuration error, but I'm getting to despair :-(.


Many thanks for any help,




Simon

----------------------------------------------------------------------
Simon J. Coles Email: simon at coles.to
=============== Life is too precious to take seriously ==============

Search Discussions

  • Jon Carnes at Mar 21, 2002 at 10:29 pm
    Is your system using "smrsh"? If so, you will have to put a link in the
    /etc/smrsh directory for /home/mailman//mail/wrapper.
    ----- Original Message -----
    From: "Simon Coles" <simon at coles.to>
    To: <mailman-users at python.org>
    Sent: Thursday, March 21, 2002 5:06 PM
    Subject: [Mailman-Users] Problem with the dreaded mail GIDs

    Hi,

    I've been trying for the past couple of evenings to get Mailman working on
    my system - its a RedHat 7.1 machine with the Ensim control panel installed
    (not that I wanted Ensim; but I don't think it matters for this).

    My sendmail.cf has the following in:

    O DefaultUser=8:12

    So I configure Mailman with:

    ./configure --with-cgi-gid="www www-data apache
    nobody" --with-mail-gid="12"
    And then I do
    make clean;make install

    When I try to post to a list, I get

    Mar 21 16:55:00 ensim sendmail[11168]: g2LLt0o11167:
    to="|/home/mailman/mail/wrapper mailowner outlook-03-2002",
    ctladdr=(8/0),
    delay�:00:00,
    xdelay�:00:00, mailer=prog, pri8400, dsn=4.0.0, stat=Operating system
    error

    And the mail is left in the queue with "Operating system error"

    If I su to "mail", I can invoke from the command line

    /home/mailman/mail/wrapper mailowner outlook-03-2002

    Just fine. If I su to nobody (or anyone else) it gives an error message
    about the wrong GID.

    I've tried different --with-mail-gid options, including:
    - "mail"
    - "mail, nobody"
    - "12, 99, 0"

    If you give it multiple values, the configure script seems to pay attention
    only to the last one; the installation instructions seem to imply you can
    have multiple values for this field.


    I'm going mad here; does anyone have any tips? I appreciate its probably a
    simple configuration error, but I'm getting to despair :-(.


    Many thanks for any help,




    Simon
  • Simon Coles at Mar 24, 2002 at 10:00 pm
    Indeed, that was it.

    I was installing on a RedHat machine which had Ensim on it. This had
    installed a /etc/smrsh/wrapper file already for Majordomo. I had tried to
    do the /etc/smrsh/mailman_wrapper thing as suggested in the install
    documentation. That didn't seem to work, but removing the Majordomo and
    replacing it with Mailman's did the trick.

    Thanks for your help,



    Simon

    --On Thursday, March 21, 2002 5:29 pm -0500 Jon Carnes wrote:
    Is your system using "smrsh"? If so, you will have to put a link in the
    /etc/smrsh directory for /home/mailman//mail/wrapper.


    ----------------------------------------------------------------------
    Simon J. Coles Email: simon at coles.to
    =============== Life is too precious to take seriously ===============

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedMar 21, '02 at 10:06p
activeMar 24, '02 at 10:00p
posts3
users2
websitelist.org

2 users in discussion

Simon Coles: 2 posts Jon Carnes: 1 post

People

Translate

site design / logo © 2022 Grokbase