Hi,

having an ugly problem here. Mailman stopped delivering mail a
couple days ago. When I post a message to a list, it seems to be
accepted fine, but it never gets any farther. Looking in logs/smtp I
see:

Sep 11 04:50:54 2000 (61599) smtp for 1028 recips, completed in
36473.001 seconds
Sep 11 05:12:16 2000 (83902) smtp for 1 recips, completed in 0.407 seconds
Sep 11 06:44:35 2000 (82886) All recipients refused: (451, 'timeout
waiting for input during message collect')

So it looks like it tried to send the message to the 1028 people on
the list, but then in logs/smtp-failures I see:

%grep '^Sep 11' smtp-failure | wc -l
1028

So every single email failed? Seems a bit odd. Mailing from the CL
works fine otherwise. I'm a bit stumped here. Details:

Mailman 2.0b5
FreeBSD 4.0-STABLE
Sendmail 8.9.3

Thanks for any help...

- H


Harold Paulson Sierra Web Design
haroldp at sierraweb.com http://www.sierraweb.com
VOICE: 775.833.9500 FAX: 810.314.1517

Search Discussions

  • Thomas T. Veldhouse at Sep 11, 2000 at 6:13 pm
    Were any of the emails greater than 50K in size?

    Tom Veldhouse
    veldy at veldy.net

    ----- Original Message -----
    From: Harold Paulson <haroldp at sierraweb.com>
    To: <mailman-users at python.org>
    Sent: Monday, September 11, 2000 1:09 PM
    Subject: [Mailman-Users] Mailman has stopped delivering mail

    Hi,

    having an ugly problem here. Mailman stopped delivering mail a
    couple days ago. When I post a message to a list, it seems to be
    accepted fine, but it never gets any farther. Looking in logs/smtp I
    see:

    Sep 11 04:50:54 2000 (61599) smtp for 1028 recips, completed in
    36473.001 seconds
    Sep 11 05:12:16 2000 (83902) smtp for 1 recips, completed in 0.407 seconds
    Sep 11 06:44:35 2000 (82886) All recipients refused: (451, 'timeout
    waiting for input during message collect')

    So it looks like it tried to send the message to the 1028 people on
    the list, but then in logs/smtp-failures I see:

    %grep '^Sep 11' smtp-failure | wc -l
    1028

    So every single email failed? Seems a bit odd. Mailing from the CL
    works fine otherwise. I'm a bit stumped here. Details:

    Mailman 2.0b5
    FreeBSD 4.0-STABLE
    Sendmail 8.9.3

    Thanks for any help...

    - H


    Harold Paulson Sierra Web Design
    haroldp at sierraweb.com http://www.sierraweb.com
    VOICE: 775.833.9500 FAX: 810.314.1517

    ------------------------------------------------------
    Mailman-Users maillist - Mailman-Users at python.org
    http://www.python.org/mailman/listinfo/mailman-users
  • Harold Paulson at Sep 11, 2000 at 6:45 pm
    checking qfiles...

    I have 300+ files in there, ONE of which has a large PDF attachment,
    over 300k (grr, have to beat that user). And interestingly enough,
    it was sent on the last day that Mailman successfully delivered
    anything.

    Tom Veldhouse suggested the following:
    You need to get rid of the large message in $MAILMAN/qfiles as well. Also,
    remove the locks in $MAILMAN/locks. Then kill the process. It will hang
    again when it comes across the queued mail if you don't do this.
    which seems to have things running again. Does anybody know where
    the problem is here? Mailman? Python? FreeBSD? Anyone have an actual
    solution?

    - H


    Harold Paulson Sierra Web Design
    haroldp at sierraweb.com http://www.sierraweb.com
    VOICE: 775.833.9500 FAX: 810.314.1517
  • William R. Dickson at Sep 11, 2000 at 6:56 pm

    On Mon, 11 Sep 2000, Harold Paulson wrote:

    which seems to have things running again. Does anybody know where
    the problem is here? Mailman? Python? FreeBSD? Anyone have an actual
    solution?
    I have yet to find a solution, but I only experience the problem on my
    FreeBSD server. My NetBSD server has no such difficulty. On the other
    hand, it also didn't happen until I upgraded to the latest Mailman beta.

    -Bill


    --
    William R. Dickson -- Consuming the Earth's limited resources since 1968
    wrd at awenet.com http://www.awenet.com/~wrd/ (PGP public key available)

    I've had a perfectly wonderful evening. But this wasn't it.

    -Groucho Marx
  • Dan Mick at Sep 11, 2000 at 8:30 pm
    Guys, it's sure sounding like the "socket.send() might not write full message"
    bug that someone just reported in the last few days, which is a Python bug on
    FreeBSD, is the source of the problem here... see the attached email

    "William R. Dickson" wrote:
    On Mon, 11 Sep 2000, Harold Paulson wrote:

    which seems to have things running again. Does anybody know where
    the problem is here? Mailman? Python? FreeBSD? Anyone have an actual
    solution?
    I have yet to find a solution, but I only experience the problem on my
    FreeBSD server. My NetBSD server has no such difficulty. On the other
    hand, it also didn't happen until I upgraded to the latest Mailman beta.

    -Bill

    --
    William R. Dickson -- Consuming the Earth's limited resources since 1968
    wrd at awenet.com http://www.awenet.com/~wrd/ (PGP public key available)

    I've had a perfectly wonderful evening. But this wasn't it.

    -Groucho Marx

    ------------------------------------------------------
    Mailman-Users maillist - Mailman-Users at python.org
    http://www.python.org/mailman/listinfo/mailman-users
    -------------- next part --------------
    An embedded message was scrubbed...
    From: Mark Lysek <mjl at squid.jpl.nasa.gov>
    Subject: Re: [Mailman-Users] Mailman/FreeBSD lockup
    Date: Fri, 08 Sep 2000 18:14:29 -0700
    Size: 5379
    Url: http://mail.python.org/pipermail/mailman-users/attachments/20000911/7e924efb/attachment.mht

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedSep 11, '00 at 6:09p
activeSep 11, '00 at 8:30p
posts5
users4
websitelist.org

People

Translate

site design / logo © 2022 Grokbase