FAQ
moin, moin,

I'm having trouble getting mailman to send messages to external hosts.
I've got qmail setup as the MTA. Non-list mail to and from the mailhost
works just fine. Incoming list mail from either remote or local hosts
works just fine. Outgoing list mail to the local host works fine. Outgoing
mail to an external host doesn't appear to leave any traces that it should
be ocurring, even though an external addy is subscribed. Also the sub
message didn't go to the external email addy and the external email addy
shows up both in the web page subbed list as well as in the list shown by
using the command line list_members utility. I don't see anything in the
syslog or mailman logs indicating that any attemp whatsoever was made to
send the mail to the external host.

Here's the syslog output from a piece of mail sent to the list:

Jun 19 02:28:11 dw qmail: 961406891.660407 new msg 98633
Jun 19 02:28:11 dw qmail: 961406891.661128 info msg 98633: bytes 473 from
<lufthans at somedomain.de> qp 23183 uid 503
Jun 19 02:28:11 dw qmail: 961406891.666936 starting delivery 20: msg 98633
to local probe at somedomain.de
Jun 19 02:28:11 dw qmail: 961406891.666999 status: local 1/10 remote 0/20
Jun 19 02:28:12 dw qmail: 961406892.083562 new msg 98634
Jun 19 02:28:12 dw qmail: 961406892.084285 info msg 98634: bytes 1057 from
<probe-admin at somedomain.de> qp 23191 uid 505
Jun 19 02:28:12 dw qmail: 961406892.091150 starting delivery 21: msg 98634
to local LuftHans at somedomain.de
Jun 19 02:28:12 dw qmail: 961406892.091213 status: local 2/10 remote 0/20
Jun 19 02:28:12 dw qmail: 961406892.124517 delivery
20: success: did_0+0+1/
Jun 19 02:28:12 dw qmail: 961406892.124626 status: local 1/10 remote 0/20
Jun 19 02:28:12 dw qmail: 961406892.124669 end msg 98633
Jun 19 02:28:12 dw qmail: 961406892.146717 delivery
21: success: did_0+0+1/
Jun 19 02:28:12 dw qmail: 961406892.146807 status: local 0/10 remote 0/20
Jun 19 02:28:12 dw qmail: 961406892.146849 end msg 98634

If the mail had originated from an external addy, the results would've
been the same. I've got the list setup to only allow posts from subbed
email addies, so by being able to post from my external address I think
that shows the address is subbed to the mailing list, but the address
doesn't get any mail from the list. Both subbed addies, e.g. the local one
getting mail and the external one not getting mail, have the same user
options.

The questions are then:

How do I get mailman and qmail to work together to also be able to send
mail to remote hosts?

How do I trace mail through the mailman system ( aside from having to
learn python next weekend ;-)?

If I get an answer to the 2nd question, I can further investigate the
first one with that knowledge :).

ciao,

der.hans
--
# der.hans at LuftHans.com home.pages.de/~lufthans/ www.Opnix.com
# The only way for a woman to change a man
# is if he's wearing Depends[TM] - der.hans

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-users @
categoriespython
postedJun 19, '00 at 10:25a
activeJun 19, '00 at 10:25a
posts1
users1
websitelist.org

1 user in discussion

Der.hans: 1 post

People

Translate

site design / logo © 2022 Grokbase