FAQ
Bugs item #1109325, was opened at 2005-01-25 13:44
Message generated for change (Tracker Item Submitted) made by Item Submitter
You can respond by visiting:
https://sourceforge.net/tracker/?funcÞtail&atid0103&aid09325&group_id3

Category: Web/CGI
Group: 2.0.x
Status: Open
Resolution: None
Priority: 5
Submitted By: Tim Smith (jallen13)
Assigned to: Nobody/Anonymous (nobody)
Summary: Bug with upgrading to Mailman 2.1.4 in SuSE 9.1

Initial Comment:
[NOTE: This is a "I did it!" story.. the fix is at the
bottom of this post :) )

Just wanted to make a report here about some problems I
had upgrading
Mailman from 2.1.3 to 2.1.4 using Yast Online Update
(YOU) in Suse 9.1
AMD64.

It broke my web-based GUI, and spit this error into my
apache error logs:

[Tue Jan 25 12:43:57 2005] [error] [client IPADDR]
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
[Tue Jan 25 12:43:57 2005] [error] [client IPADDR]
[----- Mailman
Version: 2.1.4 -----]
[Tue Jan 25 12:43:57 2005] [error] [client IPADDR
[----- Traceback ------]
[Tue Jan 25 12:43:57 2005] [error] [client IPADDR]
Traceback (most
recent call last):
[Tue Jan 25 12:43:57 2005] [error] [client IPADDR] File
"/usr/lib/mailman/scripts/driver", line 241, in ?
[Tue Jan 25 12:43:57 2005] [error] [client IPADDR]
run_main()
[Tue Jan 25 12:43:57 2005] [error] [client IPADDR] File
"/usr/lib/mailman/scripts/driver", line 69, in run_main
[Tue Jan 25 12:43:57 2005] [error] [client IPADDR]
import xml.sax.saxutils
[Tue Jan 25 12:43:57 2005] [error] [client IPADDR]
ImportError: No
module named xml.sax.saxutils
[Tue Jan 25 12:43:57 2005] [error] [client IPADDR]
[Mailman: low level
unrecoverable exception]

And the output of the Web browser going to the mailman
location gives
this error:

Bug in Mailman version 2.1.4

We're sorry, we hit a bug!

If you would like to help us identify the problem,
please email a copy
of this page to the webmaster for this site with a
description of what
happened. Thanks!
Traceback:

Content-type: text/html

We're sorry, we hit a bug!

Mailman experienced a very low level failure and could
not even generate a
useful traceback for you. Please report this to the
Mailman administrator at
this site.

---------------------------------------------------------------------

So, I googled around, and found that this error is
very common in
2.1.4 version. Just google for "Mailman Low level
failure" and you'll
get a lot of web pages like the one I just pasted, all
for 2.1.4.

I got some help from Don Burns from mailman-users
list, he told me all I need
to do is install python-xml. (Thanks Don!!)

So, I used the trusty YAST and searched for python-xml
and installed it.

Wham-Bam, it works.

I guess 2.1.4 version expects python-xml as a depends,
whereas the
earlier versions didn't care about that.

I wanted to document this so maybe it''ll come up
quicker for some
poor sucker like myself googling around for this answer :)

Cheers,

Tim Smith

----------------------------------------------------------------------

You can respond by visiting:
https://sourceforge.net/tracker/?funcÞtail&atid0103&aid09325&group_id3

Search Discussions

  • SourceForge.net at Jan 29, 2005 at 11:57 pm
    Bugs item #1109325, was opened at 2005-01-25 14:44
    Message generated for change (Comment added) made by bwarsaw
    You can respond by visiting:
    https://sourceforge.net/tracker/?funcÞtail&atid0103&aid09325&group_id3

    Category: Web/CGI
    Group: 2.0.x
    Status: Closed
    Resolution: Invalid
    Priority: 5
    Submitted By: Tim Smith (jallen13)
    Assigned to: Nobody/Anonymous (nobody)
    Summary: Bug with upgrading to Mailman 2.1.4 in SuSE 9.1

    Initial Comment:
    [NOTE: This is a "I did it!" story.. the fix is at the
    bottom of this post :) )

    Just wanted to make a report here about some problems I
    had upgrading
    Mailman from 2.1.3 to 2.1.4 using Yast Online Update
    (YOU) in Suse 9.1
    AMD64.

    It broke my web-based GUI, and spit this error into my
    apache error logs:

    [Tue Jan 25 12:43:57 2005] [error] [client IPADDR]
    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    [Tue Jan 25 12:43:57 2005] [error] [client IPADDR]
    [----- Mailman
    Version: 2.1.4 -----]
    [Tue Jan 25 12:43:57 2005] [error] [client IPADDR
    [----- Traceback ------]
    [Tue Jan 25 12:43:57 2005] [error] [client IPADDR]
    Traceback (most
    recent call last):
    [Tue Jan 25 12:43:57 2005] [error] [client IPADDR] File
    "/usr/lib/mailman/scripts/driver", line 241, in ?
    [Tue Jan 25 12:43:57 2005] [error] [client IPADDR]
    run_main()
    [Tue Jan 25 12:43:57 2005] [error] [client IPADDR] File
    "/usr/lib/mailman/scripts/driver", line 69, in run_main
    [Tue Jan 25 12:43:57 2005] [error] [client IPADDR]
    import xml.sax.saxutils
    [Tue Jan 25 12:43:57 2005] [error] [client IPADDR]
    ImportError: No
    module named xml.sax.saxutils
    [Tue Jan 25 12:43:57 2005] [error] [client IPADDR]
    [Mailman: low level
    unrecoverable exception]

    And the output of the Web browser going to the mailman
    location gives
    this error:

    Bug in Mailman version 2.1.4

    We're sorry, we hit a bug!

    If you would like to help us identify the problem,
    please email a copy
    of this page to the webmaster for this site with a
    description of what
    happened. Thanks!
    Traceback:

    Content-type: text/html

    We're sorry, we hit a bug!

    Mailman experienced a very low level failure and could
    not even generate a
    useful traceback for you. Please report this to the
    Mailman administrator at
    this site.

    ---------------------------------------------------------------------

    So, I googled around, and found that this error is
    very common in
    2.1.4 version. Just google for "Mailman Low level
    failure" and you'll
    get a lot of web pages like the one I just pasted, all
    for 2.1.4.

    I got some help from Don Burns from mailman-users
    list, he told me all I need
    to do is install python-xml. (Thanks Don!!)

    So, I used the trusty YAST and searched for python-xml
    and installed it.

    Wham-Bam, it works.

    I guess 2.1.4 version expects python-xml as a depends,
    whereas the
    earlier versions didn't care about that.

    I wanted to document this so maybe it''ll come up
    quicker for some
    poor sucker like myself googling around for this answer :)

    Cheers,

    Tim Smith

    ----------------------------------------------------------------------
    Comment By: Barry A. Warsaw (bwarsaw)
    Date: 2005-01-29 17:57

    Message:
    Logged In: YES
    user_id800

    This is really a problem with your Python installation since
    nothing in Mailman directly imports xml.sax.saxutils. But
    you knew that because your fix installed whatever bits of
    Python Suse didn't deem important enough to include by
    default <wink>.

    ----------------------------------------------------------------------

    You can respond by visiting:
    https://sourceforge.net/tracker/?funcÞtail&atid0103&aid09325&group_id3

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmailman-coders @
categoriespython
postedJan 25, '05 at 8:44p
activeJan 29, '05 at 11:57p
posts2
users1
websitelist.org

1 user in discussion

SourceForge.net: 2 posts

People

Translate

site design / logo © 2022 Grokbase