FAQ
============================================================================
POSTGRESQL BUG REPORT TEMPLATE
============================================================================


Your name : Mathijs Brands
Your email address : shrike@il.fontys.nl

Category : runtime: back-end
Severity : critical

Summary: Get a 'ERROR: nodeRead: Bad type 0'

System Configuration
--------------------
Operating System : Linux 2.2.7 (glibc 2.0/redhat 5.2 w/ patches)

PostgreSQL version : 6.5

Compiler used : gcc 2.7.2.3

Hardware:
---------
Linux bucephalus.dynip.com 2.2.7 #3 Sun Jun 20 09:26:47 CEST 1999 i686 unknown

Versions of other tools:
------------------------
flex 2.5.4, bison 1.25

--------------------------------------------------------------------------

Problem Description:
--------------------
After creating my database, I get the following error:
ERROR: nodeRead: Bad type 0

After that, I can still query the database, but I can't
do anything else with it anymore (dump, \d).

This is very reproducible and doesn't happen with
6.3.2.

--------------------------------------------------------------------------

Test Case:
----------
I have a couple of insert statements that cause this problem
every time. I can send a transcript, if you like.

--------------------------------------------------------------------------

Solution:
---------


--------------------------------------------------------------------------

Search Discussions

  • Thomas Lockhart at Jun 24, 1999 at 2:57 pm

    Problem Description:
    --------------------
    After creating my database, I get the following error:
    ERROR: nodeRead: Bad type 0
    Test Case:
    ----------
    I have a couple of insert statements that cause this problem
    every time. I can send a transcript, if you like.
    You will have to. We don't have enough details to make any guesses...

    - Thomas

    --
    Thomas Lockhart lockhart@alumni.caltech.edu
    South Pasadena, California
  • M.Brands at Jun 24, 1999 at 6:30 pm

    On Thu, Jun 24, 1999 at 02:58:45PM +0000, Thomas Lockhart allegedly wrote:
    Problem Description:
    --------------------
    After creating my database, I get the following error:
    ERROR: nodeRead: Bad type 0
    Test Case:
    ----------
    I have a couple of insert statements that cause this problem
    every time. I can send a transcript, if you like.
    You will have to. We don't have enough details to make any guesses...
    I also ran the same postgres version and insert script on a FreeBSD 3.2
    system. No problems. I guess I'll have to investigate further. I'll get
    back to you about this.

    Mathijs

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedJun 24, '99 at 2:41p
activeJun 24, '99 at 6:30p
posts3
users2
websitepostgresql.org
irc#postgresql

2 users in discussion

M.Brands: 2 posts Thomas Lockhart: 1 post

People

Translate

site design / logo © 2022 Grokbase