FAQ
I have just successfully compiled and installed version 6.4.2
on IRIX 6.2, using MIPSpro 7.2.1 compilers with SGI_ABI set
to -64. However, when I run initdb, I get the following:

We are initializing the database system with username postgres (uid=9998).
This user will own all the files and must also own the server process.

Creating Postgres database system directory /usr/local/pgsql/data/base

Creating template database in /usr/local/pgsql/data/base/template1
ERROR: create index: type for attribute 'attrelid' undefined
ERROR: create index: type for attribute 'attrelid' undefined
Quit - core dumped
initdb: could not create template database
initdb: cleaning up by wiping out /usr/local/pgsql/data/base/template1

I have read the IRIX specific FAQ, and followed all the patches for
Postgres 6.3. I ran configure --with-tcl. I was able to get initdb
to work when I compiled with -o32 and -n32.

Thanks for any help,

--Yu Cao

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedMar 6, '99 at 1:49a
activeMar 6, '99 at 1:49a
posts1
users1
websitepostgresql.org
irc#postgresql

1 user in discussion

Yu Cao: 1 post

People

Translate

site design / logo © 2022 Grokbase