Hello,

I am trying to install postgresql-8.2.1-1 on a VPS server (via Remote Desktop) with Windows Server 2003 (pack 1).

I use the postgresql-8.2.msi installer with:
- installation language = english
- national language support, PL/java, Development files selected
- install a service option checked with postgres user
- initialise database cluster option checked with port 5432, accept connection on all adresses not just localhost option checked, locale English UK, encoding Latin1 and superuser postgres
- PL/pgsql, PL/perl, PL/python selected
- Adminpack selected as contrib module.

I execute the installation as Administrator (usergroup Administrators).
I get the error " Failed to run initdb: 128! " with an error log that is empty.

Googling this error, I can see it is probably something to do with authorisations but I can't figure out what is wrong exactly.

Have you ever encountered this error message? How did you finally fix it?

Thanks a lot for your help.
Best regards,
Anthony


---------------------------------
Découvrez une nouvelle façon d'obtenir des réponses à toutes vos questions ! Profitez des connaissances, des opinions et des expériences des internautes sur Yahoo! Questions/Réponses.

Search Discussions

  • Magnus Hagander at Feb 1, 2007 at 2:01 pm

    On Thu, Feb 01, 2007 at 12:58:17PM +0100, anthony herve wrote:
    Hello,

    I am trying to install postgresql-8.2.1-1 on a VPS server (via Remote Desktop) with Windows Server 2003 (pack 1).
    What VPS technology is being used?

    Also, beware that there are known issues when installing from Terminal
    Services. Most of them are not current anymore, but there seems to be at
    least one problem still there. However, that usually shows a log.
    Anyway, make sure you try to install it from the console session (using
    mstsc /console and connecting to the RDP service)
    I use the postgresql-8.2.msi installer with:
    - installation language = english
    - national language support, PL/java, Development files selected
    - install a service option checked with postgres user
    - initialise database cluster option checked with port 5432, accept connection on all adresses not just localhost option checked, locale English UK, encoding Latin1 and superuser postgres
    - PL/pgsql, PL/perl, PL/python selected
    - Adminpack selected as contrib module.

    I execute the installation as Administrator (usergroup Administrators).
    I get the error " Failed to run initdb: 128! " with an error log that is empty.
    Unfortunatly, error 128 is a very "catch-all" like error :-(
    What you should try is to install it without initdb:ing (just uncheck
    the box), and then try to manually run the initdb command (don't forget
    to set your locale and encoding). If that also fails, it shuld at least
    be able to give you a better error message since it's not running under
    the limited environment in the Windows Installer executor.

    //Magnus

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedFeb 1, '07 at 12:05p
activeFeb 1, '07 at 2:01p
posts2
users2
websitepostgresql.org
irc#postgresql

2 users in discussion

Magnus Hagander: 1 post Anthony herve: 1 post

People

Translate

site design / logo © 2022 Grokbase