With each version 8.0.4 and 8.1.1, I have tried at different times to
install:

* on a clean machine with no folders or users previously created.
* on a machine with E:/Program Files/PostgreSQL created and the service user
created with permissions set to full control

I got the following message:

Failed to run initdb: 1!
Please see the logfile in "E:\Program Files\PostgreSQL\8.1\tmp\initdb.log

The log file:

creating directory E:/ProgramFiles/PostgreSQL/8.1/data/global ... initdb:
could not create directory "E:/Program Files": File exists
initdb: removing contents of data directory
"E:/Program Files/PostgreSQL/8.1/data"

The odd thing is that this log entry happens even when the PostgresSQL
folder was not present before the install program ran. What would cause the
install program to be able to create the PostgresSQL directory during one
step and then not be able to create other directories later?

Searching the archives, it appears that others have had this problem in the
past and it was a permissions problem, but as I stated before, I tried
creating the service account before the install and granting it full control
of the install dir and it still did not work.

Anyone have any ideas?

Thanks,
Kent
--
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.371 / Virus Database: 267.14.3/209 - Release Date: 12/21/2005

Search Discussions

  • Magnus Hagander at Dec 21, 2005 at 7:06 pm

    With each version 8.0.4 and 8.1.1, I have tried at different times to
    install:

    * on a clean machine with no folders or users previously created.
    * on a machine with E:/Program Files/PostgreSQL created and
    the service user created with permissions set to full control

    I got the following message:

    Failed to run initdb: 1!
    Please see the logfile in "E:\Program
    Files\PostgreSQL\8.1\tmp\initdb.log

    The log file:

    creating directory E:/ProgramFiles/PostgreSQL/8.1/data/global
    ... initdb:
    could not create directory "E:/Program Files": File exists
    initdb: removing contents of data directory "E:/Program
    Files/PostgreSQL/8.1/data"

    The odd thing is that this log entry happens even when the
    PostgresSQL folder was not present before the install program
    ran. What would cause the install program to be able to
    create the PostgresSQL directory during one step and then not
    be able to create other directories later?
    The first steps are run as your account, the step that fails runs as the
    service user.

    Searching the archives, it appears that others have had this
    problem in the past and it was a permissions problem, but as
    I stated before, I tried creating the service account before
    the install and granting it full control of the install dir
    and it still did not work.

    Anyone have any ideas?
    I've seen similar issues when there was a directory or file on the
    system called C:\Program, causing windows to get confused abotu the
    path. Any chance that's your case?

    //Magnus
  • Kent Morrison at Dec 21, 2005 at 7:23 pm
    Yes there is a c:\Program Files directory.

    I tried to install to e:\PostgreSQL and still got the same error.

    -----Original Message-----
    From: pgsql-ports-owner@postgresql.org
    On Behalf Of Magnus Hagander
    Sent: Wednesday, December 21, 2005 1:07 PM
    To: Kent Morrison; pgsql-ports@postgresql.org
    Subject: Re: [PORTS] Problem Installing on Windows 2000 Server

    With each version 8.0.4 and 8.1.1, I have tried at different times to
    install:

    * on a clean machine with no folders or users previously created.
    * on a machine with E:/Program Files/PostgreSQL created and
    the service user created with permissions set to full control

    I got the following message:

    Failed to run initdb: 1!
    Please see the logfile in "E:\Program
    Files\PostgreSQL\8.1\tmp\initdb.log

    The log file:

    creating directory E:/ProgramFiles/PostgreSQL/8.1/data/global
    ... initdb:
    could not create directory "E:/Program Files": File exists
    initdb: removing contents of data directory "E:/Program
    Files/PostgreSQL/8.1/data"

    The odd thing is that this log entry happens even when the
    PostgresSQL folder was not present before the install program
    ran. What would cause the install program to be able to
    create the PostgresSQL directory during one step and then not
    be able to create other directories later?
    The first steps are run as your account, the step that fails runs as the
    service user.

    Searching the archives, it appears that others have had this
    problem in the past and it was a permissions problem, but as
    I stated before, I tried creating the service account before
    the install and granting it full control of the install dir
    and it still did not work.

    Anyone have any ideas?
    I've seen similar issues when there was a directory or file on the
    system called C:\Program, causing windows to get confused abotu the
    path. Any chance that's your case?

    //Magnus

    ---------------------------(end of broadcast)---------------------------
    TIP 9: In versions below 8.0, the planner will ignore your desire to
    choose an index scan if your joining column's datatypes do not
    match

    --
    No virus found in this incoming message.
    Checked by AVG Free Edition.
    Version: 7.1.371 / Virus Database: 267.14.3/209 - Release Date: 12/21/2005

    --
    No virus found in this outgoing message.
    Checked by AVG Free Edition.
    Version: 7.1.371 / Virus Database: 267.14.3/209 - Release Date: 12/21/2005
  • Magnus Hagander at Dec 21, 2005 at 8:08 pm
    The question was for c:\program, not c:\program files. Buti f you get
    the same error for e.\postgresql, that's not the case.

    What permissons do you have on e:\ and e:\PostgreSQL when you try this?
    PLease dump the permissions during the break where the error message
    shows up so all permissions are exactly the way they are when the error
    msg shows up. Actually, please dump every directory from the root and
    down to the data directory.
    Dump the permissions using "cacls" (just type cacls e:\ etc).

    Also, please check if any of the directories have the readonly attribute
    set (either using the GUI or usnig the attrib command).

    //Magnus
    -----Original Message-----
    From: Kent Morrison
    Sent: Wednesday, December 21, 2005 8:23 PM
    To: Magnus Hagander; pgsql-ports@postgresql.org
    Subject: RE: [PORTS] Problem Installing on Windows 2000 Server

    Yes there is a c:\Program Files directory.

    I tried to install to e:\PostgreSQL and still got the same error.

    -----Original Message-----
    From: pgsql-ports-owner@postgresql.org
    On Behalf Of Magnus Hagander
    Sent: Wednesday, December 21, 2005 1:07 PM
    To: Kent Morrison; pgsql-ports@postgresql.org
    Subject: Re: [PORTS] Problem Installing on Windows 2000 Server

    With each version 8.0.4 and 8.1.1, I have tried at
    different times to
    install:

    * on a clean machine with no folders or users previously created.
    * on a machine with E:/Program Files/PostgreSQL created and the
    service user created with permissions set to full control

    I got the following message:

    Failed to run initdb: 1!
    Please see the logfile in "E:\Program
    Files\PostgreSQL\8.1\tmp\initdb.log

    The log file:

    creating directory E:/ProgramFiles/PostgreSQL/8.1/data/global
    ... initdb:
    could not create directory "E:/Program Files": File exists
    initdb: removing contents of data directory "E:/Program
    Files/PostgreSQL/8.1/data"

    The odd thing is that this log entry happens even when the
    PostgresSQL
    folder was not present before the install program ran. What would
    cause the install program to be able to create the PostgresSQL
    directory during one step and then not be able to create other
    directories later?
    The first steps are run as your account, the step that fails
    runs as the service user.

    Searching the archives, it appears that others have had
    this problem
    in the past and it was a permissions problem, but as I
    stated before,
    I tried creating the service account before the install and granting
    it full control of the install dir and it still did not work.

    Anyone have any ideas?
    I've seen similar issues when there was a directory or file
    on the system called C:\Program, causing windows to get
    confused abotu the path. Any chance that's your case?

    //Magnus

    ---------------------------(end of
    broadcast)---------------------------
    TIP 9: In versions below 8.0, the planner will ignore your desire to
    choose an index scan if your joining column's datatypes do not
    match

    --
    No virus found in this incoming message.
    Checked by AVG Free Edition.
    Version: 7.1.371 / Virus Database: 267.14.3/209 - Release
    Date: 12/21/2005

    --
    No virus found in this outgoing message.
    Checked by AVG Free Edition.
    Version: 7.1.371 / Virus Database: 267.14.3/209 - Release
    Date: 12/21/2005

  • Kent Morrison at Dec 21, 2005 at 9:12 pm
    OK. Here is the permissions dump:


    C:\Documents and Settings\D30047756>e:

    E:\>cacls e:\
    e:\ BUILTIN\Administrators:(OI)(CI)F
    DHP01064\D30047756:(OI)(CI)F
    DHP01064\delladmin:(OI)(CI)F
    DHP01064\IUSR_DELL350:(OI)(CI)C
    DHP01064\IWAM_DELL350:(OI)(CI)C
    DHP01064\mpiehota:(OI)(CI)F


    E:\>cacls e:\postgresql
    e:\PostgreSQL DHP01064\postgres:(OI)(CI)(DENY)(special access:)
    DELETE
    WRITE_DAC
    WRITE_OWNER
    FILE_WRITE_DATA
    FILE_APPEND_DATA
    FILE_WRITE_EA
    FILE_DELETE_CHILD
    FILE_WRITE_ATTRIBUTES

    <Account Domain not found>(OI)(CI)(DENY)(special access:)
    DELETE
    WRITE_DAC
    WRITE_OWNER
    FILE_WRITE_DATA
    FILE_APPEND_DATA
    FILE_WRITE_EA
    FILE_DELETE_CHILD
    FILE_WRITE_ATTRIBUTES

    <Account Domain not found>(OI)(CI)R
    DHP01064\postgres:(OI)(CI)R
    BUILTIN\Administrators:(OI)(CI)F
    DHP01064\D30047756:(OI)(CI)F
    DHP01064\delladmin:(OI)(CI)F
    DHP01064\IUSR_DELL350:(OI)(CI)C
    DHP01064\IWAM_DELL350:(OI)(CI)C
    DHP01064\mpiehota:(OI)(CI)F


    E:\>cacls e:\postgresql\data
    e:\postgresql\data BUILTIN\Administrators:(OI)(CI)F
    DHP01064\D30047756:(OI)(CI)F
    DHP01064\delladmin:(OI)(CI)F
    DHP01064\IUSR_DELL350:(OI)(CI)C
    DHP01064\IWAM_DELL350:(OI)(CI)C
    DHP01064\mpiehota:(OI)(CI)F
    <Account Domain not found>(OI)(CI)C
    DHP01064\postgres:(OI)(CI)C


    E:\>

    I checked the e:\postgresql and the e:\postgresql\data directories and
    neither had the readonly attrib set.

    Thanks for your help.

    Kent

    -----Original Message-----
    From: pgsql-ports-owner@postgresql.org
    On Behalf Of Magnus Hagander
    Sent: Wednesday, December 21, 2005 2:09 PM
    To: Kent Morrison; pgsql-ports@postgresql.org
    Subject: Re: [PORTS] Problem Installing on Windows 2000 Server


    The question was for c:\program, not c:\program files. Buti f you get
    the same error for e.\postgresql, that's not the case.

    What permissons do you have on e:\ and e:\PostgreSQL when you try this?
    PLease dump the permissions during the break where the error message
    shows up so all permissions are exactly the way they are when the error
    msg shows up. Actually, please dump every directory from the root and
    down to the data directory.
    Dump the permissions using "cacls" (just type cacls e:\ etc).

    Also, please check if any of the directories have the readonly attribute
    set (either using the GUI or usnig the attrib command).

    //Magnus
    -----Original Message-----
    From: Kent Morrison
    Sent: Wednesday, December 21, 2005 8:23 PM
    To: Magnus Hagander; pgsql-ports@postgresql.org
    Subject: RE: [PORTS] Problem Installing on Windows 2000 Server

    Yes there is a c:\Program Files directory.

    I tried to install to e:\PostgreSQL and still got the same error.

    -----Original Message-----
    From: pgsql-ports-owner@postgresql.org
    On Behalf Of Magnus Hagander
    Sent: Wednesday, December 21, 2005 1:07 PM
    To: Kent Morrison; pgsql-ports@postgresql.org
    Subject: Re: [PORTS] Problem Installing on Windows 2000 Server

    With each version 8.0.4 and 8.1.1, I have tried at
    different times to
    install:

    * on a clean machine with no folders or users previously created.
    * on a machine with E:/Program Files/PostgreSQL created and the
    service user created with permissions set to full control

    I got the following message:

    Failed to run initdb: 1!
    Please see the logfile in "E:\Program
    Files\PostgreSQL\8.1\tmp\initdb.log

    The log file:

    creating directory E:/ProgramFiles/PostgreSQL/8.1/data/global
    ... initdb:
    could not create directory "E:/Program Files": File exists
    initdb: removing contents of data directory "E:/Program
    Files/PostgreSQL/8.1/data"

    The odd thing is that this log entry happens even when the
    PostgresSQL
    folder was not present before the install program ran. What would
    cause the install program to be able to create the PostgresSQL
    directory during one step and then not be able to create other
    directories later?
    The first steps are run as your account, the step that fails
    runs as the service user.

    Searching the archives, it appears that others have had
    this problem
    in the past and it was a permissions problem, but as I
    stated before,
    I tried creating the service account before the install and granting
    it full control of the install dir and it still did not work.

    Anyone have any ideas?
    I've seen similar issues when there was a directory or file
    on the system called C:\Program, causing windows to get
    confused abotu the path. Any chance that's your case?

    //Magnus

    ---------------------------(end of
    broadcast)---------------------------
    TIP 9: In versions below 8.0, the planner will ignore your desire to
    choose an index scan if your joining column's datatypes do not
    match

    --
    No virus found in this incoming message.
    Checked by AVG Free Edition.
    Version: 7.1.371 / Virus Database: 267.14.3/209 - Release
    Date: 12/21/2005

    --
    No virus found in this outgoing message.
    Checked by AVG Free Edition.
    Version: 7.1.371 / Virus Database: 267.14.3/209 - Release
    Date: 12/21/2005

    ---------------------------(end of broadcast)---------------------------
    TIP 1: if posting/reading through Usenet, please send an appropriate
    subscribe-nomail command to majordomo@postgresql.org so that your
    message can get through to the mailing list cleanly

    --
    No virus found in this incoming message.
    Checked by AVG Free Edition.
    Version: 7.1.371 / Virus Database: 267.14.3/209 - Release Date: 12/21/2005

    --
    No virus found in this outgoing message.
    Checked by AVG Free Edition.
    Version: 7.1.371 / Virus Database: 267.14.3/209 - Release Date: 12/21/2005

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedDec 21, '05 at 5:46p
activeDec 21, '05 at 9:12p
posts5
users2
websitepostgresql.org
irc#postgresql

2 users in discussion

Kent Morrison: 3 posts Magnus Hagander: 2 posts

People

Translate

site design / logo © 2022 Grokbase