FAQ
Hi
I was trying to build a new base data type into postgres. i am
using 7.4.8 on debian. There is already an eg in src/tutorial which
gives code for intenal and external functions of a new type called
complex. I tried to create a shared library for the file complex.c
using "cc -fpic -c complex.c" and "cc -shared -o complex.so
complex.c". That gave me a lot of errors like the header files
"fmgr.h" and "postgres.h" did not exist. I did a "make" anyway.
After that I went into postgres and tried to
create the functions corresponding to the new type. It says the file
complex.so could not be found. So the shared library seems to have not
been created.
When I installed postgres-7.4.8 there was some error when I
gave "make install-all-headers", so I just did "make install". I think
the header files required for server side development are not there
due to that. I think they are still there in the include dir. How do I
use those header files when I make a shared library and compile. If
anybody has created datatypes and defined them please share your
experience.
Thank you
Moginraj

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedJul 27, '05 at 7:32a
activeJul 27, '05 at 7:32a
posts1
users1
websitepostgresql.org
irc#postgresql

1 user in discussion

Mogin Mohandas: 1 post

People

Translate

site design / logo © 2022 Grokbase