FAQ
while I am stalled, waiting on my SA to provide me with a "gmake", I'd
like to know where I can find the libreadline needed to "configure"
pgsql with readline support. Oddly enough (to me, a newbie) this didn't
fall out of the tarball along with the many other goodies.

Anybody have an idea where to find the lib support for readline?

thanks,

Ross

Search Discussions

  • Chris Browne at May 4, 2005 at 10:50 pm

    After a long battle with technology, RMohan@arbinet.com ("Mohan, Ross"), an earthling, wrote:
    while I am stalled, waiting on my SA to provide me with a "gmake", I'd
    like to know where I can find the libreadline needed to "configure"
    pgsql with readline support. Oddly enough (to me, a newbie) this didn't
    fall out of the tarball along with the many other goodies.

    Anybody have an idea where to find the lib support for readline?
    That falls out of the GNU Readline system, which must also be
    installed.

    It may be handy for you to know what sorts of things we have found
    useful to compile and install in addition to PostgreSQL on AIX:

    1. GNU readline 5.0
    2. zlib 1.2.1
    3. GNU Make 3.8.0
    4. m4 1.4
    5. GNU flex 2.5.4
    6. GNU Bison 1.875

    I can't warrant that that is all you'll ever need, but it will
    probably do for now...
    --
    select 'cbbrowne' || '@' || 'ntlug.org';
    http://linuxdatabases.info/info/
    Rules of the Evil Overlord #63. "Bulk trash will be disposed of in
    incinerators, not compactors. And they will be kept hot, with none of
    that nonsense about flames going through accessible tunnels at
    predictable intervals." <http://www.eviloverlord.com/>
  • Tom Lane at May 7, 2005 at 4:47 am

    Christopher Browne writes:
    It may be handy for you to know what sorts of things we have found
    useful to compile and install in addition to PostgreSQL on AIX:
    1. GNU readline 5.0
    2. zlib 1.2.1
    3. GNU Make 3.8.0
    4. m4 1.4
    5. GNU flex 2.5.4
    6. GNU Bison 1.875
    You definitely do need GNU make if you are going to compile Postgres,
    and you want to have readline and zlib if you want to build fully
    functional psql and pg_dump/pg_restore (respectively).

    In theory you should not need m4, flex, or bison to build Postgres
    from a distribution tarball (though you likely will need them to build
    from a CVS pull). A tarball should include all the derived files that
    you'd otherwise need these programs to build. If you've found otherwise
    please let us know ...

    regards, tom lane
  • Mohan, Ross at May 7, 2005 at 11:09 pm
    Status as of now:

    - Can do without flex/bison (because I am not pulling from CVS,ie)
    - Can ( theoretically ) do without readline and zlib via the
    --without flags, but agree that no practical implementation
    would want to do this
    --GNU Make 3.4.3 _seems_ to be working fine (my SA finds anything
    above 3.3.x "provocative"; I demurred.)

    -- Can build 32-bit executables -- but I don't want these.

    -- Can NOT build the 64-bit XCOFF executables I do want. (see
    the PS below for specifics )


    Have tried various combinations of:


    OBJECT_MODE=64
    -Xlinker -b64 -Xlinker -bbibtoc
    --enable-aix64

    If "GNU Make 3.80" will solve this, I'll fight that battle. But
    I suspect the problem is my limited understanding of 64bitAIX
    enviroments and possibly a bad OS build environment.



    Thanks for any thoughts on this,


    --Ross "--without-clue --enable-flail" Mohan



    p.s. some details

    #######################################################################################
    here is the error snippet from CONFIG.LOG:

    configure:2008: checking for C compiler default output
    configure:2011: gcc -Xlinker -b64 -Xlinker -bbigtoc conftest.c >&5
    Assembler:
    /tmp//ccTtf8Lf.s: line 9: Only .llong should be used for relocatable expressions.
    configure:2014: $? = 1
    configure: failed program was:
    #line 1985 "configure"
    #######################################################################################
    Here is gcc version:

    $gcc --version
    gcc (GCC) 3.4.3
    #######################################################################################
    Here is configure command line:

    ./configure --enable-aix64 --prefix=/u01/app/postgres/app --exec-prefix=/u01/app/postgres/app
    #######################################################################################
    Here are CC/LD flags:

    $set | grep FLAGS
    LDFLAGS='-Xlinker -b64 -Xlinker -bbigtoc'
    #######################################################################################






    -----Original Message-----
    From: pgsql-ports-owner@postgresql.org On Behalf Of Tom Lane
    Sent: Saturday, May 07, 2005 12:47 AM
    To: Christopher Browne
    Cc: pgsql-ports@postgresql.org
    Subject: Re: [PORTS] AIX5.2 compile for PG 8.0.2. -- novice installer


    Christopher Browne <cbbrowne@acm.org> writes:
    It may be handy for you to know what sorts of things we have found
    useful to compile and install in addition to PostgreSQL on AIX:
    1. GNU readline 5.0
    2. zlib 1.2.1
    3. GNU Make 3.8.0
    4. m4 1.4
    5. GNU flex 2.5.4
    6. GNU Bison 1.875
    You definitely do need GNU make if you are going to compile Postgres, and you want to have readline and zlib if you want to build fully functional psql and pg_dump/pg_restore (respectively).

    In theory you should not need m4, flex, or bison to build Postgres from a distribution tarball (though you likely will need them to build from a CVS pull). A tarball should include all the derived files that you'd otherwise need these programs to build. If you've found otherwise please let us know ...

    regards, tom lane

    ---------------------------(end of broadcast)---------------------------
    TIP 9: the planner will ignore your desire to choose an index scan if your
    joining column's datatypes do not match
  • Mohan, Ross at May 7, 2005 at 11:20 pm
    ( Correction for last mail: )

    Strike the GNUMake comment below. I was referring to GCC 3.4.3

    -----Original Message-----
    From: Mohan, Ross
    Sent: Saturday, May 07, 2005 7:09 PM
    To: 'Tom Lane'; Christopher Browne
    Cc: pgsql-ports@postgresql.org
    Subject: RE: [PORTS] AIX5.2 compile for PG 8.0.2. -- novice installer


    Status as of now:

    - Can do without flex/bison (because I am not pulling from CVS,ie)
    - Can ( theoretically ) do without readline and zlib via the
    --without flags, but agree that no practical implementation
    would want to do this
    --GNU Make 3.4.3 _seems_ to be working fine (my SA finds anything
    above 3.3.x "provocative"; I demurred.)

    -- Can build 32-bit executables -- but I don't want these.

    -- Can NOT build the 64-bit XCOFF executables I do want. (see
    the PS below for specifics )


    Have tried various combinations of:


    OBJECT_MODE=64
    -Xlinker -b64 -Xlinker -bbibtoc
    --enable-aix64

    If "GNU Make 3.80" will solve this, I'll fight that battle. But
    I suspect the problem is my limited understanding of 64bitAIX
    enviroments and possibly a bad OS build environment.



    Thanks for any thoughts on this,


    --Ross "--without-clue --enable-flail" Mohan



    p.s. some details

    #######################################################################################
    here is the error snippet from CONFIG.LOG:

    configure:2008: checking for C compiler default output
    configure:2011: gcc -Xlinker -b64 -Xlinker -bbigtoc conftest.c >&5
    Assembler:
    /tmp//ccTtf8Lf.s: line 9: Only .llong should be used for relocatable expressions.
    configure:2014: $? = 1
    configure: failed program was:
    #line 1985 "configure" #######################################################################################
    Here is gcc version:

    $gcc --version
    gcc (GCC) 3.4.3 #######################################################################################
    Here is configure command line:

    ./configure --enable-aix64 --prefix=/u01/app/postgres/app --exec-prefix=/u01/app/postgres/app
    #######################################################################################
    Here are CC/LD flags:

    $set | grep FLAGS
    LDFLAGS='-Xlinker -b64 -Xlinker -bbigtoc' #######################################################################################






    -----Original Message-----
    From: pgsql-ports-owner@postgresql.org On Behalf Of Tom Lane
    Sent: Saturday, May 07, 2005 12:47 AM
    To: Christopher Browne
    Cc: pgsql-ports@postgresql.org
    Subject: Re: [PORTS] AIX5.2 compile for PG 8.0.2. -- novice installer


    Christopher Browne <cbbrowne@acm.org> writes:
    It may be handy for you to know what sorts of things we have found
    useful to compile and install in addition to PostgreSQL on AIX:
    1. GNU readline 5.0
    2. zlib 1.2.1
    3. GNU Make 3.8.0
    4. m4 1.4
    5. GNU flex 2.5.4
    6. GNU Bison 1.875
    You definitely do need GNU make if you are going to compile Postgres, and you want to have readline and zlib if you want to build fully functional psql and pg_dump/pg_restore (respectively).

    In theory you should not need m4, flex, or bison to build Postgres from a distribution tarball (though you likely will need them to build from a CVS pull). A tarball should include all the derived files that you'd otherwise need these programs to build. If you've found otherwise please let us know ...

    regards, tom lane

    ---------------------------(end of broadcast)---------------------------
    TIP 9: the planner will ignore your desire to choose an index scan if your
    joining column's datatypes do not match

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedMay 4, '05 at 8:20p
activeMay 7, '05 at 11:20p
posts5
users3
websitepostgresql.org
irc#postgresql

People

Translate

site design / logo © 2022 Grokbase