FAQ
Hi,
I have just installed Solaris 10 and downloaded postgresql 8.0.1 using
the pkg-get tool.
I have also installed readline 5.0 with the same pk-get tool.
Then I tried ti initialize postgresql by executing initdb but the
follwoing error occured:

bash-3.00# ./initdb -D /usr/local/pgsql/data/
ld.so.1: ./initdb: fatal:
/usr/local/lib/libreadline.so/libreadline.so.4: Not a directory
Killed
bash-3.00#

Could someone please help me on this configuration issue ?

Search Discussions

  • Crisan Mircea at Apr 4, 2005 at 4:25 pm
    Thanks to Mark Round, the problem is solved. I just have to symlink
    /usr/local/lib/libreadline.so.5 to /usr/local/lib/libreadline.so.4 and
    it all seems to work.

    Mircea

    On Apr 2, 2005 3:13 PM, Crisan Mircea wrote:
    Hi,
    I have just installed Solaris 10 and downloaded postgresql 8.0.1 using
    the pkg-get tool.
    I have also installed readline 5.0 with the same pk-get tool.
    Then I tried ti initialize postgresql by executing initdb but the
    follwoing error occured:

    bash-3.00# ./initdb -D /usr/local/pgsql/data/
    ld.so.1: ./initdb: fatal:
    /usr/local/lib/libreadline.so/libreadline.so.4: Not a directory
    Killed
    bash-3.00#

    Could someone please help me on this configuration issue ?
  • Mark Round at Apr 11, 2005 at 8:00 am

    On Apr 4, 2005 5:25 PM, Crisan Mircea wrote:

    Thanks to Mark Round, the problem is solved. I just have to symlink
    /usr/local/lib/libreadline.so.5 to /usr/local/lib/libreadline.so.4 and
    it all seems to work.

    Um, thanks - but this isn't what I suggested doing :)

    While symlinking libraries for backwards compatibility reasons may work in
    the short term, it can open up a whole can of worms later on. It seems as
    though your version of PostgreSQL is linked to an older version of readline
    - the best option would be either to downgrade your version of readline
    (assuming nothing else on your system is making use of it), or obtain /
    build PostgreSQL linked to a newer version of readline.

    -Mark
  • Jose Luis Cocha at Apr 11, 2005 at 2:54 pm
    Necesito cambiar el codigo de caracteres porque no me salen
    correctamente los acentos y las letras ñ. Como puedo manejar esto tengo
    mucha informacion q sale como basura, Al cambiar el codigo de caracteres
    toda la informacion se corrige ??

    Saludos y Gracias


    José Luis Cocha
    Consultor de Sistemas
    Telf. 537-4498 / 96742279


    -----Mensaje original-----
    De: pgsql-ports-owner@postgresql.org
    En nombre de Crisan Mircea
    Enviado el: Lunes, 04 de Abril de 2005 11:25 a.m.
    Para: pgsql-ports@postgresql.org
    Asunto: Re: [PORTS] postgresql 8.0.1 on solaris 10


    Thanks to Mark Round, the problem is solved. I just have to symlink
    /usr/local/lib/libreadline.so.5 to /usr/local/lib/libreadline.so.4 and
    it all seems to work.

    Mircea

    On Apr 2, 2005 3:13 PM, Crisan Mircea wrote:
    Hi,
    I have just installed Solaris 10 and downloaded postgresql 8.0.1 using
    the pkg-get tool. I have also installed readline 5.0 with the same
    pk-get tool. Then I tried ti initialize postgresql by executing initdb
    but the follwoing error occured:

    bash-3.00# ./initdb -D /usr/local/pgsql/data/
    ld.so.1: ./initdb: fatal:
    /usr/local/lib/libreadline.so/libreadline.so.4: Not a directory Killed
    bash-3.00#

    Could someone please help me on this configuration issue ?
    ---------------------------(end of broadcast)---------------------------
    TIP 5: Have you checked our extensive FAQ?

    http://www.postgresql.org/docs/faq

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedApr 2, '05 at 10:14p
activeApr 11, '05 at 2:54p
posts4
users3
websitepostgresql.org
irc#postgresql

People

Translate

site design / logo © 2022 Grokbase