I'll be trying to install postgres 8.0b1/b4; when I make the config a
message appear:

"configure: error: readline library not found"

$ rpm -qa | grep readline
libreadline4-4.3-7mdk
libreadline4-devel-4.3-7mdk

Then I try;

$ ./configure --with-libraries=/lib --with-includes=/usr/include/readline
(where the libs are)

I read a message from Tom Lane talking about termcap, it's installed too.

The same problem occurs with zlib.

I fix it skipping both libs with

./configure --without-readline --without-zlib

but...

Alejandro

Search Discussions

  • Peter Eisentraut at Nov 21, 2004 at 2:05 pm

    Alejandro D. Burne wrote:
    "configure: error: readline library not found"

    $ rpm -qa | grep readline
    libreadline4-4.3-7mdk
    libreadline4-devel-4.3-7mdk
    Please check the config.log file. It should contain the error messages
    by the compiler or the linker that tell why readline could not be found
    or used properly.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedNov 15, '04 at 2:07p
activeNov 21, '04 at 2:05p
posts2
users2
websitepostgresql.org
irc#postgresql

People

Translate

site design / logo © 2022 Grokbase