FAQ
I'm trying to build Postgres on Solaris 7 with the system's Kerberos
4 support. Once I got past the configure thinking it needed -ldes
when it really needed -lcrypt things went pretty well until . . .
gcc -Wall -Wmissing-prototypes -Wmissing-declarations pg_dump.o
common.o pg_backup_archiver.o pg_backup_db.o pg_backup_custom.o
pg_backup_files.o pg_backup_null.o pg_backup_tar.o sprompt.o
dumputils.o ../../../src/backend/parser/keywords.o
-L../../../src/interfaces/libpq -lpq -L../../../src/port
-R/usr/local/lib -lkrb -lcrypt -lz -lreadline -ltermcap -lrt
-lresolv -lgen -lsocket -lnsl -ldl -lm -lpgport -o pg_dump
Undefined first referenced
symbol in file
krb_get_tf_fullname ../../../src/interfaces/libpq/libpq.so
ld: fatal: Symbol referencing errors. No output written to pg_dump
collect2: ld returned 1 exit status
gmake[3]: *** [pg_dump] Error 1
gmake[3]: Leaving directory `/usr/local/dist/postgresql-7.3.2/src/bin/pg_dump'
Now I can look in /usr/lib/libkrb.{a,so} and see that routine is
defined. I can see that -lkrb comes after -lpq. I've tried it with
LD_LIBRARY_PATH undefined and defined to /usr/lib:/usr/local/lib.
Same result.

Must be something obvious, but I don't see it.

Solaris 7, 64-bit, on an Ultra-1
gcc 2.95.3
Solaris linker and other tools (/usr/ccs/bin)
postgres 7.3.2
--
The opinions expressed in this message are mine,
not those of Caltech, JPL, NASA, or the US Government.
Henry.B.Hotz@jpl.nasa.gov, or hbhotz@oxy.edu

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedApr 15, '03 at 11:47p
activeApr 15, '03 at 11:47p
posts1
users1
websitepostgresql.org
irc#postgresql

1 user in discussion

Henry B. Hotz: 1 post

People

Translate

site design / logo © 2022 Grokbase