FAQ
Hi all,
Can anyone help me here? I installed perl 5.6.1 on a RaQ3 (with cobalt
libs) but GUI fails - PostgreSQL failed. Must have done something wrong.

I have tried to roll back to the original version of perl by doing this

Re-made the hard link in /usr/bin by:
ln -f perl5.00503 perl

The /usr/lib/perl5 now contains
drwxr-xr-x 29 root root 2048 Mar 7 12:24 5.00503
drwxr-xr-x 3 root root 1024 Mar 7 12:24 man
drwxr-xr-x 3 root root 1024 Mar 7 12:24 site_perl

These are the original sub dirs complete with the cobalt bits.

However on a reboot there are still no sites showing and postreSQL is
not running, even on a manual restart. It reports:
# /etc/rc.d/init.d/postgresql start
Setting up PostgreSQL: FATAL: StreamServerPort: bind() failed:
Permission denied
Is another postmaster already running on that port?
If not, remove socket node (/tmp/.s.PGSQL.5583) and retry.
/usr/bin/postmaster: cannot create UNIX stream port

Perl -v reports correctly as does Perl -V, c/w correct @INC paths
@INC:
/usr/lib/perl5/5.00503/i386-linux
/usr/lib/perl5/5.00503
/usr/lib/perl5/site_perl/5.005/i386-linux
/usr/lib/perl5/site_perl/5.005

BTW mySQL also doesn't work so I have one db driven site down.

Is there any where else I need to look? Please?

Regards,
_________________

David Craig
_________________

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedMar 13, '03 at 4:14p
activeMar 13, '03 at 4:14p
posts1
users1
websitepostgresql.org
irc#postgresql

1 user in discussion

David: 1 post

People

Translate

site design / logo © 2021 Grokbase