Dear Sir,
I have downloaded fallowing files from http://www.postgresql.org

1. mx-2.0.1-1.i386.rpm
2. postgresql-odbc-7.1.2-5PGDG.i386.rpm
3. postgresql-7.1.2-5PGDG.i386.rpm
4. postgresql-perl-7.1.2-5PGDG.i386.rpm
5. postgresql-contrib-7.1.2-5PGDG.i386.rpm
6. postgresql-python-7.1.2-5PGDG.i386.rpm
7. postgresql-devel-7.1.2-5PGDG.i386.rpm
8. postgresql-server-7.1.2-5PGDG.i386.rpm
9. postgresql-docs-7.1.2-5PGDG.i386.rpm
10. postgresql-tcl-7.1.2-5PGDG.i386.rpm
11. postgresql-jdbc-7.1.2-5PGDG.i386.rpm
12. postgresql-test-7.1.2-5PGDG.i386.rpm
13. postgresql-libs-7.1.2-5PGDG.i386.rpm
14. postgresql-tk-7.1.2-5PGDG.i386.rpm

and Tried to install on Red Hat Linux release 7.2 (Enigma) Kernel 2.4.7-10
on an i686, I got the fallowing Errors.


[root@majcompnew p7.2]# rpm -i postgresql-contrib-7.1.2-5PGDG.i386.rpm
error: failed dependencies:
postgresql = 7.1.2 is needed by postgresql-contrib-7.1.2-5PGDG
libcrypto.so.1 is needed by postgresql-contrib-7.1.2-5PGDG
libreadline.so.4.1 is needed by postgresql-contrib-7.1.2-5PGDG
libssl.so.1 is needed by postgresql-contrib-7.1.2-5PGDG

[root@majcompnew p7.2]# rpm -i postgresql-contrib-7.1.2-5PGDG.i386.rpm
error: failed dependencies:
postgresql = 7.1.2 is needed by postgresql-contrib-7.1.2-5PGDG
libcrypto.so.1 is needed by postgresql-contrib-7.1.2-5PGDG
libreadline.so.4.1 is needed by postgresql-contrib-7.1.2-5PGDG
libssl.so.1 is needed by postgresql-contrib-7.1.2-5PGDG

[root@majcompnew p7.2]# rpm -i postgresql-devel-7.1.2-5PGDG.i386.rpm
error: failed dependencies:
postgresql-libs = 7.1.2 is needed by postgresql-devel-7.1.2-5PGDG
libcrypto.so.1 is needed by postgresql-devel-7.1.2-5PGDG
libreadline.so.4.1 is needed by postgresql-devel-7.1.2-5PGDG
libssl.so.1 is needed by postgresql-devel-7.1.2-5PGDG

[root@majcompnew p7.2]# rpm -i postgresql-docs-7.1.2-5PGDG.i386.rpm
[root@majcompnew p7.2]# rpm -i postgresql-jdbc-7.1.2-5PGDG.i386.rpm

[root@majcompnew p7.2]# rpm -i postgresql-libs-7.1.2-5PGDG.i386.rpm
error: failed dependencies:
libcrypto.so.1 is needed by postgresql-libs-7.1.2-5PGDG
libssl.so.1 is needed by postgresql-libs-7.1.2-5PGDG

[root@majcompnew p7.2]# rpm -i postgresql-perl-7.1.2-5PGDG.i386.rpm
error: failed dependencies:
libcrypto.so.1 is needed by postgresql-perl-7.1.2-5PGDG
libssl.so.1 is needed by postgresql-perl-7.1.2-5PGDG

[root@majcompnew p7.2]# rpm -i postgresql-python-7.1.2-5PGDG.i386.rpm
error: failed dependencies:
libcrypto.so.1 is needed by postgresql-python-7.1.2-5PGDG
libssl.so.1 is needed by postgresql-python-7.1.2-5PGDG

[root@majcompnew p7.2]# rpm -i postgresql-server-7.1.2-5PGDG.i386.rpm
error: failed dependencies:
postgresql = 7.1.2 is needed by postgresql-server-7.1.2-5PGDG
libcrypto.so.1 is needed by postgresql-server-7.1.2-5PGDG
libreadline.so.4.1 is needed by postgresql-server-7.1.2-5PGDG
libssl.so.1 is needed by postgresql-server-7.1.2-5PGDG

[root@majcompnew p7.2]# rpm -i postgresql-tcl-7.1.2-5PGDG.i386.rpm
error: failed dependencies:
libcrypto.so.1 is needed by postgresql-tcl-7.1.2-5PGDG
libreadline.so.4.1 is needed by postgresql-tcl-7.1.2-5PGDG
libssl.so.1 is needed by postgresql-tcl-7.1.2-5PGDG

[root@majcompnew p7.2]# rpm -i postgresql-test-7.1.2-5PGDG.i386.rpm
error: failed dependencies:
postgresql = 7.1.2 is needed by postgresql-test-7.1.2-5PGDG

oot@majcompnew p7.2]# rpm -i postgresql-tk-7.1.2-5PGDG.i386.rpm
error: failed dependencies:
libcrypto.so.1 is needed by postgresql-tk-7.1.2-5PGDG
libpgtcl.so.2 is needed by postgresql-tk-7.1.2-5PGDG
libreadline.so.4.1 is needed by postgresql-tk-7.1.2-5PGDG
libssl.so.1 is needed by postgresql-tk-7.1.2-5PGDG

I would appreciate if you could provide me help in installing PostGreSQL on
Red Hat Linux release 7.2.

Thanks and Regards,
Sharanayya G M
Majoris Systems Pvt. Ltd.
Bangalore

Search Discussions

  • Lamar Owen at Jan 22, 2003 at 10:08 pm

    On Thursday 16 January 2003 07:58, Sharanayya G M wrote:
    [root@majcompnew p7.2]# rpm -i postgresql-contrib-7.1.2-5PGDG.i386.rpm
    error: failed dependencies:
    postgresql = 7.1.2 is needed by postgresql-contrib-7.1.2-5PGDG
    libcrypto.so.1 is needed by postgresql-contrib-7.1.2-5PGDG
    libreadline.so.4.1 is needed by postgresql-contrib-7.1.2-5PGDG
    libssl.so.1 is needed by postgresql-contrib-7.1.2-5PGDG

    You need to install all of these on one line. You also need to get OpenSSL
    and readline installed.
    --
    Lamar Owen
    WGCR Internet Radio
    1 Peter 4:11

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedJan 16, '03 at 1:01p
activeJan 22, '03 at 10:08p
posts2
users2
websitepostgresql.org
irc#postgresql

2 users in discussion

Lamar Owen: 1 post Sharanayya G M: 1 post

People

Translate

site design / logo © 2022 Grokbase