This is what I have done...

1.) Download the postgresql-7.1.3-posix.patch ("curl -O
http://members.blackbox.net/a/files/postgresql-7.1.3-posix.patch")
2). Download the postgresql-7.1.3.tar.gz source.
3.) expand the .tar.gz files
3.) cd into the resulting postgresql-7.1.3 directory
4.) do a "patch -p1 < ../postgresql-7.1.3-posix.patch"

When I do a configure including ‹with-perl the make falls over.
Without this attribute, make compiles fine...

I was curious if you could offer any assistance to have make successfully
compile with perl.

The last several relevant make lines are:

LD_RUN_PATH="" cc -o blib/arch/auto/plperl/plperl.bundle -bundle
-flat_namespace -undefined suppress plperl.o eloglvl.o SPI.o
/System/Library/Perl/darwin/auto/Opcode/Opcode.bundle
-L/System/Library/Perl/darwin/CORE -lperl
/usr/bin/ld: /System/Library/Perl/darwin/auto/Opcode/Opcode.bundle is input
for the dynamic link editor, is not relocatable by the static link editor
again
make[4]: *** [blib/arch/auto/plperl/plperl.bundle] Error 1
make[3]: *** [all] Error 2
make[2]: *** [all] Error 2
make[1]: *** [all] Error 2
make: *** [all] Error 2


Do I have to manually set LD_RUN_PATH?

I¹m guessing that the patch file requires some additions for the perl
interface, however I¹m a not a programmer and this is a bit beyond me..

Anyone care to help out here?


Raoul.

Search Discussions

  • Christopher C. Weis at Oct 22, 2001 at 4:37 pm
    I'm actually having quite a bit of trouble using the "--with-perl" option
    on linux. I keep getting a "can not find libperl" error, even though I
    compiled perl with a dynamic module and put it within the standard library
    path. It would seem that most of the Postgresql community is confused with
    what "--with-perl" actually does. I know I am. Sorry I wasn't much of
    help, but you may not be alone on this one. Best of luck.

    ~me


    Raoul Callaghan wrote:
    This is what I have done...

    1.) Download the postgresql-7.1.3-posix.patch ("curl -O
    http://members.blackbox.net/a/files/postgresql-7.1.3-posix.patch")
    2). Download the postgresql-7.1.3.tar.gz source.
    3.) expand the .tar.gz files
    3.) cd into the resulting postgresql-7.1.3 directory
    4.) do a "patch -p1 < ../postgresql-7.1.3-posix.patch"

    When I do a configure including ‹with-perl the make falls over.
    Without this attribute, make compiles fine...

    I was curious if you could offer any assistance to have make successfully
    compile with perl.

    The last several relevant make lines are:

    LD_RUN_PATH="" cc -o blib/arch/auto/plperl/plperl.bundle -bundle
    -flat_namespace -undefined suppress plperl.o eloglvl.o SPI.o
    /System/Library/Perl/darwin/auto/Opcode/Opcode.bundle
    -L/System/Library/Perl/darwin/CORE -lperl
    /usr/bin/ld: /System/Library/Perl/darwin/auto/Opcode/Opcode.bundle is
    input for the dynamic link editor, is not relocatable by the static link
    editor again
    make[4]: *** [blib/arch/auto/plperl/plperl.bundle] Error 1
    make[3]: *** [all] Error 2
    make[2]: *** [all] Error 2
    make[1]: *** [all] Error 2
    make: *** [all] Error 2


    Do I have to manually set LD_RUN_PATH?

    I¹m guessing that the patch file requires some additions for the perl
    interface, however I¹m a not a programmer and this is a bit beyond me..

    Anyone care to help out here?


    Raoul.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedOct 22, '01 at 4:37p
activeOct 22, '01 at 4:37p
posts2
users2
websitepostgresql.org
irc#postgresql

People

Translate

site design / logo © 2022 Grokbase