FAQ
Heya, just read the readme and it said to email you with problems.
I don't know if this is a real problem or not, but here goes.

I was trying to install phpPgAdmin, which uses the package php-pgsql.
phpPgAdmin complained that mod_pgsql or something like that wasn't working
in Apache. Upon further investigation, I found that it was looking for
/usr/lib/libpq.so, which used to be provided in older versions of this
package. I don't know if it was taken out of the rpm for good reason
or not, so I'm letting you know about it. Other than that, thanks for
a great package!

Jerry Seutter
jseutter@phoenixcan.com

Search Discussions

  • Lamar Owen at Aug 14, 2001 at 6:27 pm

    On Friday 10 August 2001 16:12, Jerry Seutter wrote:
    Heya, just read the readme and it said to email you with problems.
    I don't know if this is a real problem or not, but here goes.
    I was trying to install phpPgAdmin, which uses the package php-pgsql.
    phpPgAdmin complained that mod_pgsql or something like that wasn't working
    in Apache. Upon further investigation, I found that it was looking for
    /usr/lib/libpq.so, which used to be provided in older versions of this
    package. I don't know if it was taken out of the rpm for good reason
    or not, so I'm letting you know about it. Other than that, thanks for
    a great package!
    Hmmm.

    Install postgresql-devel. Late 7.1.2 RPMs moved libpq.so (the symlink) to
    the devel subpackage. The actual libpq shared object is named libpq.so.2.1,
    and the others are all symlinks to it.

    The program in question should be linked against libpq.so.2.1, not plain
    libpq.so. However, installation of the -devel package provides the symlink.

    Thanks to Trond, I now understand _why_ libpq.so (the symlink, not the actual
    shared object) belongs in the -devel subpackage -- but the other packages in
    question apparently are not following the 'normal' rules......

    Or you can symlink /usr/lib/libpq.so to /usr/lib/libpq.so.2
    --
    Lamar Owen
    WGCR Internet Radio
    1 Peter 4:11
  • Peter Eisentraut at Aug 14, 2001 at 10:11 pm

    Lamar Owen writes:

    The program in question should be linked against libpq.so.2.1, not plain
    libpq.so. However, installation of the -devel package provides the symlink.
    For an appropriate definition of "linked against". In any case, the
    dependency should be against 'libpq.so.2'.

    --
    Peter Eisentraut peter_e@gmx.net http://funkturm.homeip.net/~peter
  • Lamar Owen at Aug 17, 2001 at 1:36 am

    On Tuesday 14 August 2001 18:15, Peter Eisentraut wrote:
    Lamar Owen writes:
    The program in question should be linked against libpq.so.2.1, not plain
    libpq.so. However, installation of the -devel package provides the
    symlink.
    For an appropriate definition of "linked against". In any case, the
    dependency should be against 'libpq.so.2'.
    This is of course correct, to prevent minor version headaches.
    --
    Lamar Owen
    WGCR Internet Radio
    1 Peter 4:11

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedAug 14, '01 at 4:34p
activeAug 17, '01 at 1:36a
posts4
users3
websitepostgresql.org
irc#postgresql

People

Translate

site design / logo © 2022 Grokbase