FAQ
If PostgreSQL failed to compile on your computer or you found a bug that
is likely to be specific to one platform then please fill out this form
and e-mail it to pgsql-ports@postgresql.org.

To report any other bug, fill out the form below and e-mail it to
pgsql-bugs@postgresql.org.

If you not only found the problem but solved it and generated a patch
then e-mail it to pgsql-patches@postgresql.org instead. Please use the
command "diff -c" to generate the patch.

You may also enter a bug report at http://www.postgresql.org/ instead of
e-mail-ing this form.

============================================================================
POSTGRESQL BUG REPORT TEMPLATE
============================================================================


Your name : Joël Brogniart
Your email address : Joel.Brogniart@univ-lyon2.fr


System Configuration
---------------------
Architecture (example: Intel Pentium) : Apple iMac G3 400Mhz - Apple PowerBook G4 400 Mhz

Operating System (example: Linux 2.0.26 ELF) : Mac OS X 10.0.3

PostgreSQL version (example: PostgreSQL-7.1.1): PostgreSQL-7.1.1 - PostgreSQL-7.1.2

Compiler used (example: gcc 2.95.2) : cc 2.95.2


Please enter a FULL description of your problem:
------------------------------------------------
After having compiled, tested and installed PostgreSQL successfully a PHP 4.0.5 configure fails.




Please describe a way to repeat the problem. Please try to provide a
concise reproducible example, if at all possible:
----------------------------------------------------------------------
First configure, make, install PostgreSQL (full French description on <http://nte.univ-lyon2.fr/nte/ressources/fiches/mosx-postgresql-install.html>).

user% get ftp://ftp.fr.postgresql.org/pub/v7.1.2/postgresql-7.1.2.tar.gz
user% tar xzf postgresql-7.1.2.tar.gz
user% cd postgresql-7.1.2
user% ./configure --enable-locale --enable-multibyte=UNICODE --enable-unicode-conversion --enable-syslog
user% make
user% sudo make install

Then try to install PHP 4.0.5 with PostgreSQL support.

user% wget http://www.php.net/distributions/php-4.0.5.tar.gz
user% wget http://graphics.stepwise.com/Articles/Workbench/php-4.0.5-genif.sh
user% tar xzf php-4.0.5.tar.gz
user% cp php-4.0.5-genif.sh php-4.0.5/build/genif.sh
user% cd php-4.0.5
user% ./configure --with-xml --with-apxs=/usr/sbin/apxs --with-mysql=/usr/local/mysql --with-pgsql=/usr/local/pgsql --with-zlib=/usr/lib

Configure fails with a bad zlib error.

If you know how this problem might be fixed, list the solution below:
---------------------------------------------------------------------

I tried different PHP config option and I found that the problem where somewhere from libpq.a, so I used the following command and then configuration, compilation and installation of PHP worked.

user% sudo ranlib /usr/local/pgsql/lib/libpq.a

Best regards.

Joël Brogniart

Search Discussions

  • Leandro Medina at Jun 6, 2001 at 7:13 pm
    Hi,
    I'm porting pgsql for QNX RTP. Compiling is ok, but
    "/usr/local/pqsql/bin/initdb -D data" command fail for "core dump" in

    "VACUUM ANALYZE" | postgres -o/dev/null -O -F -Ddata template1 > /dev/null
    exit_nicely
    , into initdb script (line 635).

    Try to investigate but codes are very complex for my knowldges.

    Any idea.

    Thanks.

    Leandro Medina
    (Ingdesi Group - R&D)

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedJun 5, '01 at 7:16p
activeJun 6, '01 at 7:13p
posts2
users2
websitepostgresql.org
irc#postgresql

2 users in discussion

Leandro Medina: 1 post Joël Brogniart: 1 post

People

Translate

site design / logo © 2022 Grokbase