FAQ
Good day.

I have tried this on two RedHat 7.0 systems.

By default PG 7.0.2 is installed and working fine.
I can grab the PG 7.0.3-8 RPMs from the RedHat 7.1 install CDs and they
install with some errors; but work fine:

[root@foo /root]# rpm -Uvh postgresql-7.0.3-8.i386.rpm postgresql-server-7.0.3-8.i386.rpm postgresql-devel-7.0.3-8.i386.rpm
postgresql ##################################################
/sbin/ldconfig: Input file /usr/lib/libesd.so not found.

postgresql-server ##################################################
/sbin/ldconfig: Input file /usr/lib/libesd.so not found.

postgresql-devel ##################################################

[root@foo /root]# /etc/rc.d/init.d/postgresql start
[change to user postgres] createuser
[change to my own id] createdb
setup remote access and then I can connect fine from remote servers


However, every time I try to installed PG 7_1.1 I the server does not
work properly.

[root@arbeau /root]# rpm -Uvh postgresql-7_1-1_i386.rpm postgresql-server-7_1-1_i386.rpm postgresql-libs-7_1-1_i386.rpm postgresql-devel-7_1-1_i386.rpm
postgresql ##################################################
postgresql-server ##################################################
/sbin/ldconfig: Input file /usr/lib/libesd.so not found.

postgresql-libs ##################################################
/sbin/ldconfig: Input file /usr/lib/libesd.so not found.

postgresql-devel ##################################################

The install goes like this:
[root@arbeau /root]# /etc/rc.d/init.d/postgresql start
Checking postgresql installation: no database files found.
This database system will be initialized with username "postgres".
This user will own all the data files and must also own the server process.

Fixing permissions on existing directory /var/lib/pgsql/data
Creating directory /var/lib/pgsql/data/base
Creating directory /var/lib/pgsql/data/global
Creating directory /var/lib/pgsql/data/pg_xlog
Creating template1 database in /var/lib/pgsql/data/base/1
DEBUG: database system was shut down at 2001-05-28 06:44:40 EDT
DEBUG: CheckPoint record at (0, 8)
DEBUG: Redo record at (0, 8); Undo record at (0, 8); Shutdown TRUE
DEBUG: NextTransactionId: 514; NextOid: 16384
DEBUG: database system is in production state
Creating global relations in /var/lib/pgsql/data/global
DEBUG: database system was shut down at 2001-05-28 06:44:52 EDT
DEBUG: CheckPoint record at (0, 108)
DEBUG: Redo record at (0, 108); Undo record at (0, 0); Shutdown TRUE
DEBUG: NextTransactionId: 514; NextOid: 17199
DEBUG: database system is in production state
Initializing pg_shadow.
Enabling unlimited row width for system tables.
Creating system views.
Loading pg_description.
Setting lastsysoid.
Vacuuming database.
Copying template1 to template0.

Success. You can now start the database server using:
....

I edit the pg_hba.conf file to give a remote server access and the
remote server keeps getting refused access. The database works fine;
but I can't connect to it.
Even in a case where I'm on a non-networked maching; just accessing
Postgres locally it doesn't work -using DBI-Pg in both cases.

I uninstall it, rm the /var/lib/pgsql/data directory; install 7.0.3 the
same way and all is well.

Has anyone seen some examples of error handling in writing Perl scripts for DBI-Pg?
Currently if I have typo's [say an extra quote in an UPDATE] then Perl
core dumps, the web page stops getting painted at that point and there
are no logged errors.
Even though I use || die $dbh->errstr; after every database command;
the Perl core dumps more often than it prints an error message. When
it does print an error message it is meaningless. ie it may print "7"
and that is all.


Thanks

- Eric Praetzel

Search Discussions

  • Lamar Owen at May 29, 2001 at 6:34 pm

    On Tuesday 29 May 2001 14:02, Eric Praetzel wrote:
    I have tried this on two RedHat 7.0 systems.
    However, every time I try to installed PG 7_1.1 I the server does not
    work properly.
    Edit /var/lib/pgsql/data/postgresql.conf. You want to enable tcpip_sockets.
    The line that is now:
    #tcpip_socket = false
    should become
    tcpip_socket = true

    see

    file:/usr/share/doc/postgresql-7.1/html/runtime-config.html
    (or whichever version is installed) for more details.
    - --
    Lamar Owen
    WGCR Internet Radio
    1 Peter 4:11
  • Tom Lane at May 29, 2001 at 10:23 pm

    Eric Praetzel writes:
    I edit the pg_hba.conf file to give a remote server access and the
    remote server keeps getting refused access. The database works fine;
    but I can't connect to it.
    (a) did you remember -i switch for postmaster?

    (b) what shows up in the postmaster log?

    regards, tom lane
  • Lamar Owen at May 29, 2001 at 11:02 pm

    On Tuesday 29 May 2001 18:22, Tom Lane wrote:
    Eric Praetzel <praetzel@sca.uwaterloo.ca> writes:
    I edit the pg_hba.conf file to give a remote server access and the
    remote server keeps getting refused access. The database works fine;
    but I can't connect to it.
    (a) did you remember -i switch for postmaster?
    Setting tcpip_socket = true in postgresql.conf worked for him....

    Isn't it amazing that, even with a nifty configuration file available,
    PostgreSQL old hands still want to supply command line switches? :-)
    Especially for such a FAQ as this one?
    - --
    Lamar Owen
    WGCR Internet Radio
    1 Peter 4:11

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedMay 29, '01 at 5:53p
activeMay 29, '01 at 11:02p
posts4
users3
websitepostgresql.org
irc#postgresql

People

Translate

site design / logo © 2022 Grokbase