FAQ
Hello PostgreSQL,
I tried installing PostgreSQL following the instructions in the
FAQ_MSWIN then INSTALL files. ./configure produced:

configure: error: installation or configuration problem: C compiler
cannot create executables

All the downloads were made over the last 2 days so are the latest
versions with PostgreSQL being 7.1.1.

The site http://www.xemacs.freeserve.co.uk/ no longer has downloads of
utilities so I did not install anything from there.

The FAQ_MSWIN does not say you have to start cygwin and run the INSTALL
instructions in a cygwin window instead of a normal command line window
so that is one minor addition you could make in FAQ_MSWIN.

After I tried ./configure. I tried gmake and gmake was not found. I did
a search for gmake and the closest I could find was gm in cygwin. There
were no error messages during the cygwin install so I assume that is
100% ok.

What would cause the configure error message?

Where is gmake?

Peter

Search Discussions

  • Peter at May 11, 2001 at 1:19 pm
    Hello PostgreSQL,
    I found a way past the earlier problem and a new problem.

    cygipc installed in to /usr/local/bin so I moved cygipc to
    /cygwin/usr/local/bin.

    ./configure proceeded past the previous failure and produced
    configure: error: ./src/backend/port/tas/dummy.s File not found

    I did:
    touch backend/port/tas/dummy.s

    and ./configure ran to the end without visible error.

    The touch suggestion came from an error report for PostgreSQL 6.5.2.

    Peter

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedMay 11, '01 at 1:19p
activeMay 11, '01 at 1:19p
posts2
users1
websitepostgresql.org
irc#postgresql

1 user in discussion

Peter: 2 posts

People

Translate

site design / logo © 2022 Grokbase