FAQ

I had noticed in a previous post the following information:

NOTICE: Unrecognized variable client_encoding
It means you're running a MULTIBYTE-enabled psql (or more specifically
libpq) against a non-MULTIBYTE server. Perhaps you are invoking a copy
of libpq from an older installation that was compiled with different
configure options.
The notice is harmless enough, but you may want to get your client and
server into sync...

I'm running into the same error message & I'm not sure how I got my client
and server out of sync.

I did an install of 7.0.3 on a RedHat Linux 6.2 box that has had all
previous versions of postgreSQL removed.
When I configured it, I did ./configure --with-perl --with-odbc
--enable-syslog --enable-debug --enable-cassert . Since my database will
not need any multibyte characters, I specifically did not use
--enable-multibyte. My regression test went great, and after I edited the
system's sysctl.conf to set the shmall and shmmax, postmaster started up
like a trooper. I then did the quickie test of

$ createdb
$ psql
postgres=>SELECT datetime 'now';
postgres=>\q
$ destroydb

When I did the create and the destroy, I got the "Unrecognized variable
client_encoding" notice, so obviously I'm out of sync. The question is how
did I get that way?

I also tried recompiling with the multibyte enabled. This time I got an
error along the lines of : multibyte is not enabled.
Your installation may not have been successful.

Any suggestions?

Thanks.

Search Discussions

  • Thomas Lockhart at Mar 14, 2001 at 2:24 pm

    NOTICE: Unrecognized variable client_encoding
    I'm running into the same error message & I'm not sure how I got my client
    and server out of sync.
    I did an install of 7.0.3 on a RedHat Linux 6.2 box that has had all
    previous versions of postgreSQL removed.
    How do you know that you removed all previous versions? What do you get
    when you type

    which psql

    and does it match the one you installed from tarball?
    I also tried recompiling with the multibyte enabled. This time I got an
    error along the lines of : multibyte is not enabled.
    Your installation may not have been successful.
    Did you do a "make clean" before or after reconfiguring? If not, it did
    not actually rebuild from source code.

    - Thomas
  • Tom Lane at Mar 14, 2001 at 2:56 pm

    Allen.Kimberly@epamail.epa.gov writes:
    I did an install of 7.0.3 on a RedHat Linux 6.2 box that has had all
    previous versions of postgreSQL removed.
    You may *think* that all previous versions were removed, but there's
    clearly still a copy of a multibyte-enabled libpq.so hanging about
    somewhere, and it's getting invoked by those commands. Look through
    your PATH for unexpected copies of the PG executables (createdb, psql,
    etc) and look at your dynamic loader configuration to see what library
    directories are being searched for shared libraries. (You may well
    need to add something to /etc/ld.so.conf and/or re-run ldconfig, anyway,
    to make sure that the system knows about the new PG .so files.)

    regards, tom lane

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedMar 14, '01 at 1:15p
activeMar 14, '01 at 2:56p
posts3
users3
websitepostgresql.org
irc#postgresql

People

Translate

site design / logo © 2022 Grokbase