FAQ
Hi all,

after i've installed the cygipc 1.09-2 correct ./configue works (Thanks
to Les Schaffer).

Sysinfo:
Windows NT 4 SP4
cygwin 1.1.8
cygipc 1.09-2
PostgreSQL 7.0.3


But now make fails with the following error:

....
/usr/bin/install -c -m 444 ../include/commands/trigger.h \
/usr/local/pgsql/include/commands/trigger.h
make[1]: Leaving directory `/usr/src/postgresql-7.0.3/src/backend'
make -C interfaces install
make[1]: Entering directory `/usr/src/postgresql-7.0.3/src/interfaces'
make -C libpq install
make[2]: Entering directory
`/usr/src/postgresql-7.0.3/src/interfaces/libpq'
/usr/bin/install -c -m 444 libpq-fe.h
/usr/local/pgsql/include/libpq-fe.h
/usr/bin/install -c -m 444 libpq-int.h
/usr/local/pgsql/include/libpq-int.h
/usr/bin/install -c -m 444 pqexpbuffer.h
/usr/local/pgsql/include/pqexpbuffer.h
dlltool --export-all --output-def pq.def fe-auth.o fe-connect.o
fe-exec.o fe-mis
c.o fe-print.o fe-lobj.o pqexpbuffer.o dllist.o pqsignal.o
dllwrap -o pq.dll --dllname pq.dll --def pq.def fe-auth.o fe-connect.o
fe-exec.o
fe-misc.o fe-print.o fe-lobj.o pqexpbuffer.o dllist.o pqsignal.o
../../utils/
dllinit.o -L/usr/local/lib -L/usr/local/pgsql/lib -L../../backend
-lpostgres -l
cygipc -lcygwin -lcrypt -lkernel32 -lcrypt
/usr/local/pgsql/lib/libpostgres.a: file not recognized: File truncated
collect2: ld returned 1 exit status
dllwrap: gcc exited with status 1
make[2]: *** [libpq.a] Error 1
make[2]: Leaving directory
`/usr/src/postgresql-7.0.3/src/interfaces/libpq'
make[1]: *** [install] Error 2
make[1]: Leaving directory `/usr/src/postgresql-7.0.3/src/interfaces'
make: *** [install] Error 2

The file </usr/local/pgsql/lib/libpostgres.a> has a length of 0 Byte it
seems something is going wrong here.

Any ideas?

Thanx in advance

Andreas

Search Discussions

  • Les Schaffer at Mar 6, 2001 at 3:13 pm

    On Sun, 04 Mar 2001 00:52:47 +0100, Annett Maskow und Andreas Kühl wrote:


    The file </usr/local/pgsql/lib/libpostgres.a> has a length of 0 Byte it
    seems something is going wrong here.
    hmmm... why don't you delete libpostgresql.a and do a make and see
    what happens. mine built fine first time.

    les schaffer
  • Annett Maskow und Andreas Kühl at Mar 6, 2001 at 3:14 pm
    Hi Les,

    Les Schaffer schrieb:
    On Sun, 04 Mar 2001 00:52:47 +0100, Annett Maskow und Andreas Kühl
    wrote:
    The file </usr/local/pgsql/lib/libpostgres.a> has a length of 0 Byte it
    seems something is going wrong here.
    hmmm... why don't you delete libpostgresql.a and do a make and see
    what happens. mine built fine first time.
    i did it, but after i started make again the same thing happened.

    The reason for this problem was that my harddisk was full and everything
    works fine after i made some more space available and than calling <make
    clean> and again starting <make>.

    thanks a lot Andreas
    les schaffer

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedMar 6, '01 at 3:13p
activeMar 6, '01 at 3:14p
posts3
users2
websitepostgresql.org
irc#postgresql

People

Translate

site design / logo © 2022 Grokbase