Hello !

I succesfully compiled postgresql in cygwin, but when I try to use the
perl interface (Pg), both the version included in the source tree and
the newer version from CPAN, I obtain an error.

The compilation is OK, but when I use it (perl test.pl if installed,
make test if not), I obtain :

$ make test
PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib
-I/usr/lib/perl5/5.6.1/cy
gwin -I/usr/lib/perl5/5.6.1 test.pl
Can't load 'blib/arch/auto/Pg/Pg.dll' for module Pg: dlopen: Win32 error
126 at
/usr/lib/perl5/5.6.1/cygwin/DynaLoader.pm line 206.
at test.pl line 12
Compilation failed in require at test.pl line 12.
BEGIN failed--compilation aborted at test.pl line 12.
make: *** [test_dynamic] Error 255

I obtain the same error with DBD::Pg
I am using perl-5.6.1 from sources.redhat.com, but I obtain the same
error with older version.

Do you have any idea ?
Thanks a lot,
YAS

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedJan 18, '01 at 7:10p
activeJan 18, '01 at 7:10p
posts1
users1
websitepostgresql.org
irc#postgresql

1 user in discussion

Yaacov Akiba Slama: 1 post

People

Translate

site design / logo © 2022 Grokbase