Stupid question, but why not? If someone is going to install the latest and
greatest version of PostgreSQL why would it be unreasonable to expect them
to install the latest and greatest Cygwin also? As a comparative example, I
don't think it's unreasonable for major Linux distributions to require the
presence of GLIBC as opposed to the old crustly libc v5.x. And, I don't
think it's unreasonable for Microsoft to require the latest updates to their
shared libraries for use with Office 2000. What am I missing here? Maybe
I'm incorrectly equating the cygwin dll with a library, but that's certainly
my understanding.

Now if someone is using their PostgreSQL box as a development box then I
would assume that they would be using development versions. I don't think
many people are using PostgreSQL in a production environment and also using
that same production environment for cygwin development. IOW, I would hope
that "production" use of PostgreSQL was done on a "production" box and that
only the cygwin dll was necessary and not the whole cygwin programming
environment. In that case, I don't see what would be the big deal with
requiring/providing a newer version of cygwin and "breaking" compatability
with old versions.

Someone set me straight please ;-)

Fred Reimer
Eclipsys Corporation

-----Original Message-----
From: pgsql-ports-owner@hub.org On
Behalf Of Peter Eisentraut
Sent: Tuesday, October 17, 2000 1:13 PM
To: Jason Tishler
Cc: Bruce Momjian; Cygwin; pgsql-ports@postgresql.org
Subject: Re: [PORTS] [PATCH]: Building PostgreSQL 7.0.2 on Cygwin 1.1.4
(Take 2)


Jason Tishler writes:
I was under the impression that my patch was being hand merged into the
CVS since the tree has changed since 7.0.2.
I was under the impression that part of your patch was going to abandon
compatibility with Cygwin 1.0 and B20. We can't do that.

--
Peter Eisentraut peter_e@gmx.net http://yi.org/peter-e/

Search Discussions

  • Jason Tishler at Oct 18, 2000 at 3:56 pm
    Fred,
    On Tue, Oct 17, 2000 at 01:23:38PM -0400, Reimer, Fred wrote:
    Stupid question, but why not? If someone is going to install the latest and
    greatest version of PostgreSQL why would it be unreasonable to expect them
    to install the latest and greatest Cygwin also?
    I feel likewise but I do not have a (large) base of users/systems that are
    running Cygwin 1.0 or b20. Those who do will most likely feel otherwise.
    I would hope
    that "production" use of PostgreSQL was done on a "production" box and that
    only the cygwin dll was necessary and not the whole cygwin programming
    environment.
    You are correct, only the Cygwin DLL is needed.
    In that case, I don't see what would be the big deal with
    requiring/providing a newer version of cygwin and "breaking" compatability
    with old versions.
    Unfortunately, two different version of the Cygwin DLL can not coexist
    on the same system. So, if some app needs the b20 DLL and PostgreSQL
    needs the 1.1.4 DLL you are SOL.

    Jason

    --
    Jason Tishler
    Director, Software Engineering Phone: +1 (732) 264-8770 x235
    Dot Hill Systems Corporation Fax: +1 (732) 264-8798
    82 Bethany Road, Suite 7 Email: Jason.Tishler@dothill.com
    Hazlet, NJ 07730 USA WWW: http://www.dothill.com
  • Pete Forman at Oct 19, 2000 at 7:07 am

    Jason Tishler writes:
    Unfortunately, two different version of the Cygwin DLL can not
    coexist on the same system. So, if some app needs the b20 DLL and
    PostgreSQL needs the 1.1.4 DLL you are SOL.
    Why so? I have both B20.1 and 1.1.4 on my system at the moment. PATH
    determines which is used by any particular app. And as Earnie says,
    the 1.1.4 DLL should be good for older apps.
    --
    Pete Forman -./\.- Disclaimer: This post is originated
    Western Geophysical -./\.- by myself and does not represent
    pete.forman@westgeo.com -./\.- the opinion of Baker Hughes or
    http://www.crosswinds.net/~petef -./\.- its divisions.
  • Jason Tishler at Oct 19, 2000 at 1:28 pm
    Peter,
    On Thu, Oct 19, 2000 at 08:07:39AM +0100, Pete Forman wrote:
    Jason Tishler writes:
    Unfortunately, two different version of the Cygwin DLL can not
    coexist on the same system. So, if some app needs the b20 DLL and
    PostgreSQL needs the 1.1.4 DLL you are SOL.
    Why so? I have both B20.1 and 1.1.4 on my system at the moment. PATH
    determines which is used by any particular app. And as Earnie says,
    the 1.1.4 DLL should be good for older apps.
    I was wrong. I thought that b20.1 used cygwin.dll not cygwin1.dll --
    it's been a while since I used b20.1. I'm very glad to hear that older
    apps can use the 1.1.4 DLL too.

    BTW since you have b20.1, would you be willing to build and test my
    patched version of PostgreSQL 7.0.2?

    Thanks,
    Jason

    P.S. Thanks to Earnie for setting me straight.

    --
    Jason Tishler
    Director, Software Engineering Phone: +1 (732) 264-8770 x235
    Dot Hill Systems Corporation Fax: +1 (732) 264-8798
    82 Bethany Road, Suite 7 Email: Jason.Tishler@dothill.com
    Hazlet, NJ 07730 USA WWW: http://www.dothill.com
  • Pete Forman at Oct 26, 2000 at 11:51 am

    Jason Tishler writes:
    On Thu, Oct 19, 2000 at 08:07:39AM +0100, Pete Forman wrote:
    Jason Tishler writes:
    Unfortunately, two different version of the Cygwin DLL can not
    coexist on the same system. So, if some app needs the b20 DLL and
    PostgreSQL needs the 1.1.4 DLL you are SOL.
    > >
    Why so? I have both B20.1 and 1.1.4 on my system at the moment. PATH
    determines which is used by any particular app. And as Earnie says,
    the 1.1.4 DLL should be good for older apps.
    >
    I was wrong. I thought that b20.1 used cygwin.dll not cygwin1.dll --
    it's been a while since I used b20.1. I'm very glad to hear that older
    apps can use the 1.1.4 DLL too. >
    BTW since you have b20.1, would you be willing to build and test my
    patched version of PostgreSQL 7.0.2?
    That test is now done. The only tests that fail are those involving
    timezones.

    The build and test was not that smooth. Overall I'd recommend
    upgrading to Cygwin 1.1.4 or later rather than applying all the fixes
    needed for B20.1.

    I revised Jason's patches for two of the files. My attached patch is
    against the original 7.0.2 code. Jason's patch should be edited to
    remove the sections for backend/utils/error/elog.c and exc.c. His
    patch was posted to PORTS on Tue, 26 Sep 2000 15:21:46 -0400.

    This patch is for 7.0.2. I am sending a patch to do the same thing
    for 7.1 to the PATCHES mailing list. It works around the lack of
    sys_nerr on Cygwin B20.1 and BeOS. More details on pgsql-patches.
  • Earnie Boyd at Oct 18, 2000 at 5:05 pm

    --- Jason Tishler wrote:

    Unfortunately, two different version of the Cygwin DLL can not coexist
    on the same system. So, if some app needs the b20 DLL and PostgreSQL
    needs the 1.1.4 DLL you are SOL.
    Actually, it shouldn't matter and if it does it's a bug in Cygwin. Executables
    built with b20 should execute properly with the cygwin1.dll from 1.1.4. The
    developer creating new binaries will need all objects to be created with the
    current runtime.

    Cheers,

    =====
    Earnie Boyd
    mailto:earnie_boyd@yahoo.com

    --- <http://earniesystems.safeshopper.com> ---
    --- Cygwin: POSIX on Windows <http://gw32.freeyellow.com/> ---
    --- Minimalist GNU for Windows <http://www.mingw.org/> ---

    __________________________________________________
    Do You Yahoo!?
    Yahoo! Messenger - Talk while you surf! It's FREE.
    http://im.yahoo.com/

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedOct 18, '00 at 1:25a
activeOct 26, '00 at 11:51a
posts6
users4
websitepostgresql.org
irc#postgresql

People

Translate

site design / logo © 2022 Grokbase