FAQ
Hi,

I have just compiled the new 7.0 version on FreeBSD3.4.
The compilation was fine, but psql gives me this
error:

/usr/libexec/ld-elf.so.1: ../bin/psql: Undefined symbol "PQenv2encoding"

The 6.5.3 Version is running without any problems on this system
Any idea what's wrong here?

Thanks,
David.
--
Dr. David Bauer
GenProfile AG, Robert-Roessle-Str. 10, D-13125 Berlin, Germany
Tel:+49-30-94892165, Fax:+49-30-94892151

Search Discussions

  • The Hermit Hacker at May 28, 2000 at 4:13 pm

    On Sun, 28 May 2000, David Bauer wrote:

    Hi,

    I have just compiled the new 7.0 version on FreeBSD3.4.
    The compilation was fine, but psql gives me this
    error:

    /usr/libexec/ld-elf.so.1: ../bin/psql: Undefined symbol "PQenv2encoding"

    The 6.5.3 Version is running without any problems on this system
    Any idea what's wrong here?
    what does 'ldd ../bin/psql' show? do you have two different versions of
    libpq installed on that machine (ie. 6.5.3 and v7.0)? Is it picking up
    the wrong one?

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-ports @
categoriespostgresql
postedMay 28, '00 at 1:56p
activeMay 28, '00 at 4:13p
posts2
users2
websitepostgresql.org
irc#postgresql

2 users in discussion

The Hermit Hacker: 1 post David Bauer: 1 post

People

Translate

site design / logo © 2022 Grokbase