When we set ssl=on in postgres.conf the server doesn't restart at all. No
error message, no log. When we turn it off again it connects fine.
Postgres was installed with RedHat as a package so is there some manual
installation that needs to be done? Below is the version being used.



Version : 8.1.23

Release : 1.el5_6.1

Red Hat Enterprise Linux Server release 5.6 (Tikanga)





David Patricola | Senior Cold Fusion Developer | Web Applications & Services
Jefferson Information Technologies


Thomas Jefferson Universtiy | Philadelphia, PA | 215.503.1715 (Office)

Search Discussions

  • Tom Lane at Feb 25, 2011 at 5:10 am

    "David Patricola" <david.patricola@jefferson.edu> writes:
    When we set ssl=on in postgres.conf the server doesn't restart at all. No
    error message, no log. When we turn it off again it connects fine.
    Postgres was installed with RedHat as a package so is there some manual
    installation that needs to be done? Below is the version being used.
    If you just change that setting, and don't provide the required
    certificate and private key files, it's expected that the server would
    refuse to start. It definitely will complain about that though --- I
    think you're failing to look in the right log file. Did you check
    /var/lib/pgsql/pgstartup.log?

    See here for some hints about configuring SSL correctly:
    http://www.postgresql.org/docs/9.0/static/ssl-tcp.html

    regards, tom lane

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-novice @
categoriespostgresql
postedFeb 24, '11 at 7:15p
activeFeb 25, '11 at 5:10a
posts2
users2
websitepostgresql.org
irc#postgresql

2 users in discussion

David Patricola: 1 post Tom Lane: 1 post

People

Translate

site design / logo © 2022 Grokbase