I am using a BDE connection from a windows app I'm building to connect to Postgres 7.3.2 running on Redhat on a linux box.

When I attempt to Post the dataset which I have loaded with a very large 'text' string, I get the following error: Invalid Blob length.

The field on the table is a type 'text'. The string that I am loading to the database is about 4,000 ascii characters long. (not really that large).

Any ideas as to why I am getting this error? Is there a setting I need to change on the database?

Thanks for your help,
Derrick

Search Discussions

  • Jason Hihn at Sep 11, 2003 at 1:34 pm
    I think I've heard of this before... I don't know what BDE is, but I heard
    about a problem with ODBC and blobs over 500 bytes long. It came down to the
    ODBC driver of course. That was a year ago, I don't know if it ever got
    fixed.

    I hope that helps.
    -----Original Message-----
    From: pgsql-novice-owner@postgresql.org
    On Behalf Of Derrick Betts
    Sent: Wednesday, September 10, 2003 10:35 PM
    To: pgsql-novice@postgresql.org
    Subject: [NOVICE] Invalid Blob length


    I am using a BDE connection from a windows app I'm building to connect to
    Postgres 7.3.2 running on Redhat on a linux box.

    When I attempt to Post the dataset which I have loaded with a very large
    'text' string, I get the following error: Invalid Blob length.

    The field on the table is a type 'text'. The string that I am loading to
    the database is about 4,000 ascii characters long. (not really that large).

    Any ideas as to why I am getting this error? Is there a setting I need to
    change on the database?

    Thanks for your help,
    Derrick
  • Godshall Michael at Sep 11, 2003 at 2:27 pm
    I don't know about BDE but the ODBC driver for postgres limits large text to
    about 500 characters by default. That can be changed via the properties in
    the ODBC connection settings. Maybe BDE does something similiar. You might
    try searching the pgsql-odbc mailing list.

    -----Original Message-----
    From: Derrick Betts
    Sent: Wednesday, September 10, 2003 9:35 PM
    To: pgsql-novice@postgresql.org
    Subject: [NOVICE] Invalid Blob length


    I am using a BDE connection from a windows app I'm building to connect to
    Postgres 7.3.2 running on Redhat on a linux box.

    When I attempt to Post the dataset which I have loaded with a very large
    'text' string, I get the following error: Invalid Blob length.

    The field on the table is a type 'text'. The string that I am loading to
    the database is about 4,000 ascii characters long. (not really that large).

    Any ideas as to why I am getting this error? Is there a setting I need to
    change on the database?

    Thanks for your help,
    Derrick

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-novice @
categoriespostgresql
postedSep 11, '03 at 2:35a
activeSep 11, '03 at 2:27p
posts3
users3
websitepostgresql.org
irc#postgresql

People

Translate

site design / logo © 2022 Grokbase