FAQ
I have created a db WITH ENCODING = 'unicode'.
I have SET CLIENT_ENCODING TO 'unicode'.
Is there anything else I can set to force communication in unicode?

My problem is as follows: I'm making a client application which
functions entirely in unicode utf-8. However, when I write strings
containing accented characters, with INSERT to VARCHAR or TEXT
fields, these characters end up stored as garbage.

This can mean only two things (after narrowing down the problem for 2
days). either the client doesn't write the information to psql in
unicode, or psql (7.3.2) expects something else than unicode.

The support people from my programming environment assure me the
information is being sent as unicode.

That's why I would like to know for sure whether the settings
mentioned above are enough to make psql expect its incoming strings
as unicode. (Or whether there is a known bug around.)

Thanks,

Marc

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-novice @
categoriespostgresql
postedApr 29, '03 at 6:31p
activeApr 29, '03 at 6:31p
posts1
users1
websitepostgresql.org
irc#postgresql

1 user in discussion

M. Bastin: 1 post

People

Translate

site design / logo © 2022 Grokbase