I'm trying to setup PAM authentication for PostgreSQL. I compiled with PAM
and configured pg_hba.conf:
host test 10.3.62.251 255.255.255.255 pam

When I try to connect I get:
psql: FATAL 1: PAM authentication failed for user "postgres"

The log shows:
CheckPAMAuth: pam_authenticate failed: 'No account present for user'
FATAL 1: PAM authentication failed for user "postgres"

I've searched the archives and see this same question asked several times but
no replies.

I'm trying to set this up on HP/UX 11.00 using PostgreSQL 7.2.1.

Thanks
Richard

Search Discussions

  • Josh Berkus at Oct 9, 2002 at 8:27 pm
    Richard,
    I'm trying to setup PAM authentication for PostgreSQL. I compiled with PAM
    and configured pg_hba.conf:
    host test 10.3.62.251 255.255.255.255 pam

    When I try to connect I get:
    psql: FATAL 1: PAM authentication failed for user "postgres"

    The log shows:
    CheckPAMAuth: pam_authenticate failed: 'No account present for user'
    FATAL 1: PAM authentication failed for user "postgres"
    You need to set up a PAM module for Postgresql. I can't explain how to do
    this, though, especially on HP-UX; try consulting a Unix manual about
    configuring PAM.

    Also, are you certain that HP-UX uses PAM?

    --
    -Josh Berkus
    Aglio Database Solutions
    San Francisco

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-novice @
categoriespostgresql
postedOct 9, '02 at 8:11p
activeOct 9, '02 at 8:27p
posts2
users2
websitepostgresql.org
irc#postgresql

2 users in discussion

Richard Ray: 1 post Josh Berkus: 1 post

People

Translate

site design / logo © 2022 Grokbase