initdb using the latest HEAD (9.4dev) fails with:

[amit@centos64vm postgresql]$ initdb -D ~/dev/pgdata/
The files belonging to this database system will be owned by user "amit".
This user must also own the server process.

The database cluster will be initialized with locale "en_US.utf8".
The default database encoding has accordingly been set to "UTF8".
The default text search configuration will be set to "english".

Data page checksums are disabled.

fixing permissions on existing directory /home/amit/dev/pgdata ... ok
creating subdirectories ... ok
selecting default max_connections ... 100
selecting default shared_buffers ... 128MB
creating configuration files ... ok
creating template1 database in /home/amit/dev/pgdata/base/1 ... ok
initializing pg_authid ... ok
initializing dependencies ... TRAP: FailedAssertion("!(((bool) 0))",
File: "initsplan.c", Line: 308)
sh: line 1: 11358 Aborted (core dumped)
"/home/amit/dev/pginstall/bin/postgres" --single -F -O -c
search_path=pg_catalog -c exit_on_error=true template1 > /dev/null
child process exited with exit code 134
initdb: removing contents of data directory "/home/amit/dev/pgdata"

** Backtrace from the core dump:

(gdb) bt
#0 0x00000037bf8328a5 in raise (sig=6) at
#1 0x00000037bf834085 in abort () at abort.c:92
#2 0x000000000075aaad in ExceptionalCondition (conditionName=<value
optimized out>, errorType=<value optimized out>, fileName=<value
optimized out>,
     lineNumber=<value optimized out>) at assert.c:54
#3 0x0000000000611bbe in extract_lateral_references (root=0x13798b0)
at initsplan.c:308
#4 find_lateral_references (root=0x13798b0) at initsplan.c:282
#5 0x0000000000612a18 in query_planner (root=<value optimized out>,
tlist=0x1379c58, tuple_fraction=0, limit_tuples=-1,
     qp_callback=0x613580 <standard_qp_callback>,
qp_extra=0x7fff85f9ed70, cheapest_path=0x7fff85f9edb0,
sorted_path=0x7fff85f9eda8, num_groups=0x7fff85f9edc0)
     at planmain.c:174
#6 0x0000000000614791 in grouping_planner (root=<value optimized
out>, tuple_fraction=0) at planner.c:1233
#7 0x0000000000616a3e in subquery_planner (glob=0x1378d28,
parse=0x1378b30, parent_root=<value optimized out>,
hasRecursion=<value optimized out>,
     tuple_fraction=0, subroot=0x7fff85f9eec8) at planner.c:571
#8 0x0000000000616d95 in standard_planner (parse=0x1378b30,
cursorOptions=0, boundParams=0x0) at planner.c:209
#9 0x000000000068acb7 in pg_plan_query (querytree=<value optimized
out>, cursorOptions=<value optimized out>, boundParams=<value
optimized out>) at postgres.c:754
#10 0x000000000068ade4 in pg_plan_queries (querytrees=<value optimized
out>, cursorOptions=0, boundParams=0x0) at postgres.c:813
#11 0x000000000068b3dc in exec_simple_query (query_string=0x1377ee8
"DELETE FROM pg_depend;\n") at postgres.c:982
#12 0x000000000068c8f7 in PostgresMain (argc=<value optimized out>,
argv=<value optimized out>, dbname=0x12e8f50 "template1",
username=<value optimized out>)
     at postgres.c:3990
#13 0x00000000005d58c7 in main (argc=9, argv=0x12cd330) at main.c:192

Amit Langote

Search Discussions

  • Amit Langote at Aug 1, 2013 at 6:52 am
    Build using:
    CFLAGS="-g -O0" ./configure --with-pam --enable-cassert --enable-debug

    Amit Langote
  • Amit Langote at Aug 1, 2013 at 7:04 am

    On Thu, Aug 1, 2013 at 3:52 PM, Amit Langote wrote:
    Build using:
    CFLAGS="-g -O0" ./configure --with-pam --enable-cassert --enable-debug

    Amit Langote
    Umm, I guess I forgot to "make clean" before building with the latest
    HEAD. Now, I rebuilt after "make clean", it no longer gives me the
    FailedAssertion as reported before.

    Sorry about the noise!

    Amit Langote

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-hackers @
postedAug 1, '13 at 6:51a
activeAug 1, '13 at 7:04a

1 user in discussion

Amit Langote: 3 posts



site design / logo © 2021 Grokbase