FAQ
Hello,

I want to ask why is there a requirement for 5.8 version of Perl to compile
under windows?
In this page of the documentation
http://www.postgresql.org/docs/9.0/static/install-windows-full.html#AEN23848it
sais: "Note: version 5.8 is required".
I was able to compile PostgreSQL 9.0.4 using Active Perl 5.14 (only some
warnings but the build was successful).
Should I necessarily use 5.8?

Thank you

Search Discussions

  • Heikki Linnakangas at Jul 4, 2011 at 4:33 pm

    On 04.07.2011 19:30, Marios Vodas wrote:
    Hello,

    I want to ask why is there a requirement for 5.8 version of Perl to compile
    under windows?
    In this page of the documentation
    http://www.postgresql.org/docs/9.0/static/install-windows-full.html#AEN23848it
    sais: "Note: version 5.8 is required".
    I was able to compile PostgreSQL 9.0.4 using Active Perl 5.14 (only some
    warnings but the build was successful).
    Should I necessarily use 5.8?
    Surely that means 5.8 or later. Given that 5.8 is very old by now,
    perhaps we should just remove that sentence.

    --
    Heikki Linnakangas
    EnterpriseDB http://www.enterprisedb.com
  • Marios Vodas at Jul 4, 2011 at 4:40 pm
    Yes, or at least change it by adding "or later". It is confusing without
    it...
    Thank you for your response.
    On 4/7/2011 7:33 μμ, Heikki Linnakangas wrote:
    On 04.07.2011 19:30, Marios Vodas wrote:
    Hello,

    I want to ask why is there a requirement for 5.8 version of Perl to
    compile
    under windows?
    In this page of the documentation
    http://www.postgresql.org/docs/9.0/static/install-windows-full.html#AEN23848it

    sais: "Note: version 5.8 is required".
    I was able to compile PostgreSQL 9.0.4 using Active Perl 5.14 (only some
    warnings but the build was successful).
    Should I necessarily use 5.8?
    Surely that means 5.8 or later. Given that 5.8 is very old by now,
    perhaps we should just remove that sentence.
  • Heikki Linnakangas at Jul 4, 2011 at 7:45 pm

    On 04.07.2011 19:40, Marios Vodas wrote:
    On 4/7/2011 7:33 μμ, Heikki Linnakangas wrote:
    On 04.07.2011 19:30, Marios Vodas wrote:
    I want to ask why is there a requirement for 5.8 version of Perl to
    compile
    under windows?
    In this page of the documentation
    http://www.postgresql.org/docs/9.0/static/install-windows-full.html#AEN23848it

    sais: "Note: version 5.8 is required".
    I was able to compile PostgreSQL 9.0.4 using Active Perl 5.14 (only some
    warnings but the build was successful).
    Should I necessarily use 5.8?
    Surely that means 5.8 or later. Given that 5.8 is very old by now,
    perhaps we should just remove that sentence.
    Yes, or at least change it by adding "or later". It is confusing without
    it...
    Ok, I've fixed the docs to say "or later". I did it somewhat arbitrarily
    back to 8.3, as that's as far as "git cherry-pick" worked without conflicts.

    --
    Heikki Linnakangas
    EnterpriseDB http://www.enterprisedb.com

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-hackers @
categoriespostgresql
postedJul 4, '11 at 4:30p
activeJul 4, '11 at 7:45p
posts4
users2
websitepostgresql.org...
irc#postgresql

People

Translate

site design / logo © 2021 Grokbase