On Mon, Apr 4, 2011 at 6:24 PM, Simon Riggs wrote:
Avoid assuming there will be only 3 states for synchronous_commit.
Also avoid hardcoding the current default state by giving it the name
"on" and replace with a meaningful name that reflects its behaviour.
Coding only, no change in behaviour.
I think changing the test to > SYNCHRONOUS_COMMIT_OFF is an
improvement, but I don't particularly like the renaming portion of
this change - now the internal names don't match what the user types,
which seems less clear, and inconsistent with every other enum-type
GUC.

--
Robert Haas
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-hackers @
categoriespostgresql
postedApr 4, '11 at 11:10p
activeApr 4, '11 at 11:10p
posts1
users1
websitepostgresql.org...
irc#postgresql

1 user in discussion

Robert Haas: 1 post

People

Translate

site design / logo © 2022 Grokbase