FAQ
I just downloaded PostgreSQL 8.4 beta 2 and tried to restore my old database from version 8.3. I created a new database with the same name as my old one. Then when I tried to restore the old database I got the error posted below. I'm running Windows 7 RC. I realize that probably isn't supported yet, but I thought I'd write anyhow. Everything else seems to be working fine other than one error I got during install. It said the secondary logon service wasn't started. In Windows 7 that isn't on by default. Starting the service allowed installation to continue. Will I have to set that to automatic in order to have Postgre work after if I reboot? Is the error I got during restore something I need to be worried about? Thanks so much.


C:\Program Files\PostgreSQL\8.4-beta2\bin\pg_restore.exe --host localhost --port 5432 --username postgres --dbname "HoldemManager" --verbose "E:\back up\Poker\Holdem Manager backup\Holdem Manager database.backup"
pg_restore: connecting to database for restore
pg_restore: creating SCHEMA public
pg_restore: creating COMMENT SCHEMA public
pg_restore: creating PROCEDURAL LANGUAGE plpgsql
pg_restore: [archiver (db)] Error while PROCESSING TOC:
pg_restore: [archiver (db)] Error from TOC entry 422; 2612 16386 PROCEDURAL LANGUAGE plpgsql postgres
pg_restore: [archiver (db)] could not execute query: ERROR: language "plpgsql" already exists
Command was:
CREATE PROCEDURAL LANGUAGE plpgsql;

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-hackers @
categoriespostgresql
postedJun 1, '09 at 1:00a
activeJun 1, '09 at 1:00a
posts1
users1
websitepostgresql.org...
irc#postgresql

1 user in discussion

Brian Klish: 1 post

People

Translate

site design / logo © 2021 Grokbase