Hi all,

I'm compiling PostgreSQL 8.3.6 on AIX 5.3.0.0 with GCC 4.2.0 and it is working.

But, after message "All of PostgreSQL successfully made. Ready to
install.", when it starts regression test, some unexpected (?) occurs.

First I doing only a *make* and it is doing *make install* instead just "make"

Second, there is a "pg_regress" execution that fails trying to connect
in a pg instance that is not in there, is should (must?) be there?

The steps I'm following, with some cuts, is:

---
postgres@db01 $ uid=204(postgres) gid=1(staff)

postgres@db01 $ export CC="gcc"
postgres@db01 $ export CFLAGS="-maix64"
postgres@db01 $ export LDFLAGS="-maix64 -Wl,-bbigtoc"
postgres@db01 $ export OBJECT_MODE=64
postgres@db01 $ export AR="ar -X64"
postgres@db01 $ ./configure --enable-integer-datetimes
--prefix=/srv/postgresql/8.3.6
....
postgres@db01 $ make
...
...
gmake[1]: Leaving directory `/srv/postgresql/work/postgresql-8.3.6/config'
All of PostgreSQL successfully made. Ready to install.
...
...
gmake[3]: Leaving directory `/srv/postgresql/work/postgresql-8.3.6/contrib/spi'
rm -rf ./testtablespace
mkdir ./testtablespace
./pg_regress --temp-install=./tmp_check --top-builddir=../../..
--srcdir=/srv/postgresql/work/postgresql-8.3.6/src/test/regress
--temp-port=55432 --schedule=./parallel_schedule --multibyte=SQL_ASCII
--load-language=plpgsql
============== creating temporary installation ==============
============== initializing database system ==============
============== starting postmaster ==============
running on port 55432 with pid 348354
============== creating database "regression" ==============
CREATE DATABASE
ALTER DATABASE
============== installing plpgsql ==============
CREATE LANGUAGE
============== running regression test queries ==============
...
...
...
============== shutting down postmaster ==============
server stopped

=======================
All 114 tests passed.
=======================
...
...
...
gmake[3]: Leaving directory `/srv/postgresql/work/postgresql-8.3.6/contrib/spi'
rm -rf ./testtablespace
mkdir ./testtablespace
./pg_regress --psqldir=/srv/postgresql/8.3.6/bin
--schedule=./serial_schedule
--srcdir=/srv/postgresql/work/postgresql-8.3.6/src/test/regress
--multibyte=SQL_ASCII --load-language=plpgsql
(using postmaster on Unix socket, default port)
============== dropping database "regression" ==============
psql: could not connect to server: No such file or directory
Is the server running locally and accepting
connections on Unix domain socket "/tmp/.s.PGSQL.5432"?
command failed: "/srv/postgresql/8.3.6/bin/psql" -X -c "DROP DATABASE
IF EXISTS \"regression\"" "postgres"
gmake[2]: *** [installcheck] Error 2
gmake[2]: Leaving directory
`/srv/postgresql/work/postgresql-8.3.6/src/test/regress'
gmake[1]: *** [installcheck] Error 2
gmake[1]: Leaving directory `/srv/postgresql/work/postgresql-8.3.6/src/test'
gmake: *** [installcheck] Error 2
make: 1254-004 The error code from the last command is 2.
Stop.
---

I'm wrong in anything?

Thanks!
--
Dickson S. Guedes
-
mail/xmpp: guedes@guedesoft.net - skype: guediz
http://guedesoft.net - http://planeta.postgresql.org.br

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-hackers @
categoriespostgresql
postedFeb 12, '09 at 4:56p
activeFeb 12, '09 at 4:56p
posts1
users1
websitepostgresql.org...
irc#postgresql

1 user in discussion

Dickson S. Guedes: 1 post

People

Translate

site design / logo © 2021 Grokbase