I'm trying to build PostgreSQL 8.2.2 outside the ports system on a
FreeBSD 6.2 amd64 box. The databases/postgresql81-server port builds
8.1.7 just fine on the same box. My configure fails. I'm new to
FreeBSD so I expect I'm missing something pretty obvious. config.log
follows. Line 2212 is very odd since it appears to be giving gcc the
library prefix as a file name.


This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by PostgreSQL configure 8.2.2, which was
generated by GNU Autoconf 2.59. Invocation command line was

$ ./configure --prefix=/usr/local/pgsql822_sl126_amd64_FreeBSD62
--with-includes=/usr/local/include --with-libs=/usr/local/lib
--enable-thread-saftey --with-openssl --enable-debug CC=gcc CFLAGS=-O3
-funroll-loops -m64

## --------- ##
## Platform. ##
## --------- ##

hostname = ahammond.ecoffice.experclick.com
uname -m = amd64
uname -r = 6.2-RELEASE
uname -s = FreeBSD
uname -v = FreeBSD 6.2-RELEASE #0: Fri Jan 12 08:43:30 UTC 2007
root@portnoy.cse.buffalo.edu:/usr/obj/usr/src/sys/SMP

/usr/bin/uname -p = amd64
/bin/uname -X = unknown

/bin/arch = unknown
/usr/bin/arch -k = unknown
/usr/convex/getsysinfo = unknown
hostinfo = unknown
/bin/machine = unknown
/usr/bin/oslevel = unknown
/bin/universe = unknown

PATH: /sbin
PATH: /bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /usr/games
PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /usr/X11R6/bin
PATH: /home/ahammond/bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:1408: checking build system type
configure:1426: result: x86_64-unknown-freebsd6.2
configure:1434: checking host system type
configure:1448: result: x86_64-unknown-freebsd6.2
configure:1458: checking which template to use
configure:1558: result: freebsd
configure:1700: checking whether to build with 64-bit integer date/time support
configure:1732: result: no
configure:1739: checking whether NLS is wanted
configure:1774: result: no
configure:1782: checking for default port number
configure:1812: result: 5432
configure:2170: checking for C compiler version
configure:2173: gcc --version </dev/null >&5
gcc (GCC) 3.4.6 [FreeBSD] 20060305
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:2176: $? = 0
configure:2178: gcc -v </dev/null >&5
Using built-in specs.
Configured with: FreeBSD/amd64 system compiler
Thread model: posix
gcc version 3.4.6 [FreeBSD] 20060305
configure:2181: $? = 0
configure:2183: gcc -V </dev/null >&5
gcc: `-V' option must have argument
configure:2186: $? = 1
configure:2209: checking for C compiler default output file name
configure:2212: gcc -O3 -funroll-loops -m64 conftest.c /usr/local/lib >&5
/usr/local/lib: file not recognized: File format not recognized
configure:2215: $? = 1

Search Discussions

  • Andrew Dunstan at Feb 8, 2007 at 6:59 pm
    --enable-thread-saftey is surely misspelled.

    not sure about the rest.

    cheers

    andrew



    Andrew Hammond wrote:
    I'm trying to build PostgreSQL 8.2.2 outside the ports system on a
    FreeBSD 6.2 amd64 box. The databases/postgresql81-server port builds
    8.1.7 just fine on the same box. My configure fails. I'm new to
    FreeBSD so I expect I'm missing something pretty obvious. config.log
    follows. Line 2212 is very odd since it appears to be giving gcc the
    library prefix as a file name.


    This file contains any messages produced by compilers while
    running configure, to aid debugging if configure makes a mistake.

    It was created by PostgreSQL configure 8.2.2, which was
    generated by GNU Autoconf 2.59. Invocation command line was

    $ ./configure --prefix=/usr/local/pgsql822_sl126_amd64_FreeBSD62
    --with-includes=/usr/local/include --with-libs=/usr/local/lib
    --enable-thread-saftey --with-openssl --enable-debug CC=gcc CFLAGS=-O3
    -funroll-loops -m64
  • Alvaro Herrera at Feb 8, 2007 at 7:20 pm

    Andrew Hammond wrote:

    This file contains any messages produced by compilers while
    running configure, to aid debugging if configure makes a mistake.

    It was created by PostgreSQL configure 8.2.2, which was
    generated by GNU Autoconf 2.59. Invocation command line was

    $ ./configure --prefix=/usr/local/pgsql822_sl126_amd64_FreeBSD62
    --with-includes=/usr/local/include --with-libs=/usr/local/lib
    --enable-thread-saftey --with-openssl --enable-debug CC=gcc CFLAGS=-O3
    -funroll-loops -m64 [...]
    configure:2209: checking for C compiler default output file name
    configure:2212: gcc -O3 -funroll-loops -m64 conftest.c /usr/local/lib >&5
    /usr/local/lib: file not recognized: File format not recognized
    Strange. I tried the same args on 8.2.3, and that config.log extract
    shows this:

    configure:2209: checking for C compiler default output file name
    configure:2212: gcc -O3 -funroll-loops -m64 conftest.c >&5
    [works]

    Note no misplaced libs there. The configure args were

    ./configure --prefix=/tmp --with-includes=/usr/local/include --with-libs=/usr/local/lib --enable-thread-saftey --with-openssl --enable-debug CC=gcc CFLAGS="-O3 -funroll-loops -m64"
    (including the thread-saftey typo)

    I noticed that config.log has unquoted CFLAGS -- I'd say that's a bug,
    but maybe it's of no consequence.

    --
    Alvaro Herrera http://www.CommandPrompt.com/
    The PostgreSQL Company - Command Prompt, Inc.
  • Tom Lane at Feb 8, 2007 at 7:23 pm

    "Andrew Hammond" <andrew.george.hammond@gmail.com> writes:
    I'm trying to build PostgreSQL 8.2.2 outside the ports system on a
    FreeBSD 6.2 amd64 box.
    Note you *definitely* want 8.2.3 not 8.2.2.
    configure:2209: checking for C compiler default output file name
    configure:2212: gcc -O3 -funroll-loops -m64 conftest.c /usr/local/lib >&5
    /usr/local/lib: file not recognized: File format not recognized
    That's really strange. For reference, I get this:

    configure:2209: checking for C compiler default output file name
    configure:2212: gcc conftest.c >&5
    configure:2215: $? = 0
    configure:2261: result: a.out

    I thought it might be coming from your --with-libs switch somehow,
    but when I add that to my configure command it does not change this
    output at all. Is it possible you've got environment variables
    (like CFLAGS) that configure might be picking up?

    regards, tom lane
  • Alvaro Herrera at Feb 8, 2007 at 7:28 pm

    Tom Lane wrote:

    I thought it might be coming from your --with-libs switch somehow,
    but when I add that to my configure command it does not change this
    output at all. Is it possible you've got environment variables
    (like CFLAGS) that configure might be picking up?
    A stout I'll bet it's $LIBS

    --
    Alvaro Herrera http://www.CommandPrompt.com/
    PostgreSQL Replication, Consulting, Custom Development, 24x7 support
  • Andrew Hammond at Feb 8, 2007 at 7:36 pm

    On Feb 8, 11:28 am, alvhe...@commandprompt.com (Alvaro Herrera) wrote:
    Tom Lane wrote:
    I thought it might be coming from your --with-libs switch somehow,
    but when I add that to my configure command it does not change this
    output at all. Is it possible you've got environment variables
    (like CFLAGS) that configure might be picking up?
    A stout I'll bet it's $LIBS
    Bingo. I'll pay up next time I see you guys. Or you're welcome to drop
    by Santa Barbara area to collect.

    Andrew

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-hackers @
categoriespostgresql
postedFeb 8, '07 at 6:34p
activeFeb 8, '07 at 7:36p
posts6
users4
websitepostgresql.org...
irc#postgresql

People

Translate

site design / logo © 2022 Grokbase