I have the following in my postgresql.conf

custom_variable_classes = 'pljava'
pljava.classpath =
'C:\\Tada\\Workspace\\org.postgresql.pljava\\build\\pljava.jar'

It worked fine with 8.0.0beta2. The beta4 however, gives me the
following message:

FATAL: unrecognized configuration parameter "pljava.classpath"

What happened?

Regards,
Thomas Hallgren

Search Discussions

  • Tom Lane at Nov 11, 2004 at 11:45 pm

    Thomas Hallgren writes:
    What happened?
    I broke it :-(. Fix committed.

    regards, tom lane
  • Thomas Hallgren at Nov 12, 2004 at 12:00 am

    Tom Lane wrote:
    I broke it :-(. Fix committed.
    Thanks, that was quick. You fixed it before I managed to find it.

    Not that I'm in an extreme hurry, just curious. Are we using different
    CVS repositories with some latency in replication or something? I don't
    seem to get your fix yet.

    Regards,
    Thomas Hallgren
  • Bruce Momjian at Nov 12, 2004 at 4:02 am

    Thomas Hallgren wrote:
    Tom Lane wrote:
    I broke it :-(. Fix committed.
    Thanks, that was quick. You fixed it before I managed to find it.

    Not that I'm in an extreme hurry, just curious. Are we using different
    CVS repositories with some latency in replication or something? I don't
    seem to get your fix yet.
    Anonymous CVS has a lag. I think it is 1/2 hour or an hour.

    --
    Bruce Momjian | http://candle.pha.pa.us
    pgman@candle.pha.pa.us | (610) 359-1001
    + If your life is a hard drive, | 13 Roberts Road
    + Christ can be your backup. | Newtown Square, Pennsylvania 19073
  • Thomas Hallgren at Nov 11, 2004 at 11:48 pm

    Thomas Hallgren wrote:
    I have the following in my postgresql.conf

    custom_variable_classes = 'pljava'
    pljava.classpath =
    'C:\\Tada\\Workspace\\org.postgresql.pljava\\build\\pljava.jar'

    It worked fine with 8.0.0beta2. The beta4 however, gives me the
    following message:

    FATAL: unrecognized configuration parameter "pljava.classpath"

    What happened?
    Ah, I see what's wrong. It's in the guc_file.l

    Previously, the "custom_variable_classes" was *set* first of all
    variables. Now, it's moved first in the linked list and then *tested*
    first of all. Subsequent tests of custom variables will of course then
    fail since the custom_variable_classes has not been set.

    Perhaps this change could be reverted? Or perhaps someone has other
    preferences on implementation?

    Regards,
    Thomas Hallgren

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-hackers @
categoriespostgresql
postedNov 11, '04 at 11:15p
activeNov 12, '04 at 4:02a
posts5
users3
websitepostgresql.org...
irc#postgresql

People

Translate

site design / logo © 2021 Grokbase