FAQ
Saludos,

Me puse a modificar el shared_buffers de mi maquina y lo lleve a
(shared_buffers = 64MB) al intentar arrarcar el servicio del gestor de base
de datos me da un error que es el siguiente:

the request size or reconfigure the kernel with larger SHMMAX. To reduce
the request size (currently 72220672 bytes), reduce PostgreSQL's
shared_buffers parameter (currently 8192) and/or its max_connections
parameter (currently 103). If the request size is already small, it's
possible that it is less than your kernel's SHMMIN parameter, in which case
raising the request size or reconfiguring SHMMIN is called for. The
PostgreSQL documentation contains more information about shared memory
configuration.

He buscado en la web y hay varias opciones pero me gustaria saber por
ustedes cual es la mas optima


Atentamente,


Harold Onore

Search Discussions

  • Gilberto Castillo Martínez at May 9, 2011 at 1:49 pm
    El lun, 09-05-2011 a las 08:12 -0430, Harold Alexander Onore Harold
    escribió:
    Saludos,

    Me puse a modificar el shared_buffers de mi maquina y lo lleve a
    (shared_buffers = 64MB) al intentar arrarcar el servicio del gestor de
    base de datos me da un error que es el siguiente:

    the request size or reconfigure the kernel with larger SHMMAX. To
    reduce the request size (currently 72220672 bytes), reduce
    PostgreSQL's shared_buffers parameter (currently 8192) and/or its
    max_connections parameter (currently 103). If the request size is
    already small, it's possible that it is less than your kernel's SHMMIN
    parameter, in which case raising the request size or reconfiguring
    SHMMIN is called for. The PostgreSQL documentation contains more
    information about shared memory configuration.

    He buscado en la web y hay varias opciones pero me gustaria saber por
    ustedes cual es la mas optima
    Ese parámetro esta relacionado con work_mem por lo que debes tener
    cuidado en el valor que pone, por otra parte debes jugar con la Ram real
    de tu PC y el PostgreSQL que tienes instalado si es la versión de 32 o
    64.

    --
    Saludos,
    Gilberto Castillo
    Edificio Beijing. Miramar Trade Center. Etecsa.
    Miramar, La Habana.Cuba.
  • Jaime Casanova at May 9, 2011 at 2:05 pm

    2011/5/9 Harold Alexander Onore Harold <onoreharold@gmail.com>:
    Saludos,

    Me puse a modificar el shared_buffers de mi maquina  y lo lleve a
    (shared_buffers = 64MB) al intentar arrarcar el servicio del gestor de base
    de datos me da un error  que es el siguiente:

    the request size or reconfigure the kernel with larger SHMMAX.  To reduce
    the request size (currently 72220672 bytes), reduce PostgreSQL's
    shared_buffers parameter (currently 8192) and/or its max_connections
    parameter (currently 103).    If the request size is already small, it's
    possible that it is less than your kernel's SHMMIN parameter, in which case
    raising the request size or reconfiguring SHMMIN is called for.  The
    PostgreSQL documentation contains more information about shared memory
    configuration.
    La variable shmmax esta muy baja en el SO y debes aumentarla, lee aqui
    http://www.postgresql.org/docs/9.0/static/kernel-resources.html#SYSVIPC
    busca tu sistema operativo y sigue los pasos

    --
    Jaime Casanova         www.2ndQuadrant.com
    Professional PostgreSQL: Soporte y capacitación de PostgreSQL
  • Harold Alexander Onore Harold at May 9, 2011 at 2:43 pm
    Saludos,

    estoy trabajando con la version 8.4 de 64 bits
    El equipo tiene 16gb de ram
    el sistema operativo que estoy utilizando es Debian 6

    --
    Jaime Casanova www.2ndQuadrant.com
    Professional PostgreSQL: Soporte y capacitación de PostgreSQL
  • Álvaro Hernández Tortosa at May 9, 2011 at 2:48 pm
    Mon, May 09, 2011 at 10:12:42AM -0430, Harold Alexander Onore Harold escribió:
    Saludos,

    estoy trabajando con la version 8.4 de 64 bits
    El equipo tiene 16gb de ram
    el sistema operativo que estoy utilizando es Debian 6
    Con esa configuración no serían incluso absurdos valores de 4GB
    u 8GB para shared_buffers, pero depende de muchos otros factores, como
    ¿cuál es el tamaño de la bbdd? ¿Cabe en memoria o en una fracción de
    ella? ¿Cuántos clientes se van a conectar -muchos o pocos-? Las
    consultas, ¿son pequeñas y rápidas, o largas y complejas? Depende de
    muchos factores, lo mejor es ir haciendo pruebas de rendimiento sobre
    entorno real si es posible...

    Saludos,

    Álvaro


    --

    Álvaro Hernández Tortosa


    -----------
    NOSYS
    Networked Open SYStems
  • Gilberto Castillo Martínez at May 9, 2011 at 2:51 pm
    El lun, 09-05-2011 a las 10:12 -0430, Harold Alexander Onore Harold
    escribió:
    Saludos,

    estoy trabajando con la version 8.4 de 64 bits
    El equipo tiene 16gb de ram
    En teoría deberías utilizar 25% de la RAM, para empezar deber tratar de
    ajustar u valor a eso.
    el sistema operativo que estoy utilizando es Debian 6
    --
    Saludos,
    Gilberto Castillo
    Edificio Beijing. Miramar Trade Center. Etecsa.
    Miramar, La Habana.Cuba.
  • Harold Alexander Onore Harold at May 9, 2011 at 8:47 pm
    ya configure los otros parametros ahora me reclama solo por el SHMMIN

    If the request size is already small, it's possible that it is less than
    your kernel's SHMMIN parameter, y no encuentro como definirlo



    El 9 de mayo de 2011 10:18, Gilberto Castillo Martínez <
    gilberto.castillo@etecsa.cu> escribió:

    El lun, 09-05-2011 a las 10:12 -0430, Harold Alexander Onore Harold
    escribió:
    Saludos,

    estoy trabajando con la version 8.4 de 64 bits
    El equipo tiene 16gb de ram
    En teoría deberías utilizar 25% de la RAM, para empezar deber tratar de
    ajustar u valor a eso.
    el sistema operativo que estoy utilizando es Debian 6
    --
    Saludos,
    Gilberto Castillo
    Edificio Beijing. Miramar Trade Center. Etecsa.
    Miramar, La Habana.Cuba.

    ---
    This message was processed by Kaspersky Mail Gateway 5.6.28/RELEASE running
    at host imx3.etecsa.cu
    Visit our web-site: <http://www.kaspersky.com>, <http://www.viruslist.com>
  • Gilberto Castillo Martínez at May 9, 2011 at 9:01 pm
    El lun, 09-05-2011 a las 16:16 -0430, Harold Alexander Onore Harold
    escribió:
    ya configure los otros parametros ahora me reclama solo por el SHMMIN
    Buscarlo en sysctl.conf

    --
    Saludos,
    Gilberto Castillo
    Edificio Beijing. Miramar Trade Center. Etecsa.
    Miramar, La Habana.Cuba.
  • Harold Alexander Onore Harold at May 9, 2011 at 9:09 pm
    Amigo la agregue hay me dice

    kernel.shmmax = 67108864
    kernel.shmall = 16384
    error: "kernel.shmmin" is an unknown key



    El 9 de mayo de 2011 16:27, Gilberto Castillo Martínez <
    gilberto.castillo@etecsa.cu> escribió:

    El lun, 09-05-2011 a las 16:16 -0430, Harold Alexander Onore Harold
    escribió:
    ya configure los otros parametros ahora me reclama solo por el SHMMIN
    Buscarlo en sysctl.conf

    --
    Saludos,
    Gilberto Castillo
    Edificio Beijing. Miramar Trade Center. Etecsa.
    Miramar, La Habana.Cuba.

    ---
    This message was processed by Kaspersky Mail Gateway 5.6.28/RELEASE running
    at host imx2.etecsa.cu
    Visit our web-site: <http://www.kaspersky.com>, <http://www.viruslist.com>
  • Gilberto Castillo Martínez at May 9, 2011 at 9:13 pm
    El lun, 09-05-2011 a las 16:39 -0430, Harold Alexander Onore Harold
    escribió:
    Amigo la agregue hay me dice

    kernel.shmmax = 67108864
    kernel.shmall = 16384
    error: "kernel.shmmin" is an unknown key
    Te pide que definas
    kernel.shmmin = ?

    Ponerlo y ya.

    --
    Saludos,
    Gilberto Castillo
    Edificio Beijing. Miramar Trade Center. Etecsa.
    Miramar, La Habana.Cuba.
  • Harold Alexander Onore Harold at May 9, 2011 at 9:19 pm
    lo coloque por eso me da ese error en el archivo tengo lo siguiente:
    kernel.shmmax = 67108864
    kernel.shmall = 16384
    kernel.shmmin = 1





    El 9 de mayo de 2011 16:40, Gilberto Castillo Martínez <
    gilberto.castillo@etecsa.cu> escribió:

    El lun, 09-05-2011 a las 16:39 -0430, Harold Alexander Onore Harold
    escribió:
    Amigo la agregue hay me dice

    kernel.shmmax = 67108864
    kernel.shmall = 16384
    error: "kernel.shmmin" is an unknown key
    Te pide que definas
    kernel.shmmin = ?

    Ponerlo y ya.

    --
    Saludos,
    Gilberto Castillo
    Edificio Beijing. Miramar Trade Center. Etecsa.
    Miramar, La Habana.Cuba.

    ---
    This message was processed by Kaspersky Mail Gateway 5.6.28/RELEASE running
    at host imx3.etecsa.cu
    Visit our web-site: <http://www.kaspersky.com>, <http://www.viruslist.com>
  • Gilberto Castillo Martínez at May 9, 2011 at 9:25 pm
    El lun, 09-05-2011 a las 16:45 -0430, Harold Alexander Onore Harold
    escribió:
    lo coloque por eso me da ese error en el archivo tengo lo siguiente:
    kernel.shmmax = 67108864
    kernel.shmall = 16384
    kernel.shmmin = 1
    Creo que Jaime en su correo dejo en enlace de la documentación que dice
    como configurar esos parámetros según tus valores, darle una lectura.

    --
    Saludos,
    Gilberto Castillo
    Edificio Beijing. Miramar Trade Center. Etecsa.
    Miramar, La Habana.Cuba.
  • Rafael Martinez at May 9, 2011 at 9:36 pm

    On Mon, 2011-05-09 at 16:45 -0430, Harold Alexander Onore Harold wrote:
    lo coloque por eso me da ese error en el archivo tengo lo siguiente:
    kernel.shmmax = 67108864
    kernel.shmall = 16384
    kernel.shmmin = 1
    En este articulo tienes todo lo que necesitas sobre el tema:

    "Configurando los parametros del kernel para PostgreSQL"
    http://www.postgresql.org.es/node/229

    --
    Rafael Martinez Guerrero
    Center for Information Technology
    University of Oslo, Norway

    PGP Public Key: http://folk.uio.no/rafael/
  • Álvaro Hernández Tortosa at May 9, 2011 at 2:32 pm
    Mon, May 09, 2011 at 08:12:55AM -0430, Harold Alexander Onore Harold escribió:
    Saludos,

    Me puse a modificar el shared_buffers de mi maquina y lo lleve a
    (shared_buffers = 64MB) al intentar arrarcar el servicio del gestor de base
    de datos me da un error que es el siguiente:

    the request size or reconfigure the kernel with larger SHMMAX. To reduce
    the request size (currently 72220672 bytes), reduce PostgreSQL's
    shared_buffers parameter (currently 8192) and/or its max_connections
    Hola.

    Independientemente del valor de shared_buffers de 64MB que sea
    conveniente o no para tu escenario (depende de la RAM y del tipo de base
    de datos, carga, etc que tengas), el problema es que el propio kernel no
    permite reservar un espacio de memoria compartida de dicho tamaño.

    Cómo ampliarlo depende del sistema operativo, pero si fuera un
    Linux necesitarás algo similar a:

    sysctl -w kernel.shmmax= <valor>

    donde valor sea una cantidad en bytes superior a los 64MB que solicitas
    (como por ejemplo 134217728).

    Hay mucha más información en la documentación de PostgreSQL:

    http://www.postgresql.org/docs/9.0/interactive/kernel-resources.html

    Saludos,

    Álvaro


    --

    Álvaro Hernández Tortosa


    -----------
    NOSYS
    Networked Open SYStems
  • Alvaro Herrera at May 9, 2011 at 9:34 pm

    Excerpts from Harold Alexander Onore Harold's message of lun may 09 08:42:55 -0400 2011:
    Saludos,

    Me puse a modificar el shared_buffers de mi maquina y lo lleve a
    (shared_buffers = 64MB) al intentar arrarcar el servicio del gestor de base
    de datos me da un error que es el siguiente:

    the request size or reconfigure the kernel with larger SHMMAX. To reduce
    the request size (currently 72220672 bytes), reduce PostgreSQL's
    shared_buffers parameter (currently 8192) and/or its max_connections
    parameter (currently 103). If the request size is already small, it's
    possible that it is less than your kernel's SHMMIN parameter, in which case
    raising the request size or reconfiguring SHMMIN is called for. The
    PostgreSQL documentation contains more information about shared memory
    configuration.
    Este no es el mensaje de error. Esto es solo el HINT. Un par de líneas
    más arriba debería estar el verdadero mensaje de error, que es una línea
    que empieza con "ERROR: ". Pega eso para diagnosticar correctamente el
    problema.

    --
    Álvaro Herrera <alvherre@alvh.no-ip.org>

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-es-ayuda @
categoriespostgresql
postedMay 9, '11 at 12:43p
activeMay 9, '11 at 9:36p
posts15
users6
websitepostgresql.org.es
irc#postgresql

People

Translate

site design / logo © 2022 Grokbase